User avatar
CopterRichie
Posts: 131
Joined: Tue Mar 26, 2013 3:14 am
Location: Los Angeles CA.

Omxplayer & raspivid

Wed Feb 12, 2014 2:32 pm

Please help me out here, I am having a very hard time understanding why I am not able to play a stream from Raspberry Pi#1 using raspivid and Raspberry Pi#2 using omxplayer.

On Raspberry #1

Code: Select all

raspivid -t 0 -w 640 -h 480 -o - | nc 192.168.1.10 5001
Raspberry #2

I have tried all of the variances listed there: http://elinux.org/Omxplayer including

Code: Select all

nc -l -k 5001 | omxplayer - 
nc -l -k 5001 | omxplayer /dev/stdin 
Thank you.

ethanol100
Posts: 581
Joined: Wed Oct 02, 2013 12:28 pm

Re: Omxplayer & raspivid

Wed Feb 12, 2014 4:00 pm

You can try a fifo? Similar to:
To view the feed on a Raspberry Pi:

Find your IP address by running ifconfig. (Your IP address will be listed in the console output and will probably be of the form 192.168.1.XXX).

Run the following commands in a terminal on the receiving Pi:

mkfifo buffer

nc -p 5001 -l > buffer | /opt/vc/src/hello_pi/hello_video/hello_video.bin buffer
...
from http://www.raspberrypi.org/camera

And you need first to start the listening command on the receiver, before you can pipe the video from the sender.

User avatar
CopterRichie
Posts: 131
Joined: Tue Mar 26, 2013 3:14 am
Location: Los Angeles CA.

Re: Omxplayer & raspivid

Wed Feb 12, 2014 4:04 pm

Thank you.

User avatar
Marcos.Scholl
Posts: 31
Joined: Wed Feb 05, 2014 7:12 pm
Location: Brasil

Re: Omxplayer & raspivid

Wed Feb 12, 2014 9:13 pm

CopterRichie wrote:Thank you.
Friend, managed to stream Pi for Pi with a good resolution and the video not slow and crashing?

I'm trying this, was using Mplayer , but is extremely slow . I would be grateful if you could help me , since it seems to be doing the same thing!

Which codes of Transmitter and receiver you used for its proper functioning ?
Thank you.

User avatar
CopterRichie
Posts: 131
Joined: Tue Mar 26, 2013 3:14 am
Location: Los Angeles CA.

Re: Omxplayer & raspivid

Wed Feb 12, 2014 9:20 pm

Marcos.Scholl wrote:Friend, managed to stream Pi for Pi with a good resolution and the video not slow and crashing?

I'm trying this, was using Mplayer , but is extremely slow . I would be grateful if you could help me , since it seems to be doing the same thing!

Which codes of Transmitter and receiver you used for its proper functioning ?
Thank you.
use this, it works!
mkfifo buffer

nc -p 5001 -l > buffer | /opt/vc/src/hello_pi/hello_video/hello_video.bin buffer

Return to “Camera board”