danekshea
Posts: 2
Joined: Fri Jan 24, 2014 5:57 pm

Streaming: /dev/video0 does not support streaming i/o

Fri Jan 24, 2014 6:05 pm

Hey guys,

I've been trying to get my Raspberry pi camera module working forever now and just can't seem to crack it. I'm trying to use it in conjunction with Octoprint which is a web based print server for 3d printers. Of course, it would be nice to have a stream of my printer while I'm not there.

I have installed uv4l and all the packages for that. I have also made mjpg-streamer but keep getting the following when I try to run a mjpg-streamer instance:

Code: Select all

[email protected] ~ $ /home/pi/mjpg-streamer/mjpg-streamer-experimental/mjpg_streamer -i "/home/pi/mjpg-streamer/mjpg-streamer-experimental/input_uvc.so -d /dev/video0 -r SXGA" -o "/home/pi/mjpg-streamer/mjpg-streamer-experimental/output_http.so"
MJPG Streamer Version: svn rev: Unversioned directory
 i: Using V4L2 device.: /dev/video0
 i: Desired Resolution: 1280 x 1024
 i: Frames Per Second.: -1
 i: Format............: JPEG
 i: TV-Norm...........: DEFAULT
/dev/video0 does not support streaming i/o
 Init v4L2 failed !! exit fatal
 i: init_VideoIn failed
[email protected] ~ $ ^C
[email protected]ypi ~ $ /dev/video0 does not support streaming i/o
I can't figure it out. Any ideas?

RpiName
Posts: 712
Joined: Sat Jul 06, 2013 3:14 am

Re: Streaming: /dev/video0 does not support streaming i/o

Sun Jan 26, 2014 1:02 am

Add this line in /etc/environment and logoff/login or reboot:

Code: Select all

LD_PRELOAD=/usr/lib/uv4l/uv4lext/armv6l/libuv4lext.so 

danekshea
Posts: 2
Joined: Fri Jan 24, 2014 5:57 pm

Re: Streaming: /dev/video0 does not support streaming i/o

Wed Jan 29, 2014 8:59 pm

And this worked perfectly. Thank you so much, I've been caught up watching my printer on the camera :D.

Nerol
Posts: 5
Joined: Thu Aug 13, 2015 10:04 am

Re: Streaming: /dev/video0 does not support streaming i/o

Sat Sep 12, 2015 9:10 am

it doesn't work for me.

Code: Select all

mjpg_streamer -i "/usr/local/lib/input_uvc.so -f 10 -r 320x240" -o "/usr/local/lib/output_http.so -w /home/pi/domotica/video
MJPG Streamer Version: svn rev: 3:172
 i: Using V4L2 device.: /dev/video0
 i: Desired Resolution: 320 x 240
 i: Frames Per Second.: 10
 i: Format............: MJPEG
/dev/video0 does not support streaming i/o
 Init v4L2 failed !! exit fatal 
 i: init_VideoIn failed
It fails when it's executed with sudo, but works without sudo privileges :shock:

RpiName
Posts: 712
Joined: Sat Jul 06, 2013 3:14 am

Re: Streaming: /dev/video0 does not support streaming i/o

Sat Sep 12, 2015 10:11 am

Nerol wrote:

Code: Select all

mjpg_streamer -i "/usr/local/lib/input_uvc.so -f 10 -r 320x240" -o "/usr/local/lib/output_http.so -w /home/pi/domotica/video
Use the UV4L Streaming Server instead of mjpeg_streamer?

Nerol
Posts: 5
Joined: Thu Aug 13, 2015 10:04 am

Re: Streaming: /dev/video0 does not support streaming i/o

Sat Sep 12, 2015 5:39 pm

I don't know what you mean

RpiName
Posts: 712
Joined: Sat Jul 06, 2013 3:14 am

Re: Streaming: /dev/video0 does not support streaming i/o

Sat Sep 12, 2015 5:56 pm

Nerol wrote:I don't know what you mean
Why don't you use the UV4L Streaming Server to get the MJPEG Stream and control the camera settings directly instead of using mjpg_streamer?

http://www.linux-projects.org/modules/s ... e&artid=14

Return to “Camera board”