Page 1 of 1

Camera fails with ENOSPC error

Posted: Tue Dec 24, 2013 1:12 pm
by GekkePrutser
Hi Everyone,

I was wondering if any of you have seen this issue before. I found 2 similar threads but they were from May, and I think it was caused by the latest update (I update once a month or so)

The issue I'm having is that my camera fails to work just after I did an apt-get update (on raspbian). Nothing else has changed (the power adapter, software etc). The first time I rebooted it complained about the split being only 64MB to the GPU (even though it worked fine with that before) but even when I changed the split to 128MB it still fails, though not with that 64MB message.

I already tried running rpi-update as root as well but that didn't fix it (but the problem already occurred before I ran rpi-update). Also tried to re-enable the camera (I see it puts start_x=1 in config.txt)

This is the error I'm getting now:

Code: Select all

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates
I found 2 other threads (this one and this one) but I think they had different causes (e.g. running the camera app twice at the same time, which I don't do, or a bad PSU where mine used to work fine until I did the update). My problem seems to have been caused by running an apt-get upgrade so I'm wondering if there is a bug in one of the latest packages or something.

Also, my camera seems to never work now, not just sometimes as most of the other people had.

From the hardware-related packages I can see that only raspberrypi-bootloader and raspi-config were updated when I did apt-get update, the rest of the updates had nothing to do with the hardware.

I also did a 'vcdbg log msg' as suggested in one of the other threads, which returned the following:

Code: Select all

001077.868: HDMI:Setting property pixel encoding to Default
001077.893: HDMI:Setting property pixel clock type to PAL
001077.917: HDMI:Setting property content type flag to No data
001077.939: HDMI:Setting property fuzzy format match to enabled
001079.142: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
001079.171: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
003151.151: vchiq_core: vchiq_init_state: slot_zero = 0x57000000, is_master = 1
003155.933: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
003158.548: cma: cma_hwm is zero - disabling cma service
Any help would be greatly appreciated. Really miss my little camera :D

Edit: One more thing I just noticed: The red LED stays on after the first time I try to use the camera. I had previously set this to off in config.txt (disable_camera_led=1) but I switched it back on to see if that was causing the problem. But it still happens, though now I can see that it keeps the camera active after it fails.

Re: Camera fails with ENOSPC error

Posted: Tue Dec 24, 2013 1:43 pm
by jamesh
Do you have the opportunity to flash a new SD card with the latest NOOBS/Raspbian and see if it works there (it should do).

James

Re: Camera fails with ENOSPC error

Posted: Tue Dec 24, 2013 2:35 pm
by GekkePrutser
Thanks for your quick reply!

I don't actually have a spare SD card around here, this pi is not at my home. But I can make an image of the card and reinstall.. I was just hoping there'd be an easier fix, I have a lot of software installed on this one.

But you're right, it would be good to validate that it still works normally with an out-of-the-box install. I'll try this now.

Re: Camera fails with ENOSPC error

Posted: Tue Dec 24, 2013 4:39 pm
by GekkePrutser
You're right, it works totally fine with a fresh raspbian image!

Would you know what could have caused this to break? I think it must have been something to do with the bootloader (it broke right after I updated with apt-get update). Or perhaps a version incompatibility with a kernel driver or something?

It'd be great if I could copy the affected files over from the standard image as opposed to doing a fresh install because there's a lot of configuration on software on this one that I'd prefer not having to do again.. This one runs a temperature database, VPN, IRC bouncer, RTLSDR receiver and a few more things :)

Re: Camera fails with ENOSPC error

Posted: Tue Dec 24, 2013 8:32 pm
by GekkePrutser
I found the problem - I compared all the relevant files with the fresh image (/boot for the kernel/GPU code, /opt/vc etc) but all files were identical with the fresh image. 2 or 3 were different but replacing them didn't help.

However, I then found this thread and I am indeed also using the DS18 1-wire temp sensors.

So I have the same problem as in that thread. Disabled the 1-wire kernel modules and it works again! Too bad I didn't have the old ones backed up from before I upgraded :( But I'll try the workaround mentioned in that thread.

Edit: The workaround didn't work (loading the w1 mods first and then the i2c ones). But I can live without the temp. sensors for a while :)

By the way for anyone else who might have this problem: here's the github thread