Page 194 of 201

Re: RPi Cam Web Interface

Posted: Thu Oct 18, 2018 1:37 pm
by oldjake
Thanks for the reply. I have been variously refreshing or going out of the page and back in again.

I kicked off another one after I reduced the image resolution. So my image res is 600 x 900. The preview says 121kb (104). The video bit still says 'Busy". I started the conversion at 11.39 which is just about 3 hours ago.

Re: RPi Cam Web Interface

Posted: Thu Oct 18, 2018 1:39 pm
by oldjake
Oh, this is what's in the "Convert using" box:

/usr/bin/ffmpeg -f image2 -i i_%05d.jpg

Re: RPi Cam Web Interface

Posted: Thu Oct 18, 2018 2:13 pm
by btidey
oldjake wrote:
Thu Oct 18, 2018 1:39 pm
Oh, this is what's in the "Convert using" box:

/usr/bin/ffmpeg -f image2 -i i_%05d.jpg
Are you running latest version? There was a fix for the time lapse command put in last week.

If the time lapse command fails then the file will say Busy as the lack of a .mp4 file is what triggers that. The log should say what command was used to do the convert.

Re: RPi Cam Web Interface

Posted: Wed Oct 24, 2018 9:25 pm
by Gary Littlemore
Robert

I had videos that were locked and I had a day of videos today that all had busy against them so I deleted all, the videos that were locked have also deleted.

Re: RPi Cam Web Interface

Posted: Wed Oct 24, 2018 9:38 pm
by btidey
Gary Littlemore wrote:
Wed Oct 24, 2018 9:25 pm
Robert

I had videos that were locked and I had a day of videos today that all had busy against them so I deleted all, the videos that were locked have also deleted.
Yes. I can confirm that happens. Strange as the files are set to read only.

Under investigation.

Re: RPi Cam Web Interface

Posted: Wed Oct 24, 2018 9:55 pm
by btidey
btidey wrote:
Wed Oct 24, 2018 9:38 pm
Gary Littlemore wrote:
Wed Oct 24, 2018 9:25 pm
Robert

I had videos that were locked and I had a day of videos today that all had busy against them so I deleted all, the videos that were locked have also deleted.
Yes. I can confirm that happens. Strange as the files are set to read only.

Under investigation.
It looks like the php unlink used in the delete all is not respecting the read only flag.

I'm checking further but I have put in an extra check to prevent this which seems to work in the latest version.

Edit: I understand this now, The erase permissions that unlink is using are at the folder not file level.
The fix put in is effective.

Re: RPi Cam Web Interface

Posted: Wed Oct 24, 2018 11:37 pm
by smxsmxsmx
How would I go about using RPi-Cam-Web-Interface over local wifi access point / connecting with phone to wifi of raspberry pi without going over router?

Re: RPi Cam Web Interface

Posted: Thu Oct 25, 2018 8:23 am
by btidey
smxsmxsmx wrote:
Wed Oct 24, 2018 11:37 pm
How would I go about using RPi-Cam-Web-Interface over local wifi access point / connecting with phone to wifi of raspberry pi without going over router?
If you set the raspberry Pi up as an AP (access point) then it behaves like a wifi router. You can then scan wifi on your phone and connect to the raspberry pi hosted network. The Cam-Web interface will then be accessible from the phone.

There are various tutorials on setting the Pi as an AP. E.g.

https://www.raspberrypi.org/documentati ... s-point.md

Re: RPi Cam Web Interface

Posted: Thu Oct 25, 2018 10:12 am
by Kaushik
Camera preview freeze issue:
Hi, I have a set up that works perfectly most of the time. However, every 3 or 4 days. The preview freezes. I want to know why and how to avoid it?

The cam.jpg stops getting updated. I understand, when that happens, the child raspimjpeg should kill itself and the parent will spawn a new child.
However, that isn't happening : htop shows two raspimjpeg processes and they are sleeping. The TIME+ column has 10h51:15 for the child raspimjpeg.
Why didn't the expected behavior happen. Is there anything I can look for?

Re: RPi Cam Web Interface

Posted: Fri Oct 26, 2018 7:17 am
by ruder
Hello, everyone, I am facing big problem while installing Rpi cam web interface on Raspbian strech lite.

After cloning from Git. I install it using chmod u+x ...

but later i get this error , every time when i try to use sudo :( .

"sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set"

Any solution plz help me, btidey.

Re: RPi Cam Web Interface

Posted: Fri Oct 26, 2018 9:28 am
by Gary Littlemore
ruder wrote:
Fri Oct 26, 2018 7:17 am
Hello, everyone, I am facing big problem while installing Rpi cam web interface on Raspbian strech lite.

After cloning from Git. I install it using chmod u+x ...

but later i get this error , every time when i try to use sudo :( .

"sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set"

Any solution plz help me, btidey.
The wiki says the chmod was only for older versions, just go with the following:

git clone https://github.com/silvanmelchior/RPi_C ... erface.git
cd RPi_Cam_Web_Interface
./install.sh

Re: RPi Cam Web Interface

Posted: Fri Oct 26, 2018 9:37 am
by ruder
Ok thanks :)

Re: RPi Cam Web Interface

Posted: Sat Oct 27, 2018 7:33 am
by ruder
:)

Re: RPi Cam Web Interface

Posted: Sun Oct 28, 2018 7:06 am
by Gary Littlemore
I’ve got wrongly reported video length times in library, but look at the times between the clips roughly 10 seconds clips.

0541 267921 Kb 359s
2018-10-28
06:51:39

0542 13186 Kb 189s
2018-10-28
06:51:49

0543 9977 Kb 176s
2018-10-28
06:51:52

0544 24992 Kb 183s
2018-10-28
06:52:04

0545 21601 Kb 162s
2018-10-28
06:52:16

Re: RPi Cam Web Interface

Posted: Mon Oct 29, 2018 6:05 pm
by smxsmxsmx
btidey wrote:
Thu Oct 25, 2018 8:23 am
smxsmxsmx wrote:
Wed Oct 24, 2018 11:37 pm
How would I go about using RPi-Cam-Web-Interface over local wifi access point / connecting with phone to wifi of raspberry pi without going over router?
If you set the raspberry Pi up as an AP (access point) then it behaves like a wifi router. You can then scan wifi on your phone and connect to the raspberry pi hosted network. The Cam-Web interface will then be accessible from the phone.

There are various tutorials on setting the Pi as an AP. E.g.

https://www.raspberrypi.org/documentati ... s-point.md

Thank you! I did that, but now the service doesn't autostart anymore and the buttons to capture video, photo do not work anymore. Why could that be?

Re: RPi Cam Web Interface

Posted: Tue Oct 30, 2018 10:43 am
by smxsmxsmx
smxsmxsmx wrote:
Mon Oct 29, 2018 6:05 pm
btidey wrote:
Thu Oct 25, 2018 8:23 am
smxsmxsmx wrote:
Wed Oct 24, 2018 11:37 pm
How would I go about using RPi-Cam-Web-Interface over local wifi access point / connecting with phone to wifi of raspberry pi without going over router?
If you set the raspberry Pi up as an AP (access point) then it behaves like a wifi router. You can then scan wifi on your phone and connect to the raspberry pi hosted network. The Cam-Web interface will then be accessible from the phone.

There are various tutorials on setting the Pi as an AP. E.g.

https://www.raspberrypi.org/documentati ... s-point.md

Thank you! I did that, but now the service doesn't autostart anymore and the buttons to capture video, photo do not work anymore. Why could that be?
RPi-Cam-Web-Interface now autostarts but where the camera preview would be is a broken image icon that keeps flashing. Buttons still don't work.

Re: RPi Cam Web Interface

Posted: Thu Nov 01, 2018 8:11 am
by Gary Littlemore
Gary Littlemore wrote:
Sun Oct 28, 2018 7:06 am
I’ve got wrongly reported video length times in library, but look at the times between the clips roughly 10 seconds clips.

0541 267921 Kb 359s
2018-10-28
06:51:39

0542 13186 Kb 189s
2018-10-28
06:51:49

0543 9977 Kb 176s
2018-10-28
06:51:52

0544 24992 Kb 183s
2018-10-28
06:52:04

0545 21601 Kb 162s
2018-10-28
06:52:16
I’ve got more again this morning:

1375 11846 Kb 204s
2018-11-01
07:36:00

1374 21513 Kb 689s
2018-11-01
07:35:55

1373 11576 Kb 867s
2018-11-01
07:35:45

1372 5112 Kb 1258s
2018-11-01
07:35:42

1371 1988047 Kb 2456s
2018-11-01
07:35:35

Re: RPi Cam Web Interface

Posted: Fri Nov 02, 2018 11:15 pm
by wpballa1
Bob,
I can't quite prove it yet, but I suspect that the purge based on % of disk space left is not working properly. My disk seems to fill up and then the program locks up instead of deleting old videos. If I can get in on time and delete them manually, all is fine, but the automatic purge doesn't seem to be working.
Thanks for any help or advice.
Bill Ballard

Re: RPi Cam Web Interface

Posted: Fri Nov 02, 2018 11:22 pm
by Gary Littlemore
wpballa1 wrote:
Fri Nov 02, 2018 11:15 pm
Bob,
I can't quite prove it yet, but I suspect that the purge based on % of disk space left is not working properly. My disk seems to fill up and then the program locks up instead of deleting old videos. If I can get in on time and delete them manually, all is fine, but the automatic purge doesn't seem to be working.
Thanks for any help or advice.
Bill Ballard
I’ve found mine gets to around 60% and every montion dectection after that locks up and stays as the status ‘busy’.

Re: RPi Cam Web Interface

Posted: Fri Nov 02, 2018 11:28 pm
by wpballa1
Yes, that sounds like the problem. I will try using Max Space in GB and see if that works. I had to rebuild the entire system it locked up so badly this time. Fortunately, that doesn't take too long.

Re: RPi Cam Web Interface

Posted: Sat Nov 03, 2018 12:20 am
by Gary Littlemore
wpballa1 wrote:
Fri Nov 02, 2018 11:28 pm
Yes, that sounds like the problem. I will try using Max Space in GB and see if that works. I had to rebuild the entire system it locked up so badly this time. Fortunately, that doesn't take too long.
I’m currently on ‘local:52.5% Total:60052(MB)’ so I’d think it’ll hit 60% at some point tomorrow so I’ll see how I get on.

Re: RPi Cam Web Interface

Posted: Sun Nov 04, 2018 8:54 pm
by Gary Littlemore
Gary Littlemore wrote:
Sat Nov 03, 2018 12:20 am
wpballa1 wrote:
Fri Nov 02, 2018 11:28 pm
Yes, that sounds like the problem. I will try using Max Space in GB and see if that works. I had to rebuild the entire system it locked up so badly this time. Fortunately, that doesn't take too long.
I’m currently on ‘local:52.5% Total:60052(MB)’ so I’d think it’ll hit 60% at some point tomorrow so I’ll see how I get on.
I’m currently on ‘local:74% Total:60052(MB)’ no issues yet.

Re: RPi Cam Web Interface

Posted: Mon Nov 05, 2018 7:29 pm
by wpballa1
Well, I got to about the limit in GB that I requested, and then it just stopped recording videos rather than purging any.

Re: RPi Cam Web Interface

Posted: Mon Nov 05, 2018 10:24 pm
by Gary Littlemore
wpballa1 wrote:
Mon Nov 05, 2018 7:29 pm
Well, I got to about the limit in GB that I requested, and then it just stopped recording videos rather than purging any.
I’m now on local:82% Total:60052(MB), 85% is my limit where it should start deleting files.

Re: RPi Cam Web Interface

Posted: Wed Nov 07, 2018 10:06 pm
by demballs
Hi,

I've ended up here after lots of searching and have a few questions about whether this tool will meet my requirements.

What I'm after really is (at least) a 720 height, 30fps live video server that applications like OBS Studio can read and include in recordings / streams.

I've read a lot about the preview feed - would that be configurable to that kind of resolution? It would be included in videos / streams that are designed to be watched for entertainment rather than security / surveillance. I'm pretty certain I can connect OBS Studio to that feed, given that it's mjpeg.

I have a few Raspberry Pi Bs hanging around - is it worth me picking up a camera? Can I achieve this?

Thanks in advance for any help.