posthuman_1000
Posts: 19
Joined: Wed Aug 28, 2013 8:52 pm

Re: Camera freezes

Sun Sep 01, 2013 2:47 pm

Update:

Tried it on a fresh install of Raspbian, exact same results. I guess my only option now is a new camera :(

decebal
Posts: 6
Joined: Sat Jan 12, 2013 12:17 pm

Re: Camera freezes

Sun Sep 01, 2013 5:55 pm

Why do you think that a new camera help you? I have a new camera, new SD card with the last raspbian (apt-get update, apt-get upgrade, raspi-config) and I cannot use the camera.
posthuman_1000 wrote:Update:

Tried it on a fresh install of Raspbian, exact same results. I guess my only option now is a new camera :(

posthuman_1000
Posts: 19
Joined: Wed Aug 28, 2013 8:52 pm

Re: Camera freezes

Sun Sep 01, 2013 8:34 pm

decebal wrote:Why do you think that a new camera help you? I have a new camera, new SD card with the last raspbian (apt-get update, apt-get upgrade, raspi-config) and I cannot use the camera.
posthuman_1000 wrote:Update:

Tried it on a fresh install of Raspbian, exact same results. I guess my only option now is a new camera :(
The next most likely scenario in my case seems to be that I've damaged the camera myself (as I admitted above, I probably wasn't as careful handling it as I should have been). It is a gamble, I've got no idea if that is the problem but I don't know how to check (if I even can). If that doesn't solve the issue, other than swearing a lot, I don't know to do.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24635
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Mon Sep 02, 2013 8:43 am

decebal wrote:Why do you think that a new camera help you? I have a new camera, new SD card with the last raspbian (apt-get update, apt-get upgrade, raspi-config) and I cannot use the camera.
posthuman_1000 wrote:Update:

Tried it on a fresh install of Raspbian, exact same results. I guess my only option now is a new camera :(
On the other hand, lots of people have exactly the same setup and it works fine. And there is the possibility that the caerma was damaged in transit.

That said, Dom found a bug in the GPU code that might be related to obscure (ie very infrequent) camera startup problems, but I need to talk to him about it to see if it might be relevant. If he thinks there may be a link, we'll release new firmware asap. so you will be able to test to see if it helps.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24635
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Mon Sep 02, 2013 12:31 pm

OK, Dom has released a new version of the GPU code with a fix to the I2C communications to the camera. There was some uninitialised data in a structure that could, on very infrequent occasions cause a I2C problem, which may or may not have some bearing on the issues seen here.

sudo rpi-update will get the latest code - could someone with problems give it a go to see if it helps?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

decebal
Posts: 6
Joined: Sat Jan 12, 2013 12:17 pm

Re: Camera freezes

Mon Sep 02, 2013 3:51 pm

Doesn't work for me.
jamesh wrote:OK, Dom has released a new version of the GPU code with a fix to the I2C communications to the camera. There was some uninitialised data in a structure that could, on very infrequent occasions cause a I2C problem, which may or may not have some bearing on the issues seen here.

sudo rpi-update will get the latest code - could someone with problems give it a go to see if it helps?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24635
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Mon Sep 02, 2013 4:11 pm

decebal wrote:Doesn't work for me.
jamesh wrote:OK, Dom has released a new version of the GPU code with a fix to the I2C communications to the camera. There was some uninitialised data in a structure that could, on very infrequent occasions cause a I2C problem, which may or may not have some bearing on the issues seen here.

sudo rpi-update will get the latest code - could someone with problems give it a go to see if it helps?
OK. I wonder then if either the camera is faulty or the CSI interface on the Raspi is faulty. Got to be one or the other (since the software is known to work, and assuming it's all installed correctly)
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

User avatar
RaTTuS
Posts: 10517
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Camera freezes

Mon Sep 02, 2013 4:12 pm

decebal where in the world are you ?
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

mfsd
Posts: 6
Joined: Wed Aug 28, 2013 10:31 pm
Location: Sweden

Re: Camera freezes

Mon Sep 02, 2013 5:14 pm

Hello...

It doesnt work for me either....

The only difference I notice was that, now it seems to take more time to go through "Connecting camera stills to encoder input port"

/mfsd

decebal
Posts: 6
Joined: Sat Jan 12, 2013 12:17 pm

Re: Camera freezes

Mon Sep 02, 2013 6:40 pm

Bucharest, Romania
RaTTuS wrote:decebal where in the world are you ?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24635
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Mon Sep 02, 2013 7:45 pm

mfsd wrote:Hello...

It doesnt work for me either....

The only difference I notice was that, now it seems to take more time to go through "Connecting camera stills to encoder input port"

/mfsd
That's odd. The problem Dom fixed would exhibit as a non-detected camera, which would error earlier than that so I would not expect that point to be slower. There may be other code changes in the firmware release though.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

posthuman_1000
Posts: 19
Joined: Wed Aug 28, 2013 8:52 pm

Re: Camera freezes

Mon Sep 02, 2013 9:51 pm

jamesh wrote:OK, Dom has released a new version of the GPU code with a fix to the I2C communications to the camera. There was some uninitialised data in a structure that could, on very infrequent occasions cause a I2C problem, which may or may not have some bearing on the issues seen here.

sudo rpi-update will get the latest code - could someone with problems give it a go to see if it helps?
I very much want to try it, but can't get the sudo rpi-update to work. I'm pretty sure it installed properly but I keep getting the 'command not found' error - I don't really understand what's gone wrong here so I can't make any progress. Frustrating.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24635
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Tue Sep 03, 2013 7:39 am

IIRC,

sudo apt-get install rpi-update
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

alexcroox
Posts: 18
Joined: Sun Jun 02, 2013 10:57 pm

Re: Camera freezes

Tue Sep 03, 2013 1:20 pm

Didn't fix it for me, Red light comes on and stays on even when I kill all processes, only re-boot will stop it staying on:

raspistill -v -o b3.jpg

raspistill Camera App v1.2

Width 2592, Height 1944, quality 85, filename b3.jpg
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled no
Full resolution preview No

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 400, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000

Hangs at this point.

mfsd
Posts: 6
Joined: Wed Aug 28, 2013 10:31 pm
Location: Sweden

Re: Camera freezes

Tue Sep 03, 2013 1:53 pm

alexcroox,

The output you posted is what I see from the second time I run the application.
The first time it hangs, it does it at "Start Capture 1" point.... if you kill the process with ctrl+c, and call the raspistill again, then I see what you have posted. Is it right? Could you please double check?

Thanks and regards,
/mfsd

posthuman_1000
Posts: 19
Joined: Wed Aug 28, 2013 8:52 pm

Re: Camera freezes

Tue Sep 03, 2013 8:30 pm

jamesh wrote:IIRC,

sudo apt-get install rpi-update
Thanks, I got it to work in the end - turns out I'm an idiot that can't tell the difference between 'update' and 'upgrade' - through my rage I just didn't notice myself repeatedly typing the wrong thing.

Anyway, the firmware update didn't seem to fix anything, but...

I took the gamble on buying a new one and it works - I guess I did break it after all. I mean I know I wasn't being that careful, but I also didn't feel what I was doing was far beyond the normal handling one would expect to do with the camera. It seems they are pretty sensitive then, perhaps to the point of not really being that practical...

Oh well, I am just having to be ULTRA careful with the new one now.

alexcroox
Posts: 18
Joined: Sun Jun 02, 2013 10:57 pm

Re: Camera freezes

Sat Sep 07, 2013 11:59 am

Does anywhere sell 3D printed enclosures for the module? Would make handling it a lot easier if it so sensitive to ESD.

User avatar
Mortimer
Posts: 924
Joined: Sun Jun 10, 2012 3:57 pm

Re: Camera freezes

Sat Sep 07, 2013 12:19 pm

There is these at CPC:
http://cpc.farnell.com/jsp/search/produ ... arProducts

Image

Don't know how good they are, as I don't have one. Thinking about it though.
--------------
The purpose of a little toe is to ensure you keep your furniture in the right place.

User avatar
recantha2
Posts: 287
Joined: Wed Nov 14, 2012 9:34 am
Location: Potton, Bedfordshire
Contact: Website Facebook Twitter

Re: Camera freezes

Sun Sep 08, 2013 6:45 am

There are these cheap-and-cheerful mounts for the camera:
http://shop.pimoroni.com/collections/ca ... mera-mount
£3 from Pimoroni

Image
--
Michael Horne - @recantha
Raspberry Pi blog - http://www.recantha.co.uk/blog

Cambridge Raspberry Jam
Website: http://camjam.me
Facebook: https://www.facebook.com/cambridgeraspberryjam
Follow the Cambridge Raspberry Jam on Twitter - @cambridgejam

alexcroox
Posts: 18
Joined: Sun Jun 02, 2013 10:57 pm

Re: Camera freezes

Sun Sep 08, 2013 4:55 pm

recantha2 wrote:There are these cheap-and-cheerful mounts for the camera:
http://shop.pimoroni.com/collections/ca ... mera-mount
£3 from Pimoroni

Image
Ah that's great, and in the UK too, cheers!

Ben
Posts: 1
Joined: Thu Aug 08, 2013 3:21 pm

Re: Camera freezes

Sun Sep 08, 2013 11:42 pm

I had the same problem as many of you (including retrodans and decebel), where any camera-related command would cause the light to come on, a blank file to be created, then nothing. I would have to reboot the Pi just to get the light off, and Ctrl+C only reset the command line with the camera still frozen. raspistill -v would freeze at "Closing down". I disconnected all peripherals and did the full apt-get update / upgrade commands, but still no success.

I then reset all three camera connections, including the ribbon to the Pi, the ribbon to the camera module, and finally the little connector between the little black camera housing and the camera board itself.

Success! The camera is working 100% normally. I know the connector reset didn't work for retrodans, but I thank him for the suggestion and hope it works for others.

Rogerion
Posts: 3
Joined: Mon Sep 09, 2013 5:46 pm

Re: Camera freezes

Mon Sep 09, 2013 5:56 pm

I have the same problem with camera freeze and I know that is no camera issu but something with Raspberry Pi I have 2 Pi v B for me and my brother. It worked 2 days and next day it stopped. I have done all with update&upgrade and still nothing :( Then I took my SD, HDMI monitor, kayboard and camera plugged to secund Raspberry ... power on ...., and try raspivid -d and it worked! So ... there is problem with my Pi not the camera! :(

Rogerion
Posts: 3
Joined: Mon Sep 09, 2013 5:46 pm

Re: Camera freezes

Mon Sep 09, 2013 7:28 pm

I have a strace for raspistill -o t.jpg when it freeze strace1.txt strace2.txt and after freeze I abort program on my first Raspberry Pi.
In strace3-good.txt is strace for well working my secund Raspberry Pi + camera.

Code: Select all

read(5, "\nUTC0\n", 4096)               = 6
close(5)                                = 0
munmap(0xb6fa2000, 4096)                = 0
ioctl(3, 0x400cc404, 0xbe9ea6e4)        = 0
ioctl(3, 0x400cc404, 0xbe9ea6e4)        = 0
ioctl(3, 0x400cc404, 0xbe9ea6e4)        = 0
ioctl(3, 0x400cc404, 0xbe9ea74c)        = 0
futex(0xb6f4238c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbe9ea844)        = 0
ioctl(3, 0x400cc404, 0xbe9ea8a4)        = 0
gettimeofday({1378752652, 427288}, NULL) = 0
ioctl(3, 0x400cc404, 0xbe9ea6cc)        = 0
futex(0xbe9ea9a4, FUTEX_WAIT_PRIVATE, 0, NULL <unfinished ...>
mmal: Aborting program
and good is:

Code: Select all

munmap(0xb6fb6000, 4096)                = 0
ioctl(3, 0x400cc404, 0xbeb53734)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb53734)        = 0
ioctl(3, 0x400cc404, 0xbeb53734)        = 0
ioctl(3, 0x400cc404, 0xbeb5379c)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb53894)        = 0
ioctl(3, 0x400cc404, 0xbeb538f4)        = 0
gettimeofday({1378752974, 352935}, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb5371c)        = 0
futex(0xbeb539f4, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
write(4, "%Z\231\317\320\37\366\267\3401k1\315)R\241\226\375\1k\346\330j\331U\34\323\37K\"\306\324"..., 2463) = 2463
close(4)                                = 0
munmap(0xb6fb6000, 4096)                = 0
rename("t.jpg~", "t.jpg")               = 0
ioctl(3, 0x400cc404, 0xbeb5384c)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
futex(0xc66650, FUTEX_WAKE_PRIVATE, 1)  = 1
gettimeofday({1378752974, 884232}, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb53814)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb53674)        = 0
gettimeofday({1378752975, 47138}, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb5385c)        = 0
gettimeofday({1378752975, 48136}, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb53814)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb53674)        = 0
gettimeofday({1378752975, 54032}, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb5385c)        = 0
ioctl(3, 0x400cc404, 0xbeb538d4)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb538d4)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0x400cc404, 0xbeb538d4)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
futex(0xc66640, FUTEX_WAKE_PRIVATE, 1)  = 1
ioctl(3, 0x400cc404, 0xbeb538dc)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0xc64580, FUTEX_WAKE_PRIVATE, 1)  = 1
ioctl(3, 0x400cc404, 0xbeb538d4)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = -1 EAGAIN (Resource temporarily unavailable)
ioctl(3, 0x400cc404, 0xbeb5382c)        = 0
futex(0xc614a0, FUTEX_WAKE_PRIVATE, 1)  = 1
ioctl(3, 0x400cc404, 0xbeb538dc)        = 0
futex(0xb6f5638c, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
ioctl(3, 0xc40d, 0x11008)               = 0
ioctl(3, 0xc40b, 0x11008)               = 0
exit_group(0)                           = ?
debug.zip is below.

maybe someone will know what the issue is?
Attachments
debug.zip
(9.59 KiB) Downloaded 106 times

Rogerion
Posts: 3
Joined: Mon Sep 09, 2013 5:46 pm

Re: Camera freezes

Mon Sep 09, 2013 7:36 pm

And a diff in file ... left side where raspistill freezes
Attachments
diff.png
diff.png (35.51 KiB) Viewed 2887 times

LeoWhite
Posts: 131
Joined: Mon Apr 08, 2013 9:20 am
Contact: Website

Re: Camera freezes

Sun Sep 15, 2013 9:15 pm

I've just spent the past few hours tracking down a 'camera freeze' on one of my RPis. Symptom would be either the camera not being detected, or the raspistill command would 'hang' after turning on the red camera LED.

As I had one SD card image that didn't work and another that did it ruled out a hardware issue, so I hunted around for differences and eventually tracked it down to my /etc/modules file containing

lirc_rpi gpio_in_pin=21 gpio_out_pin=17

Which seemed to be causing a clash of GPIO values which caused the camera to not work. The value of 21 for the gpio_in_pin value was chosen when running on a Rev 1.0 board, although I'm not sure if it would have caused problems on that or not. Of course it didn't actually cause me a problem until I later on plugged in a RPi camera board.

Annoyingly I don't actually have an IR receiver (just a transmitter) but the LIRC module doesn't seem to want to load if you don't specify both an in and out pin.

So just one more thing to check for anyone seeing this camera freeze issue!

Return to “Camera board”