User avatar
alexeames
Forum Moderator
Forum Moderator
Posts: 2869
Joined: Sat Mar 03, 2012 11:57 am
Location: UK
Contact: Website

Re: Camera freezes

Fri Jun 21, 2013 5:48 pm

CPC tweeted a couple of days ago about August delivery. No word about why though.
Alex Eames RasPi.TV, RasP.iO

erikcf
Posts: 19
Joined: Thu May 23, 2013 4:17 am

Re: Camera freezes

Sat Jun 22, 2013 8:42 am

retrodans wrote:Sorry no, I hadn't played with the sunny cable. Just both ends of the main cable. At a glance the sunny one looks fine, would it be obvious if disconnected (ie. Just hanging)?
I saw your message that you already tried reconnecting it, but just replying to this to answer your question.

With mine, the camera was no longer being detected, but it looked like that connector was still in. I had even tried pushing on it to make sure it was in. It wasn't until I actually disconnected and reconnected it that mine worked again.

Bradleybourbon
Posts: 1
Joined: Tue Jun 25, 2013 9:52 pm

Re: Camera freezes

Tue Jun 25, 2013 9:54 pm

I have the same issue. Worked fine for the first two days and now it hangs on any camera operation. Solid red light...

DaniProl
Posts: 5
Joined: Mon Jun 03, 2013 3:18 pm

Re: Camera freezes

Mon Jul 08, 2013 10:58 am

Same error here. Maybe I bought your camera through ebay? :S I can't solve it

guicara
Posts: 1
Joined: Wed Jul 10, 2013 6:35 pm

Re: Camera freezes

Wed Jul 10, 2013 6:37 pm

I also have the same issue: red light -> the camera freezes :cry:

kyle2k
Posts: 84
Joined: Tue Feb 19, 2013 2:47 pm

Re: Camera freezes

Thu Jul 11, 2013 6:31 pm

Hi, my camera is also doing exactly as described in this thread.

I have checked all options, different cards etc..

My camera has worked fine for over a month, strange that this seems to have happened after a apt-get upgrade?

Is the official response to return to seller?

Regards Kyle

User avatar
RaTTuS
Posts: 10499
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Camera freezes

Thu Jul 11, 2013 6:36 pm

I'm going to stick my ore in again
I've disassembled the camera for doing the macro tweek
put it al lback together and now I get the same reds light not detected...
I'm going to eat some food , watch a film and see what I can see again later
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
inversesandwich
Posts: 30
Joined: Sun Jun 30, 2013 6:18 pm
Location: Hampshire, England
Contact: Website

Re: Camera freezes

Thu Jul 11, 2013 7:25 pm

The only solutions I can think of is...
  • A - Return the camera to seller (warranty?)
  • B - Redo the image on the SD card, either via NOOBS or the traditional way
  • C - Use

    Code: Select all

    sudo apt-get update && sudo apt-get dist-upgrade
    to update everything that needs updating
Hope this might help any of you.
InverseSandwich
Visit my page at http://about.me/inversesandwich and follow me on Twitter @inversesandwich

kyle2k
Posts: 84
Joined: Tue Feb 19, 2013 2:47 pm

Re: Camera freezes

Thu Jul 11, 2013 9:00 pm

Hi,

I have tried option C on two different cards with Raspian installed and on a card with berryboot & Raspian, will using a NOOBs card make any difference??

Edit : Also tried my various cards and camera on 2 x model B's and 1 x modal A Rpi's

User avatar
RaTTuS
Posts: 10499
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Camera freezes

Thu Jul 11, 2013 9:31 pm

a)is out as I've nobbled it
b) no need as the image works fine
c) no it was working and I think I ESD broke it
I'll swap with my other camera module tomorrow but it looks dead
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
RaTTuS
Posts: 10499
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Camera freezes

Fri Jul 12, 2013 11:13 am

Quick update -
RPI 1 + camera 1 which I tried to do the Macro mod on and it stopped working last night
RPI 2 + camera 2 which was all fine and dandy and working

so this morning I
took camera 2 and put in RPI 1 - this still did not work
I took camera 1 and put this in RPi 2 and this worked,
see image :-
Image

macro mode [you can see RPI 1 with camera 2 in image]

currently I'm going to have coffee and then see if I can get RPi1 + camera 2 working.

Reseated camera 2 in RPi 1 and all works ...

so I'm back happy and I think that the Red light issue may be a bad connection between RPi and camera cable
sorry to the other who have issues
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

emos
Posts: 12
Joined: Sun May 12, 2013 11:44 pm

Re: Camera freezes

Wed Jul 17, 2013 9:55 pm

It looks like the new boards have this issue or maybe it is early model rasp pi's that have the issue. I got one 2 days ago and it is locking with the led light on when I run raspistill. It cannot capture. Looks like I will return it.

I tried the disconnect sunny ribbon approach and that did not work either.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24140
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Wed Jul 17, 2013 10:10 pm

emos wrote:It looks like the new boards have this issue or maybe it is early model rasp pi's that have the issue. I got one 2 days ago and it is locking with the led light on when I run raspistill. It cannot capture. Looks like I will return it.

I tried the disconnect sunny ribbon approach and that did not work either.
There are no differences in the new boards compared with older ones. Also no issue with older model Raspi - I use a very early Raspi and it works fine. Almost certainly a static discharge issue - I blew up one by being careless.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

User avatar
RaTTuS
Posts: 10499
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Camera freezes

Thu Jul 18, 2013 7:00 am

my bet is it is a dodgy connection on the cable
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

JonesThePi
Posts: 21
Joined: Tue Oct 23, 2012 1:08 pm

Re: Camera freezes

Thu Jul 18, 2013 10:35 am

Don't know if this helps but I had exactly this problem with a new camera board delivered early this week. I initially set up the camera on a model B running a much tinkered with SD card. Ensured everything was updated as recommended but the camera would lock with the led light on when I ran raspistill.

I then installed the camera on a model A with an SD card that was rebuilt a month or so ago to run as an Open Energy Monitor base station. The camera worked fine...

...since then I have built a SD card from scratch for the model B, re-installed the camera and everything now works as expected.

So far I have only enabled SSH on the new model B build without experiencing any camera issue. I have a sneaking suspicion that when I start to add some of the packages I was using for programming things like the GertBoard the camera may suddenly stop working, i.e. software conflicts or configuration may be part of this issue.

I will post again if I find something that breaks my camera setup...

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24140
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Thu Jul 18, 2013 1:10 pm

JonesThePi wrote:Don't know if this helps but I had exactly this problem with a new camera board delivered early this week. I initially set up the camera on a model B running a much tinkered with SD card. Ensured everything was updated as recommended but the camera would lock with the led light on when I ran raspistill.

I then installed the camera on a model A with an SD card that was rebuilt a month or so ago to run as an Open Energy Monitor base station. The camera worked fine...

...since then I have built a SD card from scratch for the model B, re-installed the camera and everything now works as expected.

So far I have only enabled SSH on the new model B build without experiencing any camera issue. I have a sneaking suspicion that when I start to add some of the packages I was using for programming things like the GertBoard the camera may suddenly stop working, i.e. software conflicts or configuration may be part of this issue.

I will post again if I find something that breaks my camera setup...
That's quite interesting...certainly food for thought. Please pass on the results!
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

JAMOV13
Posts: 2
Joined: Tue Feb 26, 2013 2:27 am
Location: New Zealand

Re: Camera freezes

Fri Jul 19, 2013 7:18 am

Reading these posts it seems that other Pi users have exactly the same issue has I do :(

It's super frustrating.

My Pi has clean power, all the hardware is setup well etc etc. The issue is software I believe.

To say it freezes might not be so accurate.. hangs is a better term, as the green (ok) light does actually flash ever so occasionally. The hang state seems to be linked to the running of the camera module in that each time the camera runs it has the potential to hang and become unresponsive.

Hang state will occur the first run (most cases) or later attempts (its never finished three runs) of my python script or when I run straight from the command line. When it does complete the images are great. It just usually doesn't complete :(

Was there any solution to the issue for this post?

Please help!!

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24140
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Fri Jul 19, 2013 8:15 am

JAMOV13 wrote:Reading these posts it seems that other Pi users have exactly the same issue has I do :(

It's super frustrating.

My Pi has clean power, all the hardware is setup well etc etc. The issue is software I believe.

To say it freezes might not be so accurate.. hangs is a better term, as the green (ok) light does actually flash ever so occasionally. The hang state seems to be linked to the running of the camera module in that each time the camera runs it has the potential to hang and become unresponsive.

Hang state will occur the first run (most cases) or later attempts (its never finished three runs) of my python script or when I run straight from the command line. When it does complete the images are great. It just usually doesn't complete :(

Was there any solution to the issue for this post?

Please help!!
Hmm. If you believe it's a software problem, have you tried a new SD with with a new image on it? A fresh install works fine for me. No locks/hangs.

It's very odd indeed that it's inconsistent - ie works sometimes. That not something people have reported before. It either works or it doesn't.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

RobinC
Posts: 1
Joined: Fri Jul 19, 2013 8:26 pm

Re: Camera freezes

Fri Jul 19, 2013 8:31 pm

Same issue here. If I run "raspivid -t 120000" it seems to run fine and display to screen. If I run "raspivid -d -t 120000" for demo mode, it runs about 20 seconds and then the camera locks up with the red led on. Reboot to fix.

DaniProl
Posts: 5
Joined: Mon Jun 03, 2013 3:18 pm

Re: Camera freezes

Wed Jul 24, 2013 4:16 pm

I just bought a new rpi (new: 2011.12, old: 2011, both B model). The new camera works fine in the new rpi. I don't know what happened there, but the "starting capture 1" error doesn't appears anymore.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24140
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Wed Jul 24, 2013 4:35 pm

RobinC wrote:Same issue here. If I run "raspivid -t 120000" it seems to run fine and display to screen. If I run "raspivid -d -t 120000" for demo mode, it runs about 20 seconds and then the camera locks up with the red led on. Reboot to fix.
Can you run in -v mode and see if it dies in the same place each time - and tell me what its saying when it does die?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

blerry
Posts: 1
Joined: Sat Jul 27, 2013 11:04 pm

Re: Camera freezes

Sat Jul 27, 2013 11:35 pm

Same issue here it hangs when closing down checked everything.

It seems many people have this problem is there no solution at all ?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24140
Joined: Sat Jul 30, 2011 7:41 pm

Re: Camera freezes

Sun Jul 28, 2013 9:20 am

blerry wrote:Same issue here it hangs when closing down checked everything.

It seems many people have this problem is there no solution at all ?
TBH, you definition of many may differ. We've had less than 5 reports like this out of over 10k sold....

It is very odd is dies on close down though. I cannot think of any reason why that would be so. At this stage the picture should have been written to SD card, the camera turned off etc. So everything should complete.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

User avatar
leol
Posts: 147
Joined: Fri Jan 13, 2012 4:27 pm
Location: Haute-Vienne, France

Re: Camera freezes

Sun Jul 28, 2013 9:48 am

For what it's worth, I have had a similar problem with a new camera. Replaced the ribbon cable - no difference. Unplugged the Sunny connector and reconnected it and every thing works fine.
The connector LOOKED ok, but clearly it was not

Leo

ade
Posts: 1
Joined: Thu Aug 01, 2013 4:07 pm

Re: Camera freezes

Thu Aug 01, 2013 4:10 pm

Hey,
I had this exact problem as outlined in the first two posts. I had really tried everything but what finally solved it was replacing the Pi, not the camera. I did have a WLAN usb device that was apparently broken and plugged in to it at one point, the Pi then crashed hard and messed up the sd card a bit, so that probably fried something on it......

Return to “Camera board”