oystercatcher
Posts: 8
Joined: Wed Nov 16, 2011 10:32 am

raspivid crashes network?

Sun May 19, 2013 9:34 pm

I just got my camera module a couple of days ago and I am having a problem with the
software commands either raspivid or raspistill

I think preview might be part of the problem and I read that the source can be
recompiled to turn off preview. When I try to pass -n the commands fail.

If I am logged into the pi via ssh and run either of the commands the network stack
crashes and the ethernet port loses its ip address. I may try shortly to hard code an
ip address as I am using dhcp for the pi.

If I run raspivid or raspistill from the console I can see the preview and the command
completes but the network goes down anyway.

Just looking for some ideas on what to do next?

patrick in socal

poing
Posts: 1131
Joined: Thu Mar 08, 2012 3:32 pm

Re: raspivid crashes network?

Sun May 19, 2013 9:38 pm

Maybe power issue; the camera draws around 280mA. Others mentioned the Pi crashes or reboots when they activate the camera due to power.

condew
Posts: 3
Joined: Thu Apr 04, 2013 4:47 pm

Re: raspivid crashes network?

Mon May 20, 2013 3:54 am

I saw the same symptom. I was powering my pi from the USB port on my monitor to the micro-usb power input on the pi. While playing with the new camera, I went to check raspberrypi.org for more information and the browser could not find it, nor anything else. I found a simple sequence to reproduce the problem; "ifconfig" to show my network had an ip address, "raspistill" to capture an image, and then "ifconfig" to show my ethernet no longer had an ip address.

I switched to powering the pi vi a hub that backfeeds power thru one of the usb ports and has a beefier power supply that says it produces in excess of 3 amps.

With the new power source, the ifconfig, raspistill, ifconfig sequence worked. Network access was confirmed by viewing the raspberrypi.org site after the image capture.

So I concur, camera use crashing the network connection is probably a power problem.

oystercatcher
Posts: 8
Joined: Wed Nov 16, 2011 10:32 am

Re: raspivid crashes network?

Mon May 20, 2013 10:37 pm

thanks for the input on power being the culprit.
Today I have a small powered hub from gear head model UH5500ESP
raspistill is now working via a bash shell loop

Code: Select all

#!/bin/bash

PIS=/usr/bin/raspistill
SAVEDIR=/home/pi/tmp
PARM01=" -w 640 -h 480 "

for i in `seq  1  20`;
do
filename=$(date -u +"%Y-%m-%d_%H%M%S").jpg
OFILE=$SAVEDIR/$filename
$PIS  -vf  -t 0   $PARM01 -o $OFILE
sleep 5
done
My original AC charger is a cirago
model ZXT138B-2.0 1 A output
but unfortunately not up to the task with the camera module installed.

Void
Posts: 2
Joined: Wed Aug 14, 2013 2:33 pm

Re: raspivid crashes network?

Wed Aug 14, 2013 2:52 pm

Hi, I just had the exact same problem. Using raspivid killed the pi's network. So I connected it with a USB to my laptop which in theory outputs more power then my adapter and problem solved ! :)

Return to “Camera board”