Andybp
Posts: 27
Joined: Mon Oct 01, 2012 5:03 pm

Raspivid crashing with -o - [solved]

Sun May 19, 2013 1:58 pm

So everything's working fine. Nearly

Things like raspivid -o video.h264 works fine which I can play elsewhere no problem. But when I stream netcat I get problems.

I think it's raspivid not working when I don't have an output file. If I run raspivid -o - then I get the preview for about 5 seconds then the machine either hangs, or I get loads of strange characters on the screen. If I clear the screen and type anything it looks like a strange character mapping. Weird behaviour I can emulate always. Tried it on two pis. Tried different power supplies too. Different images. Etc Etc. now run out of ideas

User avatar
fbutler
Posts: 302
Joined: Thu Mar 15, 2012 4:09 pm
Location: Surrey, England

Re: Raspivid crashing with -o -

Sun May 19, 2013 2:04 pm

Andybp wrote:So everything's working fine. Nearly

Things like raspivid -o video.h264 works fine which I can play elsewhere no problem. But when I stream netcat I get problems.

I think it's raspivid not working when I don't have an output file. If I run raspivid -o - then I get the preview for about 5 seconds then the machine either hangs, or I get loads of strange characters on the screen. If I clear the screen and type anything it looks like a strange character mapping. Weird behaviour I can emulate always. Tried it on two pis. Tried different power supplies too. Different images. Etc Etc. now run out of ideas
It's behaving exactly as it should. The -o - option sends the output to stdout which in this case is your screen. You need a to pipe the output into another command using the '|' symbol.

Andybp
Posts: 27
Joined: Mon Oct 01, 2012 5:03 pm

Re: Raspivid crashing with -o -

Sun May 19, 2013 3:17 pm

figured it out.

I noticed that if the listening device is set too early, it appears to drop.

I started them both off within seconds, listener first, and it works...

Happy as a pig in the proverbial.

Thanks.

is the time of 999999 the maximum? I wanted infinity to be honest

User avatar
fbutler
Posts: 302
Joined: Thu Mar 15, 2012 4:09 pm
Location: Surrey, England

Re: Raspivid crashing with -o -

Sun May 19, 2013 3:35 pm

Andybp wrote:is the time of 999999 the maximum? I wanted infinity to be honest
I don't know what the limit is in the demo program, but the source for the demo programs is available at :
https://github.com/raspberrypi/userland ... s/raspicam
So you can modify them work as you require.

Return to “Camera board”