Posts: 3
Joined: Wed May 27, 2020 12:16 am

HQ camera module

Wed May 27, 2020 12:35 am

New to the forum and to the Pi HQ camera....Received camera module last week and after installing M42 to C adapter ring to the camera module and screwing in the Pentax 1:1.4/50 lens and connecting to the RPi then from the terminal and raspistill -o test.jpg . This all resulted in termimal response of "Failed to create camera component" and "Camera is not detected". After double checking all ribbon cable connections with no change in result, I connected a V1 camera and everything worked as normal. The next thing was to swap ribbon cables... V1 camera worked with HQ camera ribbon cable. HQ camera does not work with V1 ribbon cable. My conclusion is that the HQ module is defective. Contacted vendor and they suggested I post here until they can get their camera guru to get back to me. Any one have another outlook on this situation? I will add that I was very careful about static discharge and carefully handling of the camera board.

Posts: 86
Joined: Tue Nov 05, 2013 8:43 pm
Location: Limmen, The Netherlands
Contact: Website Skype

Re: HQ camera module

Wed May 27, 2020 6:33 am

Did you switch camera option on in raspi-config (I guess so since you tested with other camera)?

Did you execute (I'm not 100% sure this is needed).

sudo usermod -a -G video pi

No other experimental camera related settings in the /boot/config.txt?

Did you try the camera icw another RPi board?

What memory split value did you configure?

sudo rpi-update
sudo apt-get update
sudo apt-get full-upgrade

Ribbon cable setup in this way?

Last edited by RoboRob on Wed May 27, 2020 7:31 am, edited 2 times in total.

User avatar
Posts: 358
Joined: Fri Jul 13, 2012 6:01 am
Contact: Website

Re: HQ camera module

Wed May 27, 2020 6:46 am

You did not tell us what version of Raspbian you are using.
Since the hardware seems to work, and software for older camera work it has to be outdated/corrupt software.

So download latest, install on fresh SD card and test again. for Raspberry Pi and Arduino and ESP8266 for retrocomputing with the 6502 cpu

Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 9905
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: HQ camera module

Wed May 27, 2020 9:23 am

Code: Select all

pi@raspberrypi:~ $ vcgencmd get_camera
supported=1 detected=1
If detected isn't one, then it's something in the hardware.
Have you double checked the flexi cable is the right way around at both ends?
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

Posts: 3
Joined: Wed May 27, 2020 12:16 am

Re: HQ camera module

Thu May 28, 2020 4:50 am

Thanks all for your input.

Reseated ribbon cable numerous times as well as checking that cable was inserted correctly.

Ran sudo apt-get update and sudo apt-get upgrade...same result as before.

Ran vcgencmd get_camera and the result was supported=1 detected=0.

Looks like a defective HQ camera module.

Thanks again to everyone who responded.

Posts: 3
Joined: Wed May 27, 2020 12:16 am

Re: HQ camera module

Fri Jun 19, 2020 5:44 pm

Update on HQ camera module....sent first module back to vendor, received replacement module today. Connected it to an RPi 4 and with the M42 to C adapter and the old Pentax 1:1.4/50 Takumar lens, everything works just fine now.


Return to “Camera board”