rbn
Posts: 153
Joined: Tue Dec 27, 2011 8:32 pm
Location: Near Peterborough
Contact: Website

Broken connector clamp on Camera Board

Wed Jan 15, 2020 7:00 pm

The black retaining clip for the ribbon cable connector on my raspberry pi camera board is broken and has disappeared. Any suggestions on acquiring a replacement clip to clamp the cable into the connector? Or suggestions for another solution (not gluing the cable).

pcmanbob
Posts: 7922
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Broken connector clamp on Camera Board

Wed Jan 15, 2020 9:17 pm

The only way to get another clip is to buy a replacement socket of the same type and transfer the clip but you will probably break it anyway as they are not designed to be removed once fitted.

It may even be the socket that was damaged that allowed the clip to drop off.

You could try using some plastic to jam the cable in much like the clip does.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

User avatar
Imperf3kt
Posts: 3202
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: Broken connector clamp on Camera Board

Wed Jan 15, 2020 10:37 pm

Cardboard from a cereal pack or plastic from a milk container, both of these are about the right thickness to friction hold the cable like the original plastic clamp does.
55:55:44:44:4C
52:4C:52:42:41

User avatar
HermannSW
Posts: 1869
Joined: Fri Jul 22, 2016 9:09 pm
Location: Eberbach, Germany
Contact: Website Twitter YouTube

Re: Broken connector clamp on Camera Board

Wed Jan 15, 2020 11:48 pm

Another option is sharing clamp among PIs.
I have several Pi Zeros and don't use them all together at once.
I lost two clamps, but was able to move clamps to the Zeros used.
⇨https://stamm-wilbrandt.de/en/Raspberry_camera.html

https://github.com/Hermann-SW/Raspberry_v1_camera_global_external_shutter
https://stamm-wilbrandt.de/github_repo_i420toh264
https://github.com/Hermann-SW/fork-raspiraw
https://twitter.com/HermannSW

rbn
Posts: 153
Joined: Tue Dec 27, 2011 8:32 pm
Location: Near Peterborough
Contact: Website

Re: Broken connector clamp on Camera Board

Fri Jan 17, 2020 12:39 pm

Thanks to all. I eventually manged it with a piece of card. Not as secure as the original but seems to do OK.

Return to “Camera board”