Ratsima
Posts: 42
Joined: Tue Nov 10, 2015 12:13 am
Location: Korat, Thailand
Contact: Website

FSWEBCAM with old Logitech 1080p Webcam

Thu Jun 27, 2019 2:05 am

I'm just fooling around here, but I'm trying to get fswebcam to work with an old Logitech 1080p Webcam. (No model number on the camera.)

It does take photos, but they seem to be way overexposed. I am using "skip 100" to let the camera settle down a bit, and this does improve the exposure and focus, but the exposure is still very bad.

This is the result of —list-controls:

Code: Select all

Available Controls        Current Value   Range
------------------        -------------   -----
Exposure, Auto            Aperture Priority Mode Manual Mode | Aperture Priority Mode
Exposure (Absolute)       332 (16%)       3 - 2047
Exposure, Auto Priority   True            True | False
Pan (Absolute)            0 (50%)         -36000 - 36000
Tilt (Absolute)           0 (50%)         -36000 - 36000
Focus (absolute)          85 (33%)        0 - 255
Focus, Auto               True            True | False
Zoom, Absolute            1               1 - 5
But I have no idea how to use —set with these options. I am using a config file. When I try:

Code: Select all

set 'exposure' 'manual mode'
set 'exposure' '200'
In the config file, it doesn't change the image a bit, no matter what number I use for the exposure. Granted, I am facing a brightly lit sky, but I should be able to reduce the exposure to the extent that the sky has some color other than bright white.

The man page on fswebcam doesn't give me much of a hint as to how to do this.

TIA
webcam.jpg
webcam.jpg (39.84 KiB) Viewed 710 times

Return to “Camera board”