Page 1 of 1

RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Tue May 07, 2019 9:40 am
by Roger_Thornton
We have been made aware of a manufacturing defect on RPI-CAM2 and RPI-CAM2 NoIR which means the camera will not work on arrival. The affected units are Farnell / Element 14 branded, made in China. Work is underway to resolve the issue; if you believe you have a unit affected please contact the company you purchased it from.


Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Tue May 07, 2019 2:16 pm
by Lee Jackson
Do you have more information about the defect, is there any workaround to fix it by user themselves.
How to distinguish between the common bad connection or wrong software setup issues than this defective batch build?
We usually use "vcgencmd get_camera" command to diagonse what's wrong with the camera.
It will reply "Supported = 1, detected =1" if everything is fine.

Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Thu May 23, 2019 4:57 pm
by harmlessdrudge
I am wondering if I have one of these. I bought one a few days ago and returned it because I couldn't get it to work, although it was detected.

Code: Select all

vcgencmd get_camera
returned "Supported = 1, detected =1", however raspistill ended with
Camera control callback cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

I had checked all the connections, but how I was initially supposed to know what the "Sunny" one was a mystery.

A replacement arrived today and vcgencmd returns "Supported = 1, detected = 0". I am using an RPi3B -- and have had no problem using a NoIR in either Pi2 or Pi3 units (I have 4 in all).

Am now downloading a new NOOBS disk to start from scratch.

One thing I noticed is that the RPI-CAM2 units came with no information sheet in the box, unlike the NoIR unit, nor any explanation what the white plastic ring is for (focus adjustment?). My NoIR unit, about a year old (v2.1) is in a decent quality box labeled Element 14; the newer ones came in flimsier boxes with "Camera Module V2" (913-2664) with RS Components logo but with v2.1 camera inside.

Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Thu May 23, 2019 5:07 pm
by DougieLawson
Have you swapped out the ribbon cable for a known good one?

Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Thu May 23, 2019 6:04 pm
by 6by9
No. Faulty units will report "supported=1 detected=1", but raspivid/still will fail to start.
The "no data received" message will appear after several seconds of running and means that everything is working except for not receiving data over the csi2 bus.

Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Thu May 23, 2019 6:50 pm
by harmlessdrudge
No, I don't have a spare ribbon cable*. It looks fine--no damage or crimps of any kind, though different (first had no markings that I recall; replacement has some parallel lines of text).

*I spent ages getting the NoIR positioned the way I want it in a somewhat awkward place and I don't want to mess with it unless I really have to.

So, the first one was faulty (no data received), and as yet I don't know why the 2nd isn't working. I've reseated the ribbon cable at both ends.

Just to be clear, all I need to do is enable the camera with raspi-config and run vcgencmd get_camera and it should be detected? I have seen advice that I2C needs to be enabled also (I tried it, without result). I've checked config.txt for start_x=1 and gpu_mem = 128.

Reflashing SD card now.

Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Fri May 24, 2019 2:13 pm
by harmlessdrudge
OK, even with a reflashed sd card using NOOBS 3.0.1 and enabling the camera with raspi-config I get

supported=1 detected=0

in response to "vcgencmd get_camera".


Update: changing the ribbon cable didn't work (NoIR camera worked with both cables), nor did enabling I2C.

I've called and arranged for a 2nd replacement. :cry:

Re: RPI-CAM2 and RPI-CAM2 NoIR defect

Posted: Sun Jun 09, 2019 9:06 pm
by harmlessdrudge
Eventually got a good camera that worked first time. Happy with the no quibble replacements.