narragansett
Posts: 19
Joined: Tue Aug 07, 2018 12:34 am

please help -- having problems running raspiraw

Thu Aug 16, 2018 3:45 am

I'm having some issues with running raspiraw. I've tried both branches https://github.com/6by9/raspiraw and https://github.com/Hermann-SW/fork-raspiraw.

I have a version 2.1 camera and Raspberry v3 b+.
Here's what i get when running raspiraw on either version:

[email protected]:~/raspiraw $ ./raspiraw -md 7 -t 300 -ts tstamps.csv -hd0 hd0.32k --height 480 --top 0 --vinc 17 --fps 90 -sr 1 -o /dev/shm/out.%04d.raw
Using i2C device /dev/i2c-0
RaspiRaw: Probing sensor ov5647 on addr 36
RaspiRaw: Probing sensor imx219 on addr 10
RaspiRaw: Probing sensor adv7282 on addr 21
RaspiRaw: No sensor found. Aborting

There are some setup steps described here -- viewtopic.php?f=43&t=189661&p=1232058#p1218763 but when I run the camera-i2c utility it get this:

[email protected]:~/userland-rawcam $ sudo ./camera_i2c
setting GPIO for board revsion: a020d3
Failed: don't know how to set GPIO for this board!

It seems that this is an older version of the camera_i2c utility-- perhaps for the v1 camera board? I compiled the latest code from https://github.com/6by9/userland but it doesn't seem to have the camera_i2c utility.

My v2.1 camera board works....

thanks!

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5816
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: please help -- having problems running raspiraw

Thu Aug 16, 2018 6:25 am

The camera_i2c error would be that a new board revision is now in circulation, and the script doesn't handle it. I'll sort a patch today (6by9/raspiraw only. The userland repo is the old location, and HermannSW 's repo is his to maintain)
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
Please don't send PMs asking for support - use the forum.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

narragansett
Posts: 19
Joined: Tue Aug 07, 2018 12:34 am

Re: please help -- having problems running raspiraw

Thu Aug 16, 2018 12:50 pm

Muchas gracias for the quick reply 6by9!

narragansett
Posts: 19
Joined: Tue Aug 07, 2018 12:34 am

Re: please help -- having problems running raspiraw

Thu Aug 16, 2018 1:25 pm

I didn't notice the camera_i2c script sitting in the https://github.com/6by9/raspiraw repository (oops!) It runs fine for my camera and so does raspiraw (after running camera_i2c) So, all good....

gracias!

narragansett
Posts: 19
Joined: Tue Aug 07, 2018 12:34 am

Re: please help -- having problems running raspiraw

Fri Aug 17, 2018 4:29 pm

Thought I'd share my notes --- the updated setup steps for getting raspiraw running

1. Run
sudo apt-get install wiringpi
2. Add the line
dtparam=i2c_vc=on

to the file /boot/config.txt.

3. Add the line
i2c-dev

to the file /etc/modules-load.d/modules.conf.

4. Now reboot.

5. Run these
git clone https://github.com/6by9/raspiraw.git
cd raspiraw
./buildme
6. Add the line
PATH=~/raspiraw:~/raspiraw/tools:$PATH
to your .bashrc file (~/.bashrc)

7. Bring up a new terminal and run these
cd raspiraw
./camera_i2c
raspiraw -md 7 -t 1000 --height 480 --top 0 -sr 1 -g 240 -e 200 --vinc 17 -o /dev/shm/out.%04d.raw
You should get a bunch of raw frames dumped to your /dev/shm directory.

Note, you'll need to run camera_i2c before you run raspiraw upon each reboot.

thanks!

Return to “Camera board”