pundit
Posts: 11
Joined: Sat Jul 07, 2018 10:01 pm

Cannot connect from Internet to RASPI video

Fri Jul 13, 2018 9:31 pm

G'day all,

This is my little project that I thought of running. However, I'm stuck at the moment and cannot connect to my cam from the internet. Could anyone please shed some light?

Thank you so much.

Aim:

1. Setup a domain (no-ip) so that my home cam can be viewed from any where from the inet through the browser
2. the setup should be protected with a password.
------------------------------------

My current setup:

Modem Netgear DM200 + Router ASUS RT-AC87U
Gateway for the modem - 192.168.5.1
VPN on windows
VPN on RASPI

------------------------------------
What I have done so far:

I have setup a rule in my DM200 to have port forwarding:
External port range 80
Internal port range 5566
Internal IP add 192.168.5.10 (that of my RASPI)
I know my cam works cause i can view it through my RASPI IP and from other computers on my network: http://192.168.5.10:5566/
I have setup the IP target on the no-ip website to be that of the VPN IP on RASPI which is 103.xx.xx.xx
Typing this hostname that is allocated through no-ip shows the site as unreachable from the inet.
------------------------------------

In my RASPI I have in my
/etc/apache2/ports.conf
Listen 5566
ssl
Listen 443

------------------------------------
Questions & thoughts

1. I have the external IP on my modem showing as 84.xxx.xxx.xxx
2. My VPN on my RASPI says my ip is 103.xxx.xxx.xxx
3. There is automatic redirection from 84 to 103
4. How do I get it to go from 103 to thisismypc.org 5566
5. do i need to open up any further port etc on my RASPI

This is what i get when i run my VPN on RASPI
/sbin/ip addr add dev tun0 10.8.8.67/24 broadcast 10.8.8.255
/sbin/ip route add 103.XX.XX.XX/32 via 192.168.5.1
/sbin/ip route add 0.0.0.0/1 via 10.8.8.1
/sbin/ip route add 128.0.0.0/1 via 10.8.8.1

Thanks,
Pundit.

Return to “Camera board”