zetoune
Posts: 6
Joined: Sun May 27, 2018 9:50 pm

RPi can't sent video (and audio) when joining a Jitsi meeting room

Sun May 27, 2018 10:43 pm

Hi there,

I'm trying to make this tutorial: How to join Jitsi Meet video conferences over the Web work.
I've just installed a fresh install of the latest version of Raspbian and all required libraries described in the tutorial.

I'm using the UV4L Streaming Server / Join a Jitsi Meet Room to make the tests. I didn't change anything from the default settings except the name of the room and the username

Image

Long story short, when I try to access a room, I do see the RPi to connect but Jitsi meeting says: "Rpi is having connectivity issues". (member is muted and his camera is off).

Image

Looking at the logs doesn't provide any other directions to debug this issue.

Code: Select all

pi@raspberrypi:~$ sudo journalctl -u uv4l_raspicam.service -f
-- Logs begin at Thu 2016-11-03 13:16:43 EDT. --
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [driver] Selected format: 1920x1080, encoding: mjpeg, JPEG Video Capture
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [driver] Framerate max. 30 fps
May 27 17:37:09 raspberrypi uv4l[343]: <info> [driver] ROI: 0, 0, 1, 1
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [core] Device detected!
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [core] Trying to load the the Streaming Server plug-in...
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [server] HTTP/HTTPS Streaming & WebRTC Signalling Server v1.1.112 built on Feb 25 2018
May 27 17:37:09 raspberrypi uv4l[343]: <warning> [server] SSL is not enabled for the Streaming Server. Using unsecure HTTP.
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [core] Streaming Server loaded!
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [core] Registering device node /dev/video0
May 27 17:37:09 raspberrypi uv4l[343]: <notice> [server] Web Streaming Server listening on port 8080
May 27 17:39:57 raspberrypi uv4l[343]: <notice> [server] WebRTC Renderer extension successfully loaded
May 27 17:39:57 raspberrypi uv4l[343]: <notice> [server] WebRTC, Signalling Server and STUN Server extensions successfully loaded
May 27 17:39:57 raspberrypi uv4l[343]: <info> [server] Connecting to the XMPP Bridge...
May 27 17:40:33 raspberrypi uv4l[343]: <info> [server] Stopping XMPP Session...
May 27 17:45:09 raspberrypi uv4l[343]: <info> [server] Connecting to the XMPP Bridge...
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] connecting preview component...
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Camera ready!
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Camera successfully initialized. Total memory available to the GPU: 256M
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Close down completed, all components disconnected, disabled and destroyed
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] connecting preview component...
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Camera ready!
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Camera successfully initialized. Total memory available to the GPU: 256M
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Close down completed, all components disconnected, disabled and destroyed
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] connecting preview component...
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Camera ready!
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Camera successfully initialized. Total memory available to the GPU: 256M
May 27 17:45:14 raspberrypi uv4l[343]: <info> [driver] Close down completed, all components disconnected, disabled and destroyed
May 27 17:45:15 raspberrypi uv4l[343]: <info> [driver] connecting preview component...
May 27 17:45:15 raspberrypi uv4l[343]: <info> [driver] Camera ready!
May 27 17:45:15 raspberrypi uv4l[343]: <info> [driver] Camera successfully initialized. Total memory available to the GPU: 256M
May 27 17:45:15 raspberrypi uv4l[343]: <info> [driver] connecting preview component...
May 27 17:45:15 raspberrypi uv4l[343]: <info> [driver] Camera ready!
May 27 17:45:17 raspberrypi uv4l[343]: <info> [server] Data Channel created with label: uv4l

Code: Select all

pi@raspberrypi:~$ sudo journalctl -u uv4l_xmpp_bridge.service -f
-- Logs begin at Thu 2016-11-03 13:16:43 EDT. --
May 27 17:39:29 raspberrypi systemd[1]: Starting LSB: XMPP Bridge for UV4L...
May 27 17:39:29 raspberrypi uv4l_xmpp_bridge[1158]: Starting XMPP Bridge for UV4L: xmpp-bridge
May 27 17:39:29 raspberrypi systemd[1]: Started LSB: XMPP Bridge for UV4L.
I want to create a Video-Intercom based on the Rpi and I thought this option should be an easy way to achieve this. Obviously I failed :(
So the RPi should received audio from other users and other users should receive video and audio from the Rpi.

I did try to record a sound from the rpi microphone and it works. Same thing for audio out. I can play mp3 from the pi.


I don't know where to look at to fix the problem.
Any helps would be very appreciated.
Raspberry 3B
Raspbian GNU/Linux 9.4 (stretch)
uv4l: Version 1.9.16 built on Jan 28 2018
Omnivision 5647 Camera
Audio out
Microphone

zetoune
Posts: 6
Joined: Sun May 27, 2018 9:50 pm

Re: RPi can't sent video (and audio) when joining a Jitsi meeting room

Tue May 29, 2018 12:52 am

Still searching & digging...

To see if I could get some other logs from the server, I've installed my own Jitsi Meet server.
I know it works because I could make a meeting between two computers on my LAN. Great!

So I tried to connect the Rpi to this server, still no lucks!
This is what I see from the command "/usr/bin/xmpp-bridge"

Code: Select all

New request
Data bytes available: 16392
Frame received (length=16384, flags=0x82)
Executing message...
Starting session...
connecting...
Message executed
connected
presence sent
presence sent
presence sent
etc...
In the conference room, I see the Rpi avatar but it keeps saying "Connecting..."
I think, it may be a config on the Rpi, but I don't know which one.

Still no one?

Morok
Posts: 1
Joined: Fri Jun 08, 2018 2:04 pm

Re: RPi can't sent video (and audio) when joining a Jitsi meeting room

Fri Jun 08, 2018 2:10 pm

Hi,

I have same issue. I found out, that if you rejoin the room with other member, PRi start to streaming, but I got black screen.

zetoune
Posts: 6
Joined: Sun May 27, 2018 9:50 pm

Re: RPi can't sent video (and audio) when joining a Jitsi meeting room

Sat Jun 09, 2018 11:23 pm

In my case, It doesn't stream at all. When I join with another user in Chrome on my laptop, I only see RPi saying "Connecting..."

Mike W
Posts: 1
Joined: Tue Jun 12, 2018 2:19 pm

Re: RPi can't sent video (and audio) when joining a Jitsi meeting room

Tue Jun 12, 2018 2:24 pm

I have similar issues with Jitsi on the RPi.
In my case I'm using the Pi camera with a RPi 3B+ and I'm getting an error that "the camera doesn't support the required resolution."
I've tested the camera using

raspistill -o cam.jpg

and it works ok.

zetoune
Posts: 6
Joined: Sun May 27, 2018 9:50 pm

Re: RPi can't sent video (and audio) when joining a Jitsi meeting room

Tue Jun 12, 2018 2:40 pm

I have a RPi 3B and Pi Camera clone (GPU 256 MB)

The MJPEG stream from uv4l server (http://<raspberry-ip-address>:8080/stream) does work.

Other error, I can't disconnect the RPi from the chat room. As soon as I try, uv4l server hangs, there is no other solution that rebooting the RPi.

Return to “Camera board”

Who is online

Users browsing this forum: benmaynard and 15 guests