rjhazeld
Posts: 38
Joined: Mon Feb 16, 2015 9:19 am

Raspistill doesn't work but Rpi_Cam_Web_Interface does ?

Sun Aug 27, 2017 10:25 pm

I updated a pi3 with a v2 noir camera board from Jessie to stretch and afterwards raspistill resulted in:
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

The camera is definitely enabled. By accident I opened the Rpi_Cam_Web_Interface web page and was surprised to see the image load. I had previously run apt-get update, dist-upgrade and rpi-update.

Curious I did clean installs from Noobs on a zeroW and a 2b with the same results when I had got the Rpi_Cam_Web_Interface installed correctly (the nginx install needs rpicam amending for the php-fpm socket location used by php 7.0) .

I thought that previously I was able to use raspistill even when the Rpi_Cam_Web_Interface was running.

Is there another update I need to get raspistill working?

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 7313
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Raspistill doesn't work but Rpi_Cam_Web_Interface does ?

Mon Aug 28, 2017 6:12 am

You appear to have rpi cam Web interface running. The camera only supports a single application at a time. Stop rpi cam Web interface and raspistill should work.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

rjhazeld
Posts: 38
Joined: Mon Feb 16, 2015 9:19 am

Re: Raspistill doesn't work but Rpi_Cam_Web_Interface does ?

Mon Aug 28, 2017 3:29 pm

Doh! you are quite right stopping the Rpi_Cam_Web_Interface does allow raspistill to run properly. I guess the problem getting nginx and php working masked the fact that the underlying code was running.

Return to “Camera board”