nprakaz
Posts: 2
Joined: Fri Jul 15, 2016 1:56 pm

Camera V2 not showing in Firefox browser

Fri Jul 15, 2016 2:01 pm

Hi,
I installed the Raspberry Pi Camera V2, and able to take photos via command line using raspistill.

am writing an browser based application that uses getUserMedia to capture photos via Camera.

If i connect USB webCam on my RPi 3, it works great. am able to take photos via Firefox browser.

But Firefox is not able to detect RPi Camera.

Please suggest what could be the cause.

Thanks

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 7734
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Camera V2 not showing in Firefox browser

Fri Jul 15, 2016 2:27 pm

Assuming you've loaded the V4L2 driver with "sudo modprobe bcm2835-v4l2", then it is
https://github.com/raspberrypi/linux/issues/1498 and https://bugs.chromium.org/p/chromium/is ... ?id=616007

I suspect you haven't updated since 31st May or whenever the V4L2 driver "fix" to max the minimum resolution 32x32 instead of 16x16.

But fundamentally this is a Chromium bug in not handling devices that say they there resolution list is of type V4L2_FRMSIZE_TYPE_STEPWISE (or actually anything except V4L2_FRMSIZE_TYPE_DISCRETE)
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

nprakaz
Posts: 2
Joined: Fri Jul 15, 2016 1:56 pm

Re: Camera V2 not showing in Firefox browser

Sun Jul 17, 2016 4:12 pm

Thanks. V4L2 driver installation helped to resolve my issue. now my firefox is able to show the camera video through getUserMedia.

Return to “Camera board”