mastropino
Posts: 3
Joined: Thu Jun 02, 2016 6:26 am

Motion: unable to open video device and grey screen

Thu Jun 02, 2016 6:54 am

Hi everyone ... sorry for my bad English and I'm a newbie of Raspi.
I installed last Raspbian Jessie version 2016-05-27 on Raspberry pi B+ model and Raspberry Pi camera rev 1.3.
After enabling camera from Raspi setup (sudo raspi-config), I installed motion with following instruction:
sudo apt-get install motion
and set up stream_localhost to off, that I can see stream via SSH.
Starting application with:
sudo motion
and opening browser at 192.168.1.x:8081,
there is a gray screen ad displays "Unable to open video device".

I add that Raspistill and Raspivid commands are perfectly working.

Why Motion dooesn't work? Thanks a lot

mastropino
Posts: 3
Joined: Thu Jun 02, 2016 6:26 am

Re: Motion: unable to open video device and grey screen

Thu Jun 02, 2016 2:51 pm

At above link, in paragraph "Installing Motion with a Raspberry Pi Camera" - "Installing software", at step 9, command:
./motion -n -c motion-mmalcam.conf
shows following message:
./motion: error while loading shared libraries: libavformat.so.53: cannot open shared object file: No such file or directory

Maybe is it a issue with the latest version of Raspbian Jessie ?
Should I try again with older version of Raspian ?

TY

lowflyer
Posts: 78
Joined: Sat Jun 01, 2013 2:27 pm

Re: Motion: unable to open video device and grey screen

Mon Jun 06, 2016 10:42 am

See this thread viewtopic.php?p=864996#p864996

Yes it is a jessie issue.

kernel_panik
Posts: 3
Joined: Sun Jun 05, 2016 7:48 am

Re: Motion: unable to open video device and grey screen

Tue Jun 07, 2016 12:31 pm

lowflyer wrote:See this thread viewtopic.php?p=864996#p864996

Yes it is a jessie issue.
Yeah I had this same issue, and used your code lowflyer - all working great alongside motion-notify. Thanks! :)

mastropino
Posts: 3
Joined: Thu Jun 02, 2016 6:26 am

Re: Motion: unable to open video device and grey screen

Tue Jun 07, 2016 4:04 pm

Solved, many thanks !!!

ThomasDr
Posts: 55
Joined: Tue May 20, 2014 2:16 pm

Re: Motion: unable to open video device and grey screen

Tue Jun 13, 2017 1:45 pm

Hallo,

i have the same Problem, i install Rasbian and Motion and all working.
After unplug and move the RPI to the right place i get this error.
Raspistill has given me the right tip, i have only 32 MB gpu splittmemory.
After change to 128 MB Motion work.

regards
ThomasD

Danerys
Posts: 1
Joined: Fri Jun 30, 2017 8:42 am

Re: Motion: unable to open video device and grey screen

Fri Jun 30, 2017 8:48 am

Hallo,

If you are using RPI web cam then try uninstall the fswebcam and start the motion.

I had the similar problem but I used USB webcam and got the same screen "Unable to open video device and grey screen".

I uninstalled RPI webcam interface and installed fswebcam and ffmpeg and started the motion and it worked.

Hope it would work for you also.

Thanks,
Danerys

yash10073
Posts: 2
Joined: Thu Jul 06, 2017 10:44 am

Re: Motion: unable to open video device and grey screen

Thu Jul 06, 2017 10:53 am

hey all, please try to help me. I am running motion and a pi camera for the live feed. The pi is connected to wifi and internet is enabled.SSH is also enabled and cmmands are given using putty. It all works grt, the only issue i m having is that whenevr i plug the ethernet cable from raspberry, the web page freezes and no output even though the pi is still connected via wifi.
i want the pi to be wireless as the camera is on a moving bot.
thank you

udit3012
Posts: 1
Joined: Sat Jul 21, 2018 6:42 pm

Re: Motion: unable to open video device and grey screen

Sat Jul 21, 2018 6:49 pm

I am also having this same issue please help.

My server screen is showing the same thing and i have tried all possible ways to make it correct please help to get rid of this grey screen.

I am using raspberry pi 3b and a camera module of raspberry pi.

Return to “Camera board”