skatedan
Posts: 64
Joined: Tue Nov 24, 2015 11:53 pm

raspicam motion error

Fri Feb 26, 2016 8:18 pm

h guys
when i try to shot a Pic my pi cam return this error message

raspistill -o image.jpg

Code: Select all

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates
how i can solve this problem? And why return this error?

The camera is alredy enabled.
I tried to instal another OS on another SD card but nothing, return equeals issue, should be a cable of raspicam?

User avatar
DougieLawson
Posts: 40171
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: raspicam motion error

Sat Feb 27, 2016 9:52 am

What comes out from a vcgencmd get_camera command?

If all is well with the software / hardware then you should get

Code: Select all

pi@odyssey:~$ vcgencmd get_camera
supported=1 detected=1
pi@odyssey:~$
Have you checked wiring including the little SUNNY connector on the camera board? Does the board LED come on?
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

skatedan
Posts: 64
Joined: Tue Nov 24, 2015 11:53 pm

Re: raspicam motion error

Mon Feb 29, 2016 12:16 am

So, thanks for the reply,
raspberry return me

Code: Select all

supported=1 detected=1
then all work fine, Now i saw that before don t worked because in background worked motion, But I try to Kill motion And shoot Pic, Red led turn on And turn off But i don' t find a Photo

User avatar
DougieLawson
Posts: 40171
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: raspicam motion error

Mon Feb 29, 2016 12:26 am

Try using raspistill

cd /tmp
raspistill -o photo.jpg
ls -la photo*
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

skatedan
Posts: 64
Joined: Tue Nov 24, 2015 11:53 pm

Re: raspicam motion error

Mon Feb 29, 2016 7:22 am

I have tried, return me this error

Code: Select all

mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

User avatar
DougieLawson
Posts: 40171
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: raspicam motion error

Mon Feb 29, 2016 11:43 am

Check the ribbon cable (both ends), check the SUNNY connector on the camera board.
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

skatedan
Posts: 64
Joined: Tue Nov 24, 2015 11:53 pm

Re: raspicam motion error

Mon Feb 29, 2016 11:49 am

all ends of ribbon Cable are connected also the SUNNY connector

User avatar
DougieLawson
Posts: 40171
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: raspicam motion error

Mon Feb 29, 2016 12:20 pm

skatedan wrote:all ends of ribbon Cable are connected also the SUNNY connector
Then your camera board may be dead. Try it on another RPi.
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

skatedan
Posts: 64
Joined: Tue Nov 24, 2015 11:53 pm

Re: raspicam motion error

Mon Feb 29, 2016 12:33 pm

Ou :( But red led turn on off

User avatar
DougieLawson
Posts: 40171
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: raspicam motion error

Mon Feb 29, 2016 5:02 pm

skatedan wrote:Ou :( But red led turn on off
That shows your ribbon cable is probably OK. If it's not the SUNNY connector on the front of the camera that's not fully connected then your camera is dead. Try the thumb & forefinger job where you press (quite hard) on the SUNNY connector until you get a faint but audible click.
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Return to “Camera board”