Duchess
Posts: 2
Joined: Tue Dec 27, 2011 10:03 am

Help sought on Gertboard/ATMega Blink Led issue

Mon Oct 29, 2012 10:15 am

Hi

I bought and constructed the Gertboard kit. The initial led tests work fine.

I set up the atmega stuff according to https://projects.drogon.net/raspberry-p ... duino-ide/

I started the arduino ide, set the board and chip, loaded the blink program and uploaded it. It says all is ok.

With a meter, I can see the voltage on PB5 jumping up to about 0.5v every second. I connect the PB5 pin to BUF1 ping on the board, expecting to see D1 flash, but nothing happens. Could someone point me to what I might be doing wrong please?

Thanks.

Penny

User avatar
Gert van Loo
Posts: 2482
Joined: Tue Aug 02, 2011 7:27 am
Contact: Website

Re: Help sought on Gertboard/ATMega Blink Led issue

Mon Oct 29, 2012 10:34 am

Does the BUF1 blink without being connected?
Have you made sure the BUF1 output jumper is removed?
Otherwise you have two outputs driving the BUF1 input and the 244 buffer is much stronger then your Atmel chip so it will win.

Duchess
Posts: 2
Joined: Tue Dec 27, 2011 10:03 am

Re: Help sought on Gertboard/ATMega Blink Led issue

Mon Oct 29, 2012 10:43 am

Hi Gert

I am not sure what you mean by "Does the BUF1 blink without being connected?"

The cycling voltage on PB5 is there if whether PB5 is connected to BUF1 or not.

There are no other IO jumpers set on the board (I am trying to use the BUF1 connection as a logic probe)

Penny

User avatar
Gert van Loo
Posts: 2482
Joined: Tue Aug 02, 2011 7:27 am
Contact: Website

Re: Help sought on Gertboard/ATMega Blink Led issue

Mon Oct 29, 2012 5:37 pm

Duchess wrote:Hi Gert

I am not sure what you mean by "Does the BUF1 blink without being connected?"

The cycling voltage on PB5 is there if whether PB5 is connected to BUF1 or not.

There are no other IO jumpers set on the board (I am trying to use the BUF1 connection as a logic probe)

Penny
I mean: does the BUF1 LED work as it should?
If you connect the pin to 3V3 does it go ON and if you connect the pin to GND does it go OFF?

Return to “HATs and other add-ons”