jim.glover
Posts: 3
Joined: Sat Jun 16, 2012 6:35 pm

Arduino IDE on Jessie fails

Sun Nov 29, 2015 11:42 am

Raspberry Pi Raspbian Jessie clean install

Then I followed the instructions at
https://projects.drogon.net/raspberry-p ... ation-isp/

This worked on wheezy

On Jessie using either arduino on the command line or the Menu item for Arduino IDE
I get this error.

Exception in thread "main" java.lang.ExceptionInInitializerError
at processing.app.Preferences.save(Preferences.java:735)
at processing.app.Preferences.init(Preferences.java:249)
at processing.app.Base.main(Base.java:117)
Caused by: java.awt.HeadlessException
at sun.awt.HeadlessToolkit.getMenuShortcutKeyMask(HeadlessToolkit.java:234)
at processing.core.PApplet.<clinit>(Unknown Source)
... 3 more

Can someone tell what I have done wrong or am missing?
Thanks

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino IDE on Jessie fails

Sun Nov 29, 2015 9:40 pm

Those instructions are from some time ago.
I have a recollection that the raspbian Arduino IDE was somewhere about v0.6.x at that time.
IIRC jessie now has 1.0.5 so there may have been many internal changes

Milliways
Posts: 315
Joined: Fri Apr 25, 2014 12:18 am

Re: Arduino IDE on Jessie fails

Tue Dec 01, 2015 1:34 am

I haven't actually tried Jessie with the Gertboard, but AFAIK the only changes to avrdude are the configuration files. I have installed the latest Arduino, which includes avrdude: Version 6.1

If you compare /etc/avrdude.conf and /usr/share/arduino/hardware/arduino/boards.txt and ⋯programmer.txt with the modified version you will see changes. Rather than installing the old versions I suggest editing the changes into the new files.

I have been gradually configuring a new installation of Jessie, but had not tackled the Gertboard.

The version of avrdude installed by default with arduino is Version 6.1.
There is no need for a custom avrdude.
This has support for gpio, but it is commented out.

Find linuxgpio in avrdude.conf and uncomment the lines.
Set the pins to the Gertboard values

Code: Select all

reset = 8;
sck = 11;
mosi = 10;
miso = 9;
Include Gordon's changes to boards.txt and programmers.txt, but with the following mods from

Code: Select all

gpio to linuxgpio
gert328.upload.using=linuxgpio
gert328.upload.protocol=linuxgpio

gpio.protocol=linuxgpio

jim.glover
Posts: 3
Joined: Sat Jun 16, 2012 6:35 pm

Re: Arduino IDE on Jessie fails

Tue Dec 01, 2015 2:00 pm

Thanks for your replies.
I have installed the standard arduino and avrdude and made the changes.
Still had the same failure.

The real problem was that my java was defaulting to a headless version - installed for another reason
I configured the java alternative and the Arduino IDE now works again.

Again thanks.

Return to “HATs and other add-ons”