Posts: 35
Joined: Fri Jul 27, 2012 1:47 am

Need VNC Help [Solved]

Tue Apr 30, 2013 4:26 am

I'm trying to use my old iPad 1 as my Raspberry Pi screen. For a while it was ok just using the SSH clients on the iPad to do basic stuff, but for some tasks for a command line noob like me, I just have to have a GUI. I installed a VNC server on my pi for use with my PC, works great, I even got it to start up on boot. Perfect. I have no problem connecting from my PC. However, as soon as I try a VNC client on my iPad, even the ones that claim Linux support, I get an error always along the lines of, "Error: Connection Refused." I've tried plenty of apps too, not just one. Is anybody else experiencing this problem?
Things that maybe you can interpret but I can't:
1. I have a password, I know I'm entering it correctly because it works on PC. Note that if I leave the password field blank in the configuration of the iPad app, it will connect and ask me for a password, but as soon as I give it, it throws the error.
2. I make sure to connect to the same wireless network as the pi and always triple-check that the ip address and all the information are correct.
3. I'm using a VNC client called "tightvnc." It was recommended on some RaspberryPi forum post. This may not be the original VNC client and that may be my problem, but then why would it work on my PC, but not my iPad?
4. Total networking and computer noob. Forgive me if my terminology is off.
Thank you for taking the time to read this!
Last edited by JustPat on Fri May 03, 2013 12:37 am, edited 1 time in total.

Posts: 1395
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: Need VNC Help

Tue Apr 30, 2013 5:24 am

I VNC into my Pi almost daily now from a PDA. Things I can think of that could be sources of your problem:

1. PC and iPad are on different networks?

2. PC is already connected via VNC and you did not enable shared session?

3. VNC may be down on Pi and need restarting?

4. Check display number, it could be wrong.
FORUM TIP: To view someone's posting history, sign in, click on their user name, then on "Search User's Posts." || Running ArchLinuxArm on Model 2B and 512MB Model B

Posts: 35
Joined: Fri Jul 27, 2012 1:47 am

Re: Need VNC Help

Fri May 03, 2013 12:36 am

Update Time
Ok, problem solved. Turns out the "Port" option in all of the mobile device VNC client setups was my problem. I thought that this option had something to do with accessing a VNC server outside of your LAN through a router port, and therefore wouldn't affect me if I was inside my LAN, using the local IP address of the pi. Well, I was wrong. I have no idea what "port" this if referring to, but the port you choose directly affects the display number you have designated to your desktop. I didn't specify, so I assumed it would default to 1. I was correct, however, the mobile app's default is 0, not 1. It made clear the default port was 5900. I suspected this might be the problem so I tried port 1 with no effect. It turns out the port I needed was 5901 and now I'm up and running.
The reason I didn't encounter this problem while connecting via PC is that it doesn't ask for a port, it asks you to use the display number like so:

Return to “Other projects”