xdeveloper
Posts: 1
Joined: Fri Dec 07, 2012 6:49 pm

Attrix Lapdock Keyboard and mouse problem!

Fri Dec 07, 2012 7:00 pm

Hi guys, i have purchased an Attrix Lapdock and got all the connectors/ adapters need to interface it.
i followed many tutorials online in order to hook everything up. the problem is the pi comes up on the screen, but i can't use the lapdock keyboard and mouse. i made the micro usb cable to usb male (connecting the green, white...) correctly. i am using xbmc as the os, but i also tried the Raspbian “wheezy” build as well, i am not sure what seems to be the problem here, if i use an external keyboard and mouse they work with now problem. i tested the lapdock micro usb port and it's giving out +5 when the screen is open and the any key is pressed. The only two things i can think of is:
1) There is some driver that i am supposed to install in order to support the lapdock keyboard and mouse.
2) lapdock micro usb is giving the proper voltage, but not communicating on the green and white wires, anyway to test that ?

thanks,

Liuqahs15
Posts: 21
Joined: Sun Nov 18, 2012 4:17 am

Re: Attrix Lapdock Keyboard and mouse problem!

Sat Dec 08, 2012 2:05 pm

Is there any way you can just test a phone that's actually supposed to work on it? Maybe one of your friends have the phone? It'd be better to see if it does what it's supposed to before you see if it does what you want it to. Might be a bad unit.

colin B
Posts: 119
Joined: Sun Mar 04, 2012 12:23 pm
Contact: Website

Re: Attrix Lapdock Keyboard and mouse problem!

Wed Dec 26, 2012 1:14 am

I think there is some sort of timing problem. I find that sometimes the trackpad and keyboard work and then suddenly they stop, mainly the trackpad followed by the keyboard soon after.

So I think the intermittent nature is the Pi host losing packets which could also account for the combination sometimes working at boot and sometimes not, but I also have a similar problem with the HDMI, and I've yet to find the cause.
On a clear disk one can seek forever

Bowman Cline
Posts: 1
Joined: Mon Dec 31, 2012 3:24 pm

Re: Attrix Lapdock Keyboard and mouse problem!

Mon Dec 31, 2012 5:34 pm

I had a similar experience that I have just worked out.

After modding 2 different cables with no success, I took this approach. I plugged the lapdock modded cable into an XP PC to see if the lapdock USB devices were detected. I ran this test with both cables, one at a time. In one case (using a premade USB splitter with a standard USB A hacked on one end with green, white, and black leads tied down, no shield) - XP could tell something was connected but resulted in an "unrecognized device" error. For the other (hacked like Adafruit video with a high quality cable and tied shield between 3 legs) XP found the keyboard, trackpads, and external mouse connected to a lapdock USB port.

During this exercise, the female micro USB connected has to be seated as far down on the lapdock port as possible. I found it can be hit or miss unless you remove the lapdock port plastic cover.

With port cover removed, with the tested cable properly seated, the RASPI found all lapdock devices and anything connected to it.

Also demonstrated the quality of the cable matters. The cable I mentioned above that failed tests ok for continuity. I would also suggest that the shield is important, at least for both of the RASPI model B units I am using.

DinisCruz
Posts: 1
Joined: Thu Jun 20, 2013 3:41 pm

Re: Attrix Lapdock Keyboard and mouse problem!

Thu Jun 20, 2013 3:44 pm

I having the exact same problem. The Screen works great but the keyboard doesn't (I have now tried on two different LapDocks and both have the same issue).

The mouse actually works , if I use startx to start the X server, the lapdock mouse touch pad mouse works, but the keyboard doesn't

Any other ideas on how to solve this?

pkarmstr
Posts: 1
Joined: Sat Jun 22, 2013 3:35 pm

Re: Attrix Lapdock Keyboard and mouse problem!

Sat Jun 22, 2013 3:39 pm

I had the same problem. The easiest way to test this is to connect the data output usb cord into your computer, and if you have linux, go into the terminal and enter the command lsusb. It should show that a keyboard and trackpad are attached. If nothing is showing up then no data is being transferred and that's why the keyboard isn't working. I bought another micro-usb extension cord and everything worked fine on the next boot-up

Return to “Other projects”