BlackLine
Posts: 1
Joined: Sun Feb 18, 2018 12:02 pm

Web Site Instructions Not Working Help

Sun Feb 18, 2018 12:23 pm

Hi all, Im new to the Raspberry Pi and I have a RPi 3 that I have working well with the Raspbian OS and I have it connected to my home network and I can Putty from my Windows 10 PC to the Pi, I have done an update and upgrade but when I follow the instructions from this site:

http://www.toptechboy.com/tutorial/low- ... ip-camera/

I get to Step 2 and:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-common is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-cgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-common' has no installation candidate
E: Package 'php5-cgi' has no installation candidate
E: Package 'php5' has no installation candidate

so it seems I cant install the Lighttpd Web Server, if I goto the next step ie: sudo lighty-enable-mod fastcgi-php I get:

sudo: lighty-enable-mod: command not found

Is this tutorial out of date or am I missing something? I am trying to make a Security Camera over the local network with WiFi and then later I will use it to remotely access it with my mobile phone so if it is outdated can someone point me in the right direction, Thanks all.

pcmanbob
Posts: 4268
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Web Site Instructions Not Working Help

Sun Feb 18, 2018 2:49 pm

Hi.

It looks like the instructions in the tutorial are out of date.

php5 has been replaced with php7 which is installed using php

You could try replacing php5 with php but there may be other changes you need to make as well, why not contact the writer of the script and ask them to update it.

Code: Select all

sudo apt-get install lighttpd lighttpd-doc php-common php-cgi php zip
note this may not work.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Return to “Other projects”

Who is online

Users browsing this forum: rpdom and 5 guests