DominusPi
Posts: 39
Joined: Mon Nov 18, 2013 5:31 pm

Having issues with a 16x2 LCD..

Thu Jan 30, 2014 6:39 pm

Hey guys, :D

I'm trying to connect a LCD 16x2 display, but as a matter of fact, something is not working well..
What I get when I try to display something is mostly zeros, squares or strange numbers.
I made a vid so it would be easier to understand.
http://youtu.be/CzyPHnNlJaA

I followed this tutorial and copied the exact code + cabling :
http://www.raspberrypi-spy.co.uk/2012/0 ... ng-python/

I'm really not understanding why anymore, checked all cabling .. Do you have any idea where could it come from ? :|
Thanks in advance !

UPDATE : I didn't really change anything but now I get two lines of strange symbols/swuares ..?
UPDATE : No, it just changes whenever it wants ..
Last edited by DominusPi on Thu Jan 30, 2014 6:55 pm, edited 1 time in total.
Cheers !

User avatar
Richard-TX
Posts: 1549
Joined: Tue May 28, 2013 3:24 pm
Location: North Texas

Re: Having issues with a 16x2 LCD..

Thu Jan 30, 2014 6:51 pm

That tutorial is from 2012. The model B moved some pins around so recheck the code vs your pinout.
Richard
Doing Unix since 1985.
The 9-25-2013 image of Wheezy can be found at:
http://downloads.raspberrypi.org/raspbian/images/raspbian-2013-09-27/2013-09-25-wheezy-raspbian.zip

DominusPi
Posts: 39
Joined: Mon Nov 18, 2013 5:31 pm

Re: Having issues with a 16x2 LCD..

Thu Jan 30, 2014 6:56 pm

Richard-TX wrote:That tutorial is from 2012. The model B moved some pins around so recheck the code vs your pinout.
Well that indeed is quite interesting ! I'm gonna give a look at it

EDIT : Tried changing the pins, not having any luck (even worse than before to be fair)
Cheers !

Return to “Graphics, sound and multimedia”