Page 2 of 2

Re: Espeak sounds slow and broken

Posted: Fri Jun 05, 2015 9:52 am
by Micha1982
Since the problem still exist - is there any solution for the espeak-gui?

Re: Espeak sounds slow and broken

Posted: Mon Jun 22, 2015 7:30 am
by nPHYN1T3
Sadly it's half way through 2015, made sure my OS and firmware were up to date today and audio is still horrible on the Pi. I've tried tons of tweaks but audio is always sketchy and crackly at some point but espeak produces another issue...nothing. Which is to say most the discussion on this forum is stuff I've encountered on desktops running lubuntu in the past. Various programs like espeak or beep would output "nothing" or you would have to add crap to espeak to finally get output, something like espeak "padding padding padding test 1 2 3 NOW the voice will start speaking at the word NOW." However at present espeak output is complete silence. No errors no audio.

I was originally working today on streaming audio to the pi to consolidate some audio outputs via pulse audio. I find audio from the other machines does about the same thing. So for example espeak on the other machine works fine if I change the audio to play locally. Pass the audio to the Pi and I get nothing. Use espeak local to the Pi...still nothing. However if I play an mp3 with mpg321/123 I get sound. Play a movie on the other machine, I get the movies sound. Audio from something like the movie eventually lags and locks up but certain things that yield zero output seem to make me think this is the same core problem that would "eat" half the espeak output at times or slow/lag the first bit of a said phrase. Something to do with buffers or some program being compiled to output to OSS and things getting screwed up in the process. Anyhow lots of conjecture but espeak is worse than ever here and I dare say it's related to the fact the Pi's audio is brutally fragile and easily trips, bogs, and dies on the simplest of tasks.

Re: Espeak sounds slow and broken

Posted: Mon Jun 22, 2015 8:35 pm
by nPHYN1T3
Just a quick update as I fooled around more I added a timeout value (24 hours) to my and now I can get a very crackly distorted output from espeak. The strange trade is that with the time out or the suspend module disabled I get smooth short playback like with espeak but can't play "long" things like mp3's or movies. Since I've seen this espeak issue in lubuntu in the past I'm more prone to think this is an issue with oss/alsa routing that is negated perhaps buy more robust applications buffering output where things that don't like espeak get eaten. This may also explain why so many have success if they pipe to a wav then pipe that wav output to aplay or something. So in theory espeak might be fine, it's again the fragile way alsa etc is put together coupled with the pi's bad sample rate conversion and various other problems. I mean it "eats" the espeak output from a lubuntu x64 machine as well. Crappy thing is all my projects lean heavily on espeak and while it might not be broken itself the audio output makes it seem as though it is.

Re: Espeak sounds slow and broken

Posted: Wed Sep 13, 2017 4:56 pm
by xenophod
It's 2017 and it's still a problem.

After fighting with it, I can get espeak to output sound though the HDMI TV speakers. BUT something like: espeak -ven-us+f3 -s99 "hello everyone" clips the first part of the sentence so you only hear: "veryone" . The same thing happens when I pipe it to aplay: espeak -ven-us+f3 -s99 --stdout 'hello everyone' -a300 | aplay

If I make the sentence too long, it of course, starts to lag and get choppy.

Has anyone found a solution to this that I can't seem to find?

Re: Espeak sounds slow and broken

Posted: Thu Sep 14, 2017 7:45 am
by tvjon
This morning I tried building espeak from rhdunn repository on Github, but made the mistake of suffixing the unzipped folder by rhdunn, so I'd remember later where I got it from.

The espeak name is hard-coded into part of the build process so it failed to find a sub directory. I fixed that, rebuilt it (or so it appeared), but after install it still failed to find one of its own shared object libraries.

No time to pursue that currently, but a text to speech is handy sometimes, so I built this:

in about 5 minutes on a RPi 3. Very few warnings during build, & of course, no errors.

Instead of reading the supplied README, I just listened to it via flite, & it was fine, no clipping of the speech, nor missing the start, & quite understandable.

So, "anyone found a solution to this that I can't seem to find?" not directly, but someone may find Flite useful. It actually builds, & works on RPi.

Re: Espeak sounds slow and broken

Posted: Sun Sep 17, 2017 8:14 pm
by jotadepicas
Hi everyone,
I'm facing the same issue, but I noticed it only happens when I specify a particular voice to be used (with -v argument).
If i let the default voice speak, it works fine.

So, could this be related to something in the voices, or some limitation in input/ouput performance when reading voices from sdcard or something like that?

Using the "pipe to aplay" solution works ok for me too (espeak "something to say" --stdout | aplay).