Page 1 of 1

Catch cam stream fails

Posted: Fri May 24, 2013 5:11 pm
by HashberryPee
Hi,

trying to catch the camera stream of my PiCam over Ubuntu 12.04 but receiving machine totally fails:

Code: Select all

nc -l -p 5001 | mplayer -fps 31 -cache 1024 -
results in:
This is nc from the netcat-openbsd package. An alternative nc is available
in the netcat-traditional package.
usage: nc [-46DdhklnrStUuvzC] [-i interval] [-P proxy_username] [-p source_port]
[-s source_ip_address] [-T ToS] [-w timeout] [-X proxy_protocol]
[-x proxy_address[:port]] [hostname] [port]
MPlayer svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing -.
Reading from stdin...
Cache fill: 0.00% (0 bytes)

libavformat version 53.21.1 (external)
Mismatching header version 53.19.0


Exiting... (End of file)


What's going wrong? What can I do?

BR
Michael

Re: Catch cam stream fails

Posted: Sat May 25, 2013 1:08 pm
by tvjon
Try

nc -l -p 5001

& see if it writes lots of chars to the screen.
What's your Picamera statement to send video?

Re: Catch cam stream fails

Posted: Sat May 25, 2013 5:13 pm
by HashberryPee
Solved it!

Turned out that there are different 'nc' on my system! The only 'nc' belongs to openbsd package or so.

Code: Select all

nc.traditional -l -p 5001 | etc...
did the trick.

Thanks anyway for your support. Appreciated!

Re: Catch cam stream fails

Posted: Sat May 25, 2013 6:32 pm
by EnzioBrK
I have the same problem. How did you manage to solve it?

Re: Catch cam stream fails

Posted: Sun May 26, 2013 1:05 pm
by HashberryPee
Are you using Ubuntu as well?
If so you have to install a package called 'netcat-traditional' and you also have to use the command 'nc.traditional' instead of 'nc' otherwise it takes the wrong netcat command, the one that belongs to the package 'netcat-openbsd'.

Re: Catch cam stream fails

Posted: Wed Dec 04, 2013 1:47 am
by pipiloz
Hi there.

I have the same problem. tried nc.traditional -l -p 5001 | etc…

but it complains : -bash: etc...: command not found

have any suggestions?

p-

Re: Catch cam stream fails

Posted: Wed Dec 04, 2013 6:34 am
by HashberryPee
Are you using Ubuntu too?
Have you installed the 'netcat-traditional' Package?
What does it suggest when you write 'nc' into the bash and press tab?