Posts: 3
Joined: Fri Feb 09, 2018 2:59 pm

Issues with Fadecandy and Neopixels

Fri Feb 09, 2018 3:33 pm


I'm having some issues with a project I'm working on - long term goal is to light some LEDs based on microphone input. Based my initial work on many tutorials I've seen for audio spectrum displays, as well as the fadecandy 1,500 NeoPixel LED curtain with Raspberry Pi tutorial.

I'm using a Pi 3B with a Fadecandy board to drive the LEDs. I had this working with 1 panel running on the 5V from the Pi. I moved the panel to a separate power supply, and the LEDs would no longer light from my python scripts or from any of the python or processing examples (that I tried) that come with the fadecandy. The activity light on the fadecandy blinks, meaning it is seeing the commands from the Pi, but nothing on the LEDs.

I've since reverted back to the setup I had that worked, and done quite a bit of debug:

1. Moved neopixel panel back to Pi 5V power supply
2. Swapped in a new neopixel panel
3. Swapped in a new Fadecandy board
4. Swapped in a new Pi 3B

So, essentially replaced each of the major components, and still nothing.

To make things even more interesting, I found that if I try to control the LEDs via the fadecandy web app (localhost:7890), I am able to use the "Test Patterns" to light the LEDs to 50% or 100%.

That led me to think that the hardware is all good and I must have an issue with some configuration file somewhere. So I went nuclear and reinstalled my OS fresh to build things back up from something clean.

Linux raspberrypi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

I installed tightvnc, adafruit-GPIO-halt, and the fadecandy software fcserver, tried out the examples again, and still get an activity light but no LEDs turn on.

With a little more digging, I found that a couple of the fadecandy examples ( and work, will light up LEDs and allow me to change the colors. These may have worked when I first ran into issues as well, but I didn't try them then.

I also found that I can move the fadecandy to my MacBook and control the LEDs with all of the examples there. I left the 5V power on the Pi, so this shows that the fadecandy and LED panel are wired properly.

There's a lot there, hopefully wasn't too hard to follow. Does anybody have any idea what could be going wrong here?

Key Points:
Replaced all hardware
Started from fresh install of Raspbian
Everything works if I move fadecandy USB to my MacBook, but not from the pi
Control via fcserver webapp works
Some example scripts work (possibly they work at a lower level with the fadecandy firmware?)

Thanks a lot!

Posts: 3
Joined: Fri Feb 09, 2018 2:59 pm

Re: Issues with Fadecandy and Neopixels

Sat Feb 10, 2018 10:01 pm

I think I've got it sorted out. Seems to have been an issue with a configuration file. Details in a corresponding thread I created in the fadecandy group, if anyone runs into a similar issue:!topic ... wOkvQAEBOc


Posts: 3
Joined: Thu Aug 09, 2018 6:07 am

Re: Issues with Fadecandy and Neopixels

Thu Aug 09, 2018 6:10 am

Hello people,

I was able to successful complete project with 4661 neopixels, 10 fadecandys and raspberry pi 3 b+.

Any questions or feedback is warmly welcomed.


Return to “Graphics, sound and multimedia”