jonsafc
Posts: 2
Joined: Wed Jan 17, 2018 10:19 pm

Using an External USB DAC on Raspbian Stretch

Wed Jan 17, 2018 10:59 pm

I bought an external DAC (Cambridge Audio DAC Magic XS) to help improve the sound quality of the RPi3 as it sounds terrible through the AUX connection.

When I connect this through the USB port in the back of the RPi3, it shows up within the sounds selector options in the top right of the screen.

I've also checked settings using the terminal to ensure it is being recognised using the following 'aplay -l' and the DAC shows up as 'card 1: C10 [CA DacMagicXS 1.0]'

I've looked all over the internet for solutions to this and tried all of them. However, ones that I've found are for other distros and don't seem to work with stretch. They mainly tell me to change the settings within modprobe and alsa using sudo nano, but nothing seems to work or the file simply does not exist.

I've researched that the file I may need to change is within /usr/share/alsa/alsa.conf. I tried doing this with sudo nano and changed the following:

defaults.clt.card 0
defaults.pcm.card 0
defaultspcm.device 0

to....

defaults.clt.card 1
defaults.pcm.card 1
defaultspcm.device 1

However still no luck. I've puzzled here so could someone help me with changing my RPi3 to using the USB audio device (my external DAC) as the default means of audio output.

Return to “Graphics, sound and multimedia”

Who is online

Users browsing this forum: No registered users and 6 guests