jayshah
Posts: 1
Joined: Thu Jul 19, 2012 9:53 pm

OMXPlayer 0.2 video terminates early

Thu Jul 19, 2012 10:01 pm

I've downloaded the latest Raspbian “wheezy” (2012-07-15-wheezy-raspbian.zip) and noticed that all versions of OXMPlayer including:
  • The version shipped with the distribution
  • 0.2 (Git commits ec4e7bc4, aecc18b3)
  • 0.1 (Git commit aecc18b3)
(http://omxplayer.sconde.net/)

All feature a bug where the videos (tested avi and mp4) do not reach the end (i.e. they cut off early, but the "have a nice day ;)" message is correctly displayed so no sign of Aborted/Segmentation Fault). I have tried nearly all the switches available on the CLI. However, after installing 0.1 0925300b this problem is not present.

Has anyone else seen this, or know of a fix? Ideally I'd like to be able to use the newer versions of OMXPlayer at some point.

Thanks!

dave_p
Posts: 28
Joined: Sun Mar 04, 2012 2:11 pm

Re: OMXPlayer 0.2 video terminates early

Fri Jul 20, 2012 12:08 pm

Looking at the commits between your working and non-working versions this change looks suspicious:

Code: Select all

+  /* seek behind eof */
+  if((seek_pts / AV_TIME_BASE) > (GetStreamLength()  / 1000))
+  {
+    m_eof = true;
+    UnLock();
+    return false;
+  }
If I read this correctly the video could be stopped early due to the way the check in the second line is written, but the effect would only be to shorten playback by less than one second.

You could log an issue at https://github.com/huceke/omxplayer.


Narf03
Posts: 243
Joined: Mon Jun 11, 2012 3:44 pm
Location: Malaysia

Re: OMXPlayer 0.2 video terminates early

Sat Jul 21, 2012 1:07 pm

wanted to report the same issue, play mp3 with omxplayer, the song terminate VERY early, not few seconds, perhaps 30-60% earlier.

hp1337
Posts: 3
Joined: Mon Jun 18, 2012 5:45 pm

Re: OMXPlayer 0.2 video terminates early

Sun Jul 22, 2012 6:43 am

I am seeing this issue as well.

User avatar
ph0ng
Posts: 38
Joined: Tue Jul 17, 2012 9:37 am
Location: Sweden

Re: OMXPlayer 0.2 video terminates early

Sun Jul 22, 2012 6:32 pm

If you are compiling the program yourself, apply for following fix: https://github.com/huceke/omxplayer/iss ... nt-6800379

If not, I guess you have to wait for the project manager to update the sources.

derrickcope
Posts: 6
Joined: Mon Jun 18, 2012 1:59 am

Re: OMXPlayer 0.2 video terminates early

Tue Jul 24, 2012 6:06 am

hi, I am having the same issue. I got sound and video working great through hdmi by purging and reinstalling but it will only play about 90sec of any file. then it shuts of and wishes me a nice day. What's up. Any solution on this?

KenT
Posts: 758
Joined: Tue Jan 24, 2012 9:30 am
Location: Hertfordshire, UK
Contact: Website

Re: OMXPlayer 0.2 video terminates early

Tue Jul 24, 2012 6:56 am

Its happening. See https://github.com/huceke/omxplayer/issues issue 23
Pi Presents - A toolkit to produce multi-media interactive display applications for museums, visitor centres, and more
Download from http://pipresents.wordpress.com

raha0007
Posts: 8
Joined: Wed Jul 18, 2012 10:16 am

Re: OMXPlayer 0.2 video terminates early

Thu Jul 26, 2012 2:07 pm

Imhaving the same issue and this is supposed to be the fix

https://github.com/torarin/omxplayer/co ... 286b8647f2
according to this
https://bugs.launchpad.net/raspbian/+bug/1028945

Unfortunately I have no experience compiling things or anything like that.

Return to “Graphics, sound and multimedia”