Page 1 of 1

jackd and IQaudio i2s-bus card not working

Posted: Wed Mar 04, 2015 4:54 pm
by rbn
I have an IQaudio dac+ card and am trying to get it to work with Sonic Pi. This (normally) uses jackd to connect to the inbuilt BCM2835 sound module, but I can't get jackd to connect to the IQaudio card. It says mmap-based access is not possible for this card. Anyone managed to get this to work or have any suggestions?
I gather the HiFiBerry DAC+ card has the same problem.
The IQaudio card woks ok otherwise eg aplay -D hw:0 test.wav works fine.
Running on a Pi2 with latest Raspian distro, and sound card configured using device_tree_overlay iqaudio-dacplus-overlay.dtb set up in the boot config.txt file

Re: jackd and IQaudio i2s-bus card not working

Posted: Wed May 25, 2016 5:36 pm
by stuzog
The solution is given at:

<!topic ... vkSTW0Cqnk>

Thanks to the above advice, I got Sonic Pi running on a Pi2 with a HiFiBerry DAC+ using the latest Raspbian, but the sound is stuttering with a regular clicking sound, about 4-6 clicks/sec (guesstimate). I've tried changing the frame buffer to 4 and 5, but no success.

Does anyone have any ideas about how to fix this?

Re: jackd and IQaudio i2s-bus card not working

Posted: Fri May 27, 2016 9:58 pm
by rbn
I Also get the stuttering effect when using IQAudio card on the latest Rasbian 2016-05-10
This is when using it with Sonic Pi 2.10 also on the distribution. In previous versions of Raspbian it has worked fine, so something has changed in the latest one. The card works fine when playing wav files directly using aplay soundfile.wav, so I suspect something has upset the operation of jackd which Sonic Pi used to connect to the card.