tammclaughlin
Posts: 1
Joined: Sun Mar 01, 2015 6:19 pm

Problem with midi out on Pi 2

Sun Mar 01, 2015 6:46 pm

I have an issue with the output from qsynth where the audio seems to have some kind of interference.
It's difficult to describe but it sounds as if the audio it is cutting out 10 to 50 times per second or as if a singe short note is being repeated during the duration. I can change instrument selection so piano sounds like a piano and a snare drum like a snare drum so I don't think it's bad sounds fonts.

I can play a midi file ok with timidity and mp3 playback is fine.
I have been using a usb midi keyboard, jack and qsynth. They all work fine on my laptop but not through the raspberry pi 2.
I have eliminated the keyboard and tried hydrogen, the jack keyboard and the same issue appears.
I have tried various combinations of settings from adding additional sounds fonts to changing hardware selections, duplex settings on jack, rebooted and even updated raspbian but still have the same issue. I am at a loss as I can't see any errors and the various messages screens for jack and qsynth don't give anything away.

I even considered that it could that I had 4 usb devices in use without the use of a powered hub so removed everything apart from the midi keyboard and still had the same issues.

Any ideas on how I can debug this?

treeHouse
Posts: 29
Joined: Sat Aug 06, 2016 2:35 am

Re: Problem with midi out on Pi 2

Sun Mar 19, 2017 2:48 pm

I know this is an old post, but I had the same question, and wasted far too much time finding an answer.

(Note: This may only apply to those using the built -in sound.)

*****
Whether you are running through jack, or just alsa straight into qsynth, make sure the buffer counts are >= 4.
*****

The default is 2, and that causes the intermittent-ness.

May you fellow pi/qsynth explorers be free of our headache!

Return to “Graphics, sound and multimedia”