FM Radio....

28 posts   Page 1 of 2   1, 2
by mikerr » Sat Jul 14, 2012 4:09 pm
The beginnings of a car radio project...

I've found this old radio card I had lying around and it is supported by Debian Wheezy on Pi:
finstantfmmus.jpg (4.53 KiB) Viewed 16780 times

but no radio app is installed by default in X,

I'll be running in console anyway, so I went to get a radio app:
Code: Select all
sudo apt-get install radio

radio -s

(the -s auto scans for stations)

radio.png (12.51 KiB) Viewed 16780 times

Not pretty, but it'll be used without a monitor, with a few buttons on the GPIO pins.

"Stay tuned" for the rest of the project....
Android app - Raspi Card Imager - download and image SD cards - No PC required !
User avatar
Posts: 2403
Joined: Thu Jan 12, 2012 12:46 pm
Location: Up north , UK
by david_Est » Thu Sep 06, 2012 5:14 pm
What is the exact model of the radio? would this: ... B000HNHA12 work on raspberry?
Posts: 7
Joined: Sun Jun 17, 2012 4:58 pm
by mario » Thu Sep 20, 2012 2:21 pm
Does this device work directly connected to the onboard USB ports or do you have to use a powered hub?

Maybe there´s a way to use this FM receiver to send remote commands to the Raspi.
Posts: 1
Joined: Thu Sep 20, 2012 2:18 pm
by pygmy_giant » Thu Sep 20, 2012 5:11 pm
You have more pi's and hardware than is healthy for one person - you can get help, but first you have to admit you have a problem.
Ostendo ignarus addo scientia.
Posts: 1562
Joined: Sun Mar 04, 2012 12:49 am
by ghans » Thu Sep 20, 2012 9:11 pm
I agree with pygmy_giant. :lol:
Nice post as always , mikerr :D

• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere
Posts: 7203
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany
by mikerr » Fri Sep 21, 2012 8:32 am
Lol - too many pi you say ? Never...

I do hoard old hardware, but "it'll come in useful one day" :)
Android app - Raspi Card Imager - download and image SD cards - No PC required !
User avatar
Posts: 2403
Joined: Thu Jan 12, 2012 12:46 pm
Location: Up north , UK
by bonelifer » Fri Sep 21, 2012 7:21 pm
I got the US radio awhile ago and it's just set around due to other things. I wonder do you know what kind of plug the antenna is using? Thinking of trying to flush mount a panel mount on the back of the case.
User avatar
Posts: 127
Joined: Thu Jan 12, 2012 4:01 am
by bonelifer » Sat Nov 03, 2012 10:17 pm

Wish there was a addon for XBMC.
User avatar
Posts: 127
Joined: Thu Jan 12, 2012 4:01 am
by canibalimao » Tue Dec 18, 2012 2:13 pm
I want something like this too, but I think I can't get one of those dongles here in Europe. Anyone knows if there is other devices compatible with the RPi?
Posts: 556
Joined: Tue Aug 07, 2012 8:48 pm
Location: Portugal
by officerNordberg » Fri Jan 04, 2013 2:18 am
Any luck with this? I've got the same dongle and it finds stations on scan but I cannot hear any audio. I've tried radio and I've tried piping arecord to aplay.
Posts: 1
Joined: Wed Jan 02, 2013 4:24 am
by dhead » Thu Feb 28, 2013 12:59 am
I also struggle to get this device work in linux.
I believe the issue is that the firmware of the device isn't updated.
I've complied an updated firmware from the sources on silabs site as binary and hex files but I don't have any suitable programer (and won't get one just for this).
There was an initial support for flashing the firmware on linux but it never made into linux, I've tried to get these changes into a more recent driver but had some issues with it.
Posts: 10
Joined: Fri Apr 06, 2012 4:31 am
by tonyhughes » Thu Feb 28, 2013 1:19 am
MMmm.... I think I want to do this, to roll my own podcasts of radio shows that don't have podcasts.
User avatar
Posts: 950
Joined: Wed Dec 26, 2012 3:46 am
by JustJ » Fri Mar 15, 2013 1:40 pm
Hi mikerr,

you've left us hanging. Does this really work? I have one of these devices - Instant FM Music, Part Number: RDX-155, FCC: LL5-RDX-155. Is this the one you have? I tried this with Raspian(Kernel: Linux raspberrypi 3.6.11+) but can't get it to work. "radio -s" complains that there is no radio0 file or directory. Please help with your configuration. Appreciate a response. Thanks much.
Posts: 4
Joined: Fri Mar 15, 2013 12:43 pm
by JustJ » Sun Mar 17, 2013 12:16 am
I tried this USB radio on Ubuntu today and it works(as per the instructions here). Three modules are necessary:


Number 2 and 3 are already available on the Pi.
The module(driver) missing for the ADS RDX-155 to work on Raspbian is not compile on the image that I am currently using (Linux raspberrypi 3.6.11+ #371 PREEMPT Thu Feb 7 16:31:35 GMT 2013 armv6l GNU/Linux). Can someone please compile and post the module for si470x(radio-usb-si470x)? Thanks much.
Posts: 4
Joined: Fri Mar 15, 2013 12:43 pm
by JustJ » Tue Mar 19, 2013 1:22 pm
Finally got this thing working. The latest Wheezy Raspbian image( not does come wit the radio-si470x-usb module. I cross-compiled my own kernel and modules on Ubuntu 12.04 64bit and now can use the USB radio on the PI. Audio from the USB card must be piped to the sound card using arecord and aplay like this:

arecord -q -c 2 -D hw:1,0 -r 96000 -f s16_LE | aplay -q -B -

Now I'm faced with another big issue - Underruns!!! A loud popping noise is sent through my speakers each time(approx every second) an underrun is experienced making the radio virtually unusable. Can anyone help with this issue? Thanks in advance.
Posts: 4
Joined: Fri Mar 15, 2013 12:43 pm
by dhead » Thu Mar 21, 2013 7:28 am
JustJ, thanks for the hints.
I've finally stopped working with vm's and installed linux on my laptop and the device works flawlessly.
I'm using fmtools to tune in and arecord|aplay to listen to the stream.
I've no issues with the device, maybe your issue related to usb power issues, try a powered usb hub.

The next step for me will to find the best way to use the tuner with xbmc.
One solution is to use vdr's vdr-plugin-pvrinput, I'm not sure if this works with usb radio tuners.
Second solution is to broadcast the stream and to use ssh to send tune commands.
My favorite solution would be to find a way to use the device with tvheadend, a quick solution would to broadcast the stream over ip and use tvheadend to initiate a tune fm command when activating the channel, this would need some coding and I have a pretty basic knowledge in c and no much in c++ but I'm guessing others will have interest in initiating commands on channel switch because this also will enable to initiate lirc command through ir blaster, so it might be a good project.

I'm still looking for other devices,
the good old wintv pvr usb2 should work great with vdr-plugin-pvrinput and it can tune also to am,
Rtl-sdr is also a cheap and capble and if I understood correctly with the proper hardware adjustments it can tune to am, I didn't had success with the rtl_fm tool, although I can tune with sdr# but it's quiet heavy on resources.
And of course there are more diy project especially for the Raspberry Pi, but currently I'm looking for the faster to get this up and running and for a platform dependent solution.
Posts: 10
Joined: Fri Apr 06, 2012 4:31 am
by JustJ » Thu Mar 21, 2013 12:25 pm
It works well on my desktop. I've tried it with Gnome Radio and the terminal "radio" app and I have no problems. The audio underrruns are only being experienced on the Pi. I ordered a power USB hub and will report back when it arrives. But I have read numerous posts on the Internet with folks complaining about USB sound cards on the Pi. Hopefully it's not that. Do you have a Pi with a powered USB hub? Maybe you can tell me how this works for you. Thanks.
Posts: 4
Joined: Fri Mar 15, 2013 12:43 pm
by dhead » Fri Mar 22, 2013 11:44 am
I haven't tried it with my Raspberry, yet, and giving this a second thought maybe limiting the usb hub on the Raspberry to usb1.1 as done with external usb sound cards also will fix this issue, meaning adding dwc_otg.speed=1 to cmdline.txt.
The issue with this solution is that you're limited to use devices that support usb1.1, this can be problomatic with usb keyboards and mice.
Posts: 10
Joined: Fri Apr 06, 2012 4:31 am
by bboyandru » Sun Jul 07, 2013 10:02 am

I have the same radio adapter, bought from eBay( The device works perfectly on my Ubuntu machine(radio-usb-si470x is enabled in the kernel).
I have tried to make it work under Raspberry PI and had couple of issues(compile issues) in building kernel 3.6.y and 3.8.y with support for radio-usb-si470x and snd_usb_audio. I have managed to build the kernel 3.10.y with bcmrpi_quick_defconfig as base configand above modules enabled.
I have installed radio and also fmtools and radio is working fine:
radio -s - radio is scanning the whole frequency band and store some frequencies
arecord -q -c 2 -D hw:1,0 -r 96000 -f s16_LE > test.wav - is recording from radio in the test.wav file and sound is high quality
aplay test.wav or omxplayer test.wav or mplayer test.wav is playing the file and the sound is verry good.
I have tried to play the sound without recording, using arecord -q -c 2 -D hw:1,0 -r 96000 -f s16_LE | aplay but the sound is rubbish and after a couple of seconds the radio stops working and a lot of underrun messages are shown.
I have tried to play the sound using mplayer(as it works under Ubuntu desktop):
mplayer -radio adevice=hw=1.0:arate=96000 -rawaudio rate=96000 radio//103.8/capture
But the problem is that mplayer(sudo apt-get install mplayer) is not build with radio support.
I have removed mplayer(sudo apt-get remove mplayer libx264-123) and build mplayer from source using the tutorial from and adding --enable-radio and --enable-radio-capture at ./configure. The problem is that nothing is output on the speakers, through analog output.
Posts: 24
Joined: Thu Feb 14, 2013 7:34 am
by ronlh1 » Mon Nov 25, 2013 5:13 pm
I have the same radio and am unable to get it to work.
Could someone post instructions as to import the correct modules into Raspbian.

Posts: 1
Joined: Thu Jan 26, 2012 2:04 am
by Douglas6 » Mon Nov 25, 2013 5:46 pm
pygmy_giant wrote:You have more pi's and hardware than is healthy for one person - you can get help, but first you have to admit you have a problem.

I have five Pis, but I can quit anytime....
User avatar
Posts: 3808
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL
by Activiti » Fri Nov 29, 2013 12:20 pm
Hi Geeks,

Any one knows if RPI can handle 2 cards at the same time ? I mean if i can record two channels at the same time with 2 cards pluged on the RPI USB's.

Best Regards,
Posts: 1
Joined: Fri Nov 29, 2013 12:16 pm
by robocop » Mon Feb 10, 2014 4:16 am
Hello RPi People!

I am another one that is trying to get a decent sound from the InstantFM radio USB, without any good results.

I arecord the sound and when I aplay what I recorded is in very high speed. Is like I have tape it in 33rpm and I am playing it in 45rpm. for the ones that remember the LP Pasta players.

Seems like the Radio is running (sample rate) 96000 and the USB port can not handle that speed maybe only 48,000. Question for the Drivers Developers? How can I change the Sample Rate on this (InstantFM) device? Is there any ALSA configuration file that I can force a Sample rate? or change the number of channels from Stereo to Mono?

If there is anyone that may have a little Idea on how to put this device to work, please let us know and maybe get a video to show how well it works, because meanwhile I do not see anyone in the Internet that has it working well.

Thanks again, and Happy RPi Developer.

Pablo Arthur
Dominican Republic
Posts: 3
Joined: Mon Feb 10, 2014 4:08 am
by fher98 » Wed Oct 15, 2014 10:10 pm
Hello everyone.... any luck getting this working with XBMC?

I have one that I never got to use on my old pc, so now Im trying to use it in XBMC. Any help or link that I can read

Posts: 3
Joined: Mon Dec 31, 2012 5:13 am
by Dionysus » Sat Feb 07, 2015 3:41 pm
I have the ADS Instant FM Music USB radio and can't get it to work with my Pi.


Bus 001 Device 008: ID 06e1:a155 ADS Technologies, Inc. FM Radio Receiver/Instant FM Music (RDX-155-EF)

When I use fmtools it says Radio is on at 100.00% volume. If I unplug the USB radio it will say /dev/radio0 does not exist. I plug it back in and it runs without error.

Is it working and how do I get the audio from it?

I have a USB DAC if that helps/hurts me. I am able to play mp3's through it just fine.
Posts: 4
Joined: Sat Aug 09, 2014 2:06 pm