User avatar
shawaj
Posts: 121
Joined: Wed Oct 03, 2012 3:36 am

TIDAL Connect installation!

Thu Jan 07, 2021 4:01 pm

Put together a little installer for TIDAL connect support on Raspberry Pi

Thought there might be some people in here interested...

https://github.com/shawaj/HiTide

Thinking to package this up into a debian package at some point when I have more time. PRs and stuff welcome.

Let me know how you get on.
Support The MagPi by purchasing printed copies from one of our retailers - http://themagpi.com/en/buy

Please share with anyone who is interested!

ayyy
Posts: 2
Joined: Sun Jan 24, 2021 3:22 pm

Re: TIDAL Connect installation!

Sun Jan 24, 2021 3:26 pm

Thanks for sharing this - was straightforward on Raspbian Buster, Pi 3 Model B.

I was able to get audio output through the analog out straightaway, however when I tried to use my Khadas Tone Board (USB) I found that Tidal started skipping through the song - I think this is related to sampling rates/timing. I'll have a look into this and report back. If you have any suggestions please let me know.

I have previously used the Khadas with mopidy-spotify with no problem, so I am sure it's just a settings issue.

asifjahmed
Posts: 2
Joined: Mon Jun 15, 2015 3:10 pm

Re: TIDAL Connect installation!

Mon Jan 25, 2021 2:10 pm

I too would LOVE to get this working!!!

I was able to run the installer on a Raspberry Pi 4 Model B, the Tidal connect client shows up in Tidal on iOS, but when I connect to it the song rapidly skips through to the end. I haven't tried without a USB DAC, however, only with the Topping E30 DAC connected via USB.

If we can sort through these issues, this Tidal connect installer for the Pi will be worth its weight in gold!!!

ayyy
Posts: 2
Joined: Sun Jan 24, 2021 3:22 pm

Re: TIDAL Connect installation!

Mon Jan 25, 2021 7:17 pm

asifjahmed wrote:
Mon Jan 25, 2021 2:10 pm
I too would LOVE to get this working!!!

I was able to run the installer on a Raspberry Pi 4 Model B, the Tidal connect client shows up in Tidal on iOS, but when I connect to it the song rapidly skips through to the end. I haven't tried without a USB DAC, however, only with the Topping E30 DAC connected via USB.

If we can sort through these issues, this Tidal connect installer for the Pi will be worth its weight in gold!!!
Which quality settings did you get this behaviour with? I saw it with Standard and High (I'm on a free trial without HiFi and MQA)

landmarker
Posts: 3
Joined: Sun Jan 31, 2021 5:47 pm

Re: TIDAL Connect installation!

Sun Jan 31, 2021 6:08 pm

Thank you so much for posting this.

I had to make take a few addional steps to get this working with a USB DAC, based on what you described in https://github.com/shawaj/ifi-tidal-release, but not exactly the same.

In between the steps
# correct permissions
and
# deploy files

1. identify the name of your DAC in the PortAudio devices list e.g.:

Code: Select all


/usr/ifi/ifi-tidal-release/pa_devs# more devices
device#0=bcm2835 HDMI 1: - (hw:0,0)
device#1=bcm2835 Headphones: - (hw:1,0)
[color=#0000FF]device#2=ADI-2 DAC (56760416): USB Audio (hw:2,0)
[/color]device#3=sysdefault
device#4=alsaequal
...
2. add this corresponding argument under the "ExecStart=..." statement in /usr/ifi/ifi-tidal-release/ifi-streamer-tidal-connect.service

Code: Select all

--playback-device "ADI-2 DAC (56760416): USB Audio (hw:2,0)" \
I now have a fully functional Tidal connect endpoint, working from the native Tidal app on phone or PC. In my case I installed on top of Moode. Streaming is working up to Master quality, confirmed by the input display on my DAC. This is so much better than the horrible Volumio integration.

MatteoEng
Posts: 2
Joined: Tue Feb 02, 2021 11:20 am

Re: TIDAL Connect installation!

Tue Feb 02, 2021 11:24 am

Hi, how did you start the service? It always gives me error, how precisely I have to change the "ExecStart" in the ifi-streamer-tidal-connect.service file? Thanks

MatteoEng
Posts: 2
Joined: Tue Feb 02, 2021 11:20 am

Re: TIDAL Connect installation!

Tue Feb 02, 2021 2:41 pm

Well I actually need to correct myself, I did all the things in the correct way, then when I start the service he continues to go down, sometimes he turn on again but it stands like for 10ms, any suggest ?? Thanks
-Matteo

jonthebeef
Posts: 1
Joined: Wed Feb 03, 2021 1:37 pm

Re: TIDAL Connect installation!

Wed Feb 03, 2021 1:40 pm

Hi. I'm a noob, so sorry if this a nooby question. How were you able to install alongside Moode? I'm running this on a little server that's served me well, but would love tidal connect on there too. How would I install that alongside Moode?
landmarker wrote: Thank you so much for posting this.

I had to make take a few addional steps to get this working with a USB DAC, based on what you described in https://github.com/shawaj/ifi-tidal-release, but not exactly the same.

In between the steps
# correct permissions
and
# deploy files

1. identify the name of your DAC in the PortAudio devices list e.g.:

Code: Select all


/usr/ifi/ifi-tidal-release/pa_devs# more devices
device#0=bcm2835 HDMI 1: - (hw:0,0)
device#1=bcm2835 Headphones: - (hw:1,0)
[color=#0000FF]device#2=ADI-2 DAC (56760416): USB Audio (hw:2,0)
[/color]device#3=sysdefault
device#4=alsaequal
...
2. add this corresponding argument under the "ExecStart=..." statement in /usr/ifi/ifi-tidal-release/ifi-streamer-tidal-connect.service

Code: Select all

--playback-device "ADI-2 DAC (56760416): USB Audio (hw:2,0)" \
I now have a fully functional Tidal connect endpoint, working from the native Tidal app on phone or PC. In my case I installed on top of Moode. Streaming is working up to Master quality, confirmed by the input display on my DAC. This is so much better than the horrible Volumio integration.

landmarker
Posts: 3
Joined: Sun Jan 31, 2021 5:47 pm

Re: TIDAL Connect installation!

Thu Feb 04, 2021 10:02 am

MatteoEng wrote:
Tue Feb 02, 2021 2:41 pm
Well I actually need to correct myself, I did all the things in the correct way, then when I start the service he continues to go down, sometimes he turn on again but it stands like for 10ms, any suggest ?? Thanks
-Matteo
I'm not sure I can help - I didn't have to do anything special to get the service to start, it worked when I followed steps described in the script

landmarker
Posts: 3
Joined: Sun Jan 31, 2021 5:47 pm

Re: TIDAL Connect installation!

Thu Feb 04, 2021 10:04 am

jonthebeef wrote:
Wed Feb 03, 2021 1:40 pm
Hi. I'm a noob, so sorry if this a nooby question. How were you able to install alongside Moode? I'm running this on a little server that's served me well, but would love tidal connect on there too. How would I install that alongside Moode?
landmarker wrote: Thank you so much for posting this.

I had to make take a few addional steps to get this working with a USB DAC, based on what you described in https://github.com/shawaj/ifi-tidal-release, but not exactly the same.

In between the steps
# correct permissions
and
# deploy files

1. identify the name of your DAC in the PortAudio devices list e.g.:

Code: Select all


/usr/ifi/ifi-tidal-release/pa_devs# more devices
device#0=bcm2835 HDMI 1: - (hw:0,0)
device#1=bcm2835 Headphones: - (hw:1,0)
[color=#0000FF]device#2=ADI-2 DAC (56760416): USB Audio (hw:2,0)
[/color]device#3=sysdefault
device#4=alsaequal
...
2. add this corresponding argument under the "ExecStart=..." statement in /usr/ifi/ifi-tidal-release/ifi-streamer-tidal-connect.service

Code: Select all

--playback-device "ADI-2 DAC (56760416): USB Audio (hw:2,0)" \
I now have a fully functional Tidal connect endpoint, working from the native Tidal app on phone or PC. In my case I installed on top of Moode. Streaming is working up to Master quality, confirmed by the input display on my DAC. This is so much better than the horrible Volumio integration.
I connected to Moode pi thorugh SSH then ran the steps in the installation script.

Man in a van
Posts: 213
Joined: Sat Dec 27, 2014 2:41 pm
Location: Staffordshire, UK.

Re: TIDAL Connect installation!

Fri Feb 05, 2021 10:31 am

@shawaj

Hi Aaron

I had a bash with your HiTide on a rpi3b+, updated Raspberry PI OS Desktop and iFi Audio iDSD nano usb dac.

After a few attempts (I have a problem with PulseAudio recognising the dac) I determined my approach, in the following manner.

I opened the install.sh file and ran the commands manually.

After performing the permission changes I followed the advice from @landmarker and reset the output device.

Code: Select all

nano /usr/ifi/ifi-tidal-release/pa_devs/devices

device#0=bcm2835 HDMI 1: - (hw:0,0)
device#1=bcm2835 Headphones: - (hw:1,0)
device#2=iFi (by AMR) HD USB Audio: - (hw:2,0)
device#3=sysdefault
device#4=lavrate
device#5=samplerate
device#6=speexrate
device#7=upmix
device#8=vdownmix
device#9=default
Number of devices = 10

Also I added

Code: Select all

systemctl enable ifi-streamer-tidal-connect.service
so that HiTide would start on reboot

Thanks, it seems fairly stable at the moment.
I'm using the HiFi quality setting in Tidal. ;)

Image

mrozmus
Posts: 1
Joined: Sat Feb 06, 2021 4:27 pm

Re: TIDAL Connect installation!

Sat Feb 06, 2021 4:38 pm

Hi guys

Can you help me to run this on my raspberry? I have no clue how to do it. Im not a programist and start raspbery with spotify was full day job for me:/
I use my raspbery with digi + pro like a transport and use spotify connect.
Thank you in advance

neaman_ahmed
Posts: 1
Joined: Wed Feb 17, 2021 6:39 am

Re: TIDAL Connect installation!

Wed Feb 17, 2021 6:44 am

I have been using this for 2 weeks and it fantastic , better sound then using tidal on pc , but I have problem , every i have to install again other wise service dont start.
I use this to install "curl -sSL https://raw.githubusercontent.com/shawa ... install.sh | sudo bash"

When I try to start after I boot my rpi , i get below

root@DietPi:~# systemctl start ifi-streamer-tidal-connect.service
root@DietPi:~# systemctl status ifi-streamer-tidal-connect.service
● ifi-streamer-tidal-connect.service - RasPi Streamer Tidal Connect Service
Loaded: loaded (/lib/systemd/system/ifi-streamer-tidal-connect.service; disabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2021-02-17 10:27:17 +04; 433ms ago
Process: 1386 ExecStart=/usr/ifi/ifi-tidal-release/bin/tidal_connect_application --tc-certificate-path /usr/ifi/ifi-tidal-release/id_certificate/IfiAudio_ZenStream.dat -f HiTide RasPi Streamer --codec-mpegh true --codec-mqa false --mo
del-name HiTide RasPi Streamer --disable-app-security false --disable-web-security false --enable-mqa-passthrough true --log-level 3 --enable-websocket-log 0 (code=exited, status=1/FAILURE)
Main PID: 1386 (code=exited, status=1/FAILURE),


Then I reinstall and it work for rest of day till I shutdown rpi

spuddler
Posts: 1
Joined: Fri Feb 19, 2021 5:44 pm

Re: TIDAL Connect installation!

Fri Feb 19, 2021 5:59 pm

Huge thanks for posting this, I was hoping you might be able to point me in the right direction to resolve an issue.
I went the through the steps manually and it all went to plan with one exception, the output from

Code: Select all

ifi-tidal-release/pa_devs/bin/run.sh
Came back similar to the expected output but with no devices in it, however I found my hifiberry dac listed in the devices file in /pa_devs after running the command and copied the value over to

Code: Select all

ifi-streamer-tidal-connect.service
The file looks like this:

Code: Select all

[Unit]
Description=RasPi Streamer Tidal Connect Service
[Service]
Restart=on-failure
ExecStart=/usr/ifi/ifi-tidal-release/bin/tidal_connect_application \
			--tc-certificate-path "/usr/ifi/ifi-tidal-release/id_certificate/IfiAudio_ZenStream.dat" \
			-f "HiTide RasPi Streamer" \
			--codec-mpegh true \
			--codec-mqa false \
			--model-name "HiTide RasPi Streamer" \
			--disable-app-security false \
			--disable-web-security false \
			--enable-mqa-passthrough false \
			--playback-device "snd_rpi_hifiberry_dacplus: HiFiBerry DAC+ HiFi pcm512x-hifi-0 (hw:2,0)"\
			--log-level 3 \
			--enable-websocket-log "0"

User=root
Group=root
RestartSec=1
KillMode=control-group
[Install]
WantedBy=multi-user.target

So far so good, but when I start the service and check the status I get this:

Code: Select all

ifi-streamer-tidal-connect.service - RasPi Streamer Tidal Connect Service
Loaded: loaded (/lib/systemd/system/ifi-streamer-tidal-connect.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2021-02-19 17:41:38 GMT; 12min ago
Process: 1540 ExecStart=/usr/ifi/ifi-tidal-release/bin/tidal_connect_application --tc-certificate-path /usr/ifi/ifi-tidal-release/id_certificate/IfiAudio_ZenStream.dat -f HiTide RasPi
Main PID: 1540 (code=exited, status=127)

Feb 19 17:41:38 raspberrypi systemd[1]: ifi-streamer-tidal-connect.service: Service RestartSec=1s expired, scheduling restart.
Feb 19 17:41:38 raspberrypi systemd[1]: ifi-streamer-tidal-connect.service: Scheduled restart job, restart counter is at 5.
Feb 19 17:41:38 raspberrypi systemd[1]: Stopped RasPi Streamer Tidal Connect Service.
Feb 19 17:41:38 raspberrypi systemd[1]: ifi-streamer-tidal-connect.service: Start request repeated too quickly.
Feb 19 17:41:38 raspberrypi systemd[1]: ifi-streamer-tidal-connect.service: Failed with result 'exit-code'.
Feb 19 17:41:38 raspberrypi systemd[1]: Failed to start RasPi Streamer Tidal Connect Service.

I'd really appreciate any advice you can offer.

KiKoKingKong
Posts: 2
Joined: Sat Feb 20, 2021 7:02 pm

Re: TIDAL Connect installation!

Sat Feb 20, 2021 7:06 pm

First of all thank you for providing this Tidal Connect solution.

My question: do your Tidal Apps control the output volume of the raspberry pi? For me they do not. I can manually adjust the volume in the alsamixer. But the apps do not affect that.

In my status file there is no message concerning alsamixer. dsnoop seems to be for recording and jack server too.

Code: Select all

Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: Cannot connect to server socket err = No such file or directory
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: Cannot connect to server request channel
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: jack server is not running or cannot be started
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: STARTED TidalConnect services.

vusseyv
Posts: 4
Joined: Sun Feb 21, 2021 5:29 am

Re: TIDAL Connect installation!

Sun Feb 21, 2021 5:41 am

Hi there, took me a few days but got this working. I had several problems, and the one you have below. I have no luck troubleshooting, so used a full fat version of stretch and the script, it worked straight away on a 3b+

couldn't get Buster to work at all.

also my dac name wasn't generated in the devices file correctly, i got from run.sh in pa_devs

"Cambridge AudioDAC100 USB 2: Audio (hw:1,0)"

and it should have been

"Cambridge AudioDAC100 USB 2: Audio:- (hw:1,0)"

to be added as the --playback-device in the service configuration.

when you change these parameters remember to deploy.sh and restart the daemon and the service.

systemctl daemon-reload
systemctl enable ifi-streamer-tidal-connect.service
systemctl start ifi-streamer-tidal-connect.service
systemctl status ifi-streamer-tidal-connect.service

hope you have fun. BTW this will be part of volumio soon. Tidal have agreed to let them develop it.

vusseyv
Posts: 4
Joined: Sun Feb 21, 2021 5:29 am

Re: TIDAL Connect installation!

Sun Feb 21, 2021 8:22 pm

KiKoKingKong wrote:
Sat Feb 20, 2021 7:06 pm
First of all thank you for providing this Tidal Connect solution.

My question: do your Tidal Apps control the output volume of the raspberry pi? For me they do not. I can manually adjust the volume in the alsamixer. But the apps do not affect that.

In my status file there is no message concerning alsamixer. dsnoop seems to be for recording and jack server too.

Code: Select all

Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: Cannot connect to server socket err = No such file or directory
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: Cannot connect to server request channel
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: jack server is not running or cannot be started
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Feb 20 18:42:09 raspberrypi tidal_connect_application[10966]: STARTED TidalConnect services.
same, no i'm afraid the Tidal app has no volume, but i output to a proper integrated amp so i use the remote.

KiKoKingKong
Posts: 2
Joined: Sat Feb 20, 2021 7:02 pm

Re: TIDAL Connect installation!

Mon Feb 22, 2021 8:20 am

In the mornings the tidal service is always not working for me. Running

Code: Select all

sudo systemctl status ifi-streamer-tidal-connect.service
gives me

Code: Select all

Feb 22 08:02:19 raspberrypi tidal_connect_application[9516]: [2021-02-22 08:02:19.912] [tisoc] [warning] [PlaybackControllerImpl.cpp:472] Illegal state:1
Feb 22 08:02:23 raspberrypi tidal_connect_application[9516]: [2021-02-22 08:02:23] [info] asio async_shutdown error: asio.misc:2 (End of file)
Feb 22 08:02:23 raspberrypi tidal_connect_application[9516]: [2021-02-22 08:02:23.072] [tisoc] [warning] [PlaybackControllerImpl.cpp:472] Illegal state:0
Feb 22 08:03:21 raspberrypi tidal_connect_application[9516]: [2021-02-22 08:03:21.862] [tisoc] [warning] [PlaybackControllerImpl.cpp:472] Illegal state:1
Feb 22 08:03:22 raspberrypi tidal_connect_application[9516]: [2021-02-22 08:03:22] [info] asio async_shutdown error: asio.misc:2 (End of file)
I have the Raspberry Pi connected to an external USB-DAC which I shut down before going to bed. If I do not do that, the above errors do not appear and the tidal-connect.service is still up and running in the morning.
Last edited by KiKoKingKong on Tue Feb 23, 2021 8:09 am, edited 1 time in total.

jrotaetxe
Posts: 2
Joined: Thu Mar 26, 2020 2:14 pm

Re: TIDAL Connect installation!

Mon Feb 22, 2021 8:14 pm

I have the same hardware as @spuddler, but less fortune, as my hifiberry DAC is not listed at all in pa_devs
But I have found the result of command ifi-pa-devs-get differs depending on how do you invoke

Code: Select all

pi@VOLUMIO:/usr/ifi/ifi-tidal-release/pa_devs/bin $ [b]sudo [/b]./ifi-pa-devs-get
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib conf.c:5014:(snd_config_expand) Unknown parameters {AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM iec958:{AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Number of devices = 0
vs

Code: Select all

pi@VOLUMIO:/usr/ifi/ifi-tidal-release/pa_devs/bin $  ./ifi-pa-devs-get
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib conf.c:5014:(snd_config_expand) Unknown parameters {AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM iec958:{AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
[b]device#0=pulse
device#1=default
Number of devices = 2
[/b]
Do not understand the difference on the behaviour, and perhaps is a way to guess about "howto" install this with our DACs

vusseyv
Posts: 4
Joined: Sun Feb 21, 2021 5:29 am

Re: TIDAL Connect installation!

Tue Feb 23, 2021 11:02 am

jrotaetxe wrote:
Mon Feb 22, 2021 8:14 pm
I have the same hardware as @spuddler, but less fortune, as my hifiberry DAC is not listed at all in pa_devs
But I have found the result of command ifi-pa-devs-get differs depending on how do you invoke

Code: Select all

pi@VOLUMIO:/usr/ifi/ifi-tidal-release/pa_devs/bin $ [b]sudo [/b]./ifi-pa-devs-get
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib conf.c:5014:(snd_config_expand) Unknown parameters {AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM iec958:{AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Number of devices = 0
vs

Code: Select all

pi@VOLUMIO:/usr/ifi/ifi-tidal-release/pa_devs/bin $  ./ifi-pa-devs-get
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib conf.c:5014:(snd_config_expand) Unknown parameters {AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM iec958:{AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2  CARD 0}
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
[b]device#0=pulse
device#1=default
Number of devices = 2
[/b]
Do not understand the difference on the behaviour, and perhaps is a way to guess about "howto" install this with our DACs
so i had a bunch of different errors and your issue of only finding 2 devices, i think that was with dietpi. I have have a cambridge audio dacmagic 100 USB.

i had a bit of a scatter gun approach but i could only get everything working with full fat "stretch" pi image. i used the script and run.sh to find my DAC in devices, then added that to the service config. i ignored all the errors you see above and in the service status and run.sh and just tried it... boom, i'm listening right now. there is something odd however, i reimaged my SD card from a known working backup and i had to remove ":-" from my DAC description described above as the service status said cannot be found when i started it, yet it was definitely working with that included previously. Which is strange. I will try now with a justboom digi hat, it does appear in devices when i attach it.

it took me about 3 days to get it going but its worth it trust me.

vusseyv
Posts: 4
Joined: Sun Feb 21, 2021 5:29 am

Re: TIDAL Connect installation!

Tue Feb 23, 2021 12:07 pm

Just fitted the justboom digi hat, it has sp/dif out

my devices file looks like this:-

device#0=bcm2835 ALSA: - (hw:0,0)
device#1=bcm2835 ALSA: IEC958/HDMI (hw:0,1)
device#2=snd_rpi_justboom_digi: - (hw:1,0)
device#3=sysdefault
device#4=default
device#5=dmix
Number of devices = 6

my service config looks like this:-

[Unit]
Description=RasPi Streamer Tidal Connect Service
[Service]
Restart=on-failure
ExecStart=/usr/ifi/ifi-tidal-release/bin/tidal_connect_application \
--tc-certificate-path "/usr/ifi/ifi-tidal-release/id_certificate/IfiAudio_ZenStream.dat" \
-f "HiTide RasPi Streamer" \
--codec-mpegh true \
--codec-mqa false \
--model-name "HiTide RasPi Streamer" \
--disable-app-security false \
--disable-web-security false \
--enable-mqa-passthrough false \
--playback-device "snd_rpi_justboom_digi: - (hw:1,0)" \
--log-level 3 \
--enable-websocket-log "0"

User=root
Group=root
RestartSec=1
KillMode=control-group
[Install]
WantedBy=multi-user.target

it works fine, i physically plugged the optical out from the HAT into my DAC, toslink and away we go.


Cheers

Umerfulo
Posts: 3
Joined: Tue Feb 23, 2021 10:10 pm

Re: TIDAL Connect installation!

Wed Feb 24, 2021 1:13 am

Finally I was able to make it work with IQAudIO DAC Plus, however I am unable to control the volumen from my iPhone, any help is appreciated. And second question, anyone has been able to change the name to the Tidal Connect device? I tried changing it in tidal-connect.service but didn’t change.

Thanks!!!

zirbo
Posts: 1
Joined: Wed Feb 24, 2021 6:27 pm

Re: TIDAL Connect installation!

Wed Feb 24, 2021 6:30 pm

Hi,

but don't the sources exist?
so that you can compile the binary on your own system?
like on aarch64?

ChechuRubiera
Posts: 1
Joined: Thu Feb 25, 2021 10:47 pm

Re: TIDAL Connect installation!

Thu Feb 25, 2021 10:55 pm

Thanks for the installer!

I have the same problem as below with my USB DAC - it connects but rapidly skips through every song. Did anyone encounter the same and has any solutions by any chance?
ayyy wrote:
Sun Jan 24, 2021 3:26 pm
Thanks for sharing this - was straightforward on Raspbian Buster, Pi 3 Model B.

I was able to get audio output through the analog out straightaway, however when I tried to use my Khadas Tone Board (USB) I found that Tidal started skipping through the song - I think this is related to sampling rates/timing. I'll have a look into this and report back. If you have any suggestions please let me know.

I have previously used the Khadas with mopidy-spotify with no problem, so I am sure it's just a settings issue.

dondipietro
Posts: 1
Joined: Sat Feb 27, 2021 9:38 am

Re: TIDAL Connect installation!

Sat Feb 27, 2021 9:41 am

Hello,
Just an post to thank you, it is working very well.

I use tidal connect on the raspberry pi, and I stream to my ifi hip dac and MQA (Master Quality) IS WORKING !

I'm sure about this because the led on the dac turn to purple :D

It is the first time I managed to have MQA under linux.

Return to “Graphics, sound and multimedia”