ttechnik
Posts: 3
Joined: Fri May 23, 2014 6:21 am

Linux distro with fullscreen WebKit browser and multimedia playback

Mon Nov 26, 2018 3:56 pm

For those who are interested.

We released our new project on GitHub. It's a very fast booting linux system (buildroot) starting directly into a full screen web browser.

Short overview:
- boot splash including progress bar
- boots directly into a full screen web browser (video and audio playback capable)
- Node.js webserver included for hosting local web pages displayed in the browser
- HDMI CEC support
- RPi Wireless drivers, Ralink drivers

Take a look here: https://github.com/TOLDOTECHNIK/buildroot-webkit

It can be used as a standalone digital signage info terminal. We use it for displaying complex HTML 5 user interfaces.

controllerhappy
Posts: 4
Joined: Fri Jul 20, 2018 8:48 am

Re: Linux distro with fullscreen WebKit browser and multimedia playback

Mon Nov 26, 2018 10:57 pm

This is awesome! I will check it out when I get home.

There's been a lot of demand for a simple webkit browser. I remember when BENJA was in its peak days - it was extremely useful. I'll test it out and get you a report back. Specifically -- I want to find a great replacement for the balena/resin wpe images that use Yocto/Docker since not all of us have solid internet access.

cicontrol
Posts: 1
Joined: Mon Sep 02, 2019 6:36 pm

Re: Linux distro with fullscreen WebKit browser and multimedia playback

Mon Sep 02, 2019 6:43 pm

Hi.

Is there any update for your project? What about Raspberry 4.
I tried it last year and it worked very well.

Thanks.

ttechnik
Posts: 3
Joined: Fri May 23, 2014 6:21 am

Re: Linux distro with fullscreen WebKit browser and multimedia playback

Mon Dec 02, 2019 6:01 pm

We did some tweaks since then. Everything works great on a RPi3B+. RPi4 we don't know cause of missing hardware.

hippy
Posts: 6223
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: Linux distro with fullscreen WebKit browser and multimedia playback

Mon Dec 02, 2019 8:39 pm

Looks good. Got it booting on a Pi Zero W from a pre-built image. Can ping it, but don't seem able to SSH into it, from Windows or another Pi, just getting "connection refused" on both. Is there anything I need to do to enable SSH ?

Also; how to shut down ? If I pull the power, on the next re-boot I just get the booting splash screen, then a white screen of death, have to re-image the SD Card. - Solved;Assuming it was that I hadn't twigged I had to set url.txt, and it only displays the 'demo' page on the first ever boot.

Return to “Graphics, sound and multimedia”