Page 1 of 1

esp8266 and minicom

Posted: Sun Jan 04, 2015 10:07 am
by jon wise
I have just connected my first ESP8266 WIFI module to the serial port of pi. Using minicom at 9600 baud I can see the reset message and the echo from typing AT commands but get no OK or any error messages. Using a few lines of Python to send AT messages I get the expected OK replies including the list of available WIFI signals. Any ideas on the settings required for minicom? My guess is that it is something to do with CR LF.

Re: esp8266 and minicom

Posted: Sun Jan 04, 2015 11:47 am
by DougieLawson
Try setting the baud rate to 115200,N,8,1 rather than 9600,N,8,1.

Re: esp8266 and minicom

Posted: Sun Jan 04, 2015 4:18 pm
by jon wise
I tried 115200 at the first attempt but got the normal gibberish of a wrong baud rate. 9600 works fine with python and receiving with minicom, but I cannot send AT commands from minicom.

As a next step I am trying to connect to my BT HomeHub WIFI (using python) but get FAIL reply. Do I need to do more than AT+CWJAP="BTHomeHub2-xxxxx","1234asdfg" ?

Re: esp8266 and minicom

Posted: Tue Jan 06, 2015 2:14 pm
by jon wise
Cntrl-J after 'Enter' in minicom sends the cr/lf required by esp8266 to complete each command. The 'Add Linefeed' feature of minicom just adds LF to the response, not the request.

Re: esp8266 and minicom

Posted: Thu Feb 05, 2015 8:21 am
by dubau_razvan
Have you disabled the serial port login on pi?

esp8266 and minicom

Posted: Sat Oct 24, 2015 10:29 pm
by san_ripe
Hello,
this is my first post.
I have problems to communicate the RPi to ESP8266.
When I type "minicom -b 115200 -o -D /dev/ttyAMA0", the minicom start but i canĀ“t write nothing.
is it possible that the RPi UART is not working? How can I check it?
Thank and sorry about my english.

Re: esp8266 and minicom

Posted: Mon Oct 26, 2015 1:25 pm
by scotty101
san_ripe wrote:is it possible that the RPi UART is not working? How can I check it?
Connect the TX and RX pins together (whilst connected to nothing else). Use minicom and when you send something you should receive the same thing back.

Re: esp8266 and minicom

Posted: Tue Oct 27, 2015 3:13 am
by san_ripe
Scotyy_101, thank you very much. Your test worked well, the UART of RPi is working, so I have another problems. Maybe I connected wrong the ESP8266 .
Any idea?

Re: esp8266 and minicom

Posted: Tue Oct 27, 2015 12:13 pm
by scotty101
Common mistake is connecting TX and RX the wrong way round.

Try swapping them over.

Also have you correctly set the Chip Enable pin of the ESP8266?