Page 1 of 1

Using Asus Xtion Pro Live with Raspberry Pi

Posted: Wed Mar 12, 2014 3:12 pm
by ZuLuuuuuu

I just got Asus Xtion Live Pro camera and I try to make it work. I compiled OpenNI using tutorials on internet, I needed to change some parameters in RedistMaker but t compiled. Then I installed the sensor drivers. But when I try to run SimpleRead it says: "One or more of the following nodes could not be enumarated".

The versions of my software are like this:

Raspberry Model B
OpenNI: master
Sensor: Sensor-Bin-Linux-Arm-v5.1.6.6
Raspbian: (updates are done, did the firmware update as well)

I tried compiling sensor drivers from source as well but it didn't change the outcome.

lsusb lists a USB device without a name when I plug the camera. I plug the camera to a USB socket on Raspberry itself.

dmesg | tail says that the device is from PrimeSense.

What might be the problem? Can anybody give me the exact version numbers to work with both for OpenNI itself and the sensor drivers?

Re: Using Asus Xtion Pro Live with Raspberry Pi

Posted: Thu Mar 13, 2014 8:31 am
by ZuLuuuuuu
I followed the exact steps here: ... inect.html

With OpenNI, Sensor, latest Raspbian and now it works. It didn't require a powered USB hub. I did the overclock via the setup screen (I don't know if the overclock plays a role for being able to run it).