yonubear
Posts: 90
Joined: Thu Sep 12, 2013 11:11 pm

Re: multiple GPIO triggering issue

Sat Jan 04, 2014 12:59 am

solved!!!!!

I WILL SAY IT I AM A DUMBASS

I was reading the schematic for the Optocoupler backwards I had the collector and emitter reversed as soon as I flipped the gnd and gpio wire one of them it worked so now I get to redo my perfboard may have another odd question but I will sort that out after I am done fighting the hardware.


Thanks,
Yonu

User avatar
FLYFISH TECHNOLOGIES
Posts: 1750
Joined: Thu Oct 03, 2013 7:48 am
Location: Ljubljana, Slovenia
Contact: Website

Re: multiple GPIO triggering issue

Sat Jan 04, 2014 1:43 am

Hi,
yonubear wrote:since they will all pull off the same 3.3v rail anyway can I simply pull the pull up current for each pin from the gpio side of my 1wire or is that a stupid idea?
.... huh, I'm not sure that I understand the question... If you ask to connect pull-up resistors to 3.3V GPIO pin, then the answer is: yes, you can.
yonubear wrote:Something along the lines of this diagram
These diagrams are not very readable - even when elements labels are present, the observer has to take a look into some elements (eg. transistor) datasheet for pinouts to get the complete picture... I preffer "normal" schematics of the circuits instead.

Anyway, your chances to get reliable answers is dramatically increased when you attach schematics to your questions....


Best wishes, Ivan Zilic.
Running out of GPIO pins and/or need to read analog values?
Solution: http://www.flyfish-tech.com/FF32

Return to “Automation, sensing and robotics”