David1234
Posts: 1
Joined: Thu Oct 31, 2013 10:45 am

USB Thermocouple Problem

Thu Oct 31, 2013 10:49 am

I recently purchased a TMPSNSRD-TCPL1 thermocouple reference design from Microchip. When I plug it into the RPI with the USB cable, it generates a character device file /dev/usb/biddev0. I have been trying to interrogate this file using cat and open commands but with no success. Please help!!

JustThisGuy
Posts: 114
Joined: Thu Jan 05, 2012 11:22 pm

Re: USB Thermocouple Problem

Thu Oct 31, 2013 8:35 pm

There appears to be firmware/driver code necessary.

see a windows app here:
http://designs.digikey.com/library/4294 ... 959871/613
and firmware here:
http://www.microchip.com/stellent/idcpl ... e=en546844

Check with the distributor you purchased from or the manufacturers website.
Any conversation about a sufficiently complex subject is indistinguishable from babble.

User avatar
FLYFISH TECHNOLOGIES
Posts: 1750
Joined: Thu Oct 03, 2013 7:48 am
Location: Ljubljana, Slovenia
Contact: Website

Re: USB Thermocouple Problem

Sun Nov 03, 2013 9:50 pm

Hi,

Unfortunately, I don't have this board available, but I've just take a quick look into related firmware sources available at Microchip site. I'm sure that no additional driver is needed to be installed on RasPi, since this is HID device and required driver is already present in all distributions.

According to your post (that /dev/usb/biddev0 appears) I'd say that firmware is also preloaded, what is common, anyway.
Try to locate it as hidraw device. You could be able to open/read/write it that way, I believe.

Feel free to let me know if the issue remains unsolved or you bump into another one...


Best wishes, Ivan Zilic.
Running out of GPIO pins and/or need to read analog values?
Solution: http://www.flyfish-tech.com/FF32

Return to “Automation, sensing and robotics”

Who is online

Users browsing this forum: mcjhn and 11 guests