Posts: 9
Joined: Mon Sep 17, 2012 1:31 pm

Python-openzwave & Jasco 45609

Mon Aug 12, 2013 3:58 pm

I just started playing around with the Jasco 45609 switches and the Aeon Labs z-stick 2 zwave stuff using python-openzwave... All seems to work O.K. EXCEPT that when I turn off the Jasco switches, they turn back on after about an hour... They turn back on even if they are turned off manually! When I turn them off, the network receives a callback that the switch status is False... I observe the network and there is no callback indicating the change back to ON, but if I check the switch status, they both show True after about an hour!! I have tried this with the network being monitored, and with the network stopped - same thing. I have tried turning the switch off several times in succession from the Pi and sometimes they will stay off, sometimes not... Physically, the switches turn on and off when commanded either manually of using the Pi/zstick. I have removed them from the network, and then re-associated them - same... Jasco tech support didn't know how it could happen without commands from the network or manually... Any ideas??

User avatar
Posts: 113
Joined: Sun Mar 31, 2013 8:28 pm
Location: Top of the food chain
Contact: Website

Re: Python-openzwave & Jasco 45609

Fri Aug 23, 2013 12:52 pm

Hi -- this seems so strange that I wonder if there are any other devices in the network?

When you turn off the switches and then power off your pi, the switches stay off -- right?

Zwave devices "talk" to eachother when configured as such. Sensors can turn on switches etc.

Also, keep an eye on your wife's face when the switches come on. She's probably hiding a remote in her pocket.

Dave Driesen
Linux dev and oldskool elite

Posts: 9
Joined: Mon Sep 17, 2012 1:31 pm

Re: Python-openzwave & Jasco 45609

Fri Aug 23, 2013 2:48 pm

Yes, there are Aeon Labs multisensors on the network... And when I remove the controller from the Pi, they stay off - however, the multisensors show no associations in their config! Also, when I leave the network active with the python script running and checking switch status every 150 secs, they stay off... I am in contact with support from Aeon Labs and they are helping... I will remove everything from the network and try again... Leaving a simple python script running on the Pi to switch the lights on is working for the time being - I was doing some testing this morning and had the network stopped, the lights switched on again!! I think that it is haunted...

Posts: 4
Joined: Thu Jan 09, 2014 9:52 am

Re: Python-openzwave & Jasco 45609

Thu Jan 09, 2014 1:19 pm


I also want to install python-openzwave on my RPI - do You have some procedure of installation?
I would be extremely grateful if you gave me any howto or any links of how to install it on RPI, procedure from following link:
http://bibi21000.gallet.info/index.php/ ... L_MAN.html

exits with errors during "python setup-lib.py build":

[...]lib/libopenzwave.cpp:225:20: fatal error: vers.cpp: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1

this procedure worked fine many times on my PC with Ubuntu , now I try to migrate my python scripts from PC to RPI


Posts: 9
Joined: Mon Sep 17, 2012 1:31 pm

Re: Python-openzwave & Jasco 45609

Thu Jan 09, 2014 11:25 pm

Its been a long time since I put openzwave on the RPi - I followed a how-to that was on the forum - don't remember which one... I never could make it work to my satisfaction and haven't touched it in several months. I asked for help from one of the developers of openzwave "bibi21000" and never got a reply... I also asked for help from Thomas Loughlin who posted a lot on the earlier openzwave forums and he said that he had given-up and gone with a commercial zwave master controller. I thought seriously about paying the zwave license fee and getting their libraries, but didn't.

I finally gave up and bought a MiCasaVerde VeraLite. The VeraLite is not very intuitive and difficult to make it work, but there are lots of helpers on the MiCasaVerde forum. I almost gave up on the VeraLite a few times and went back to the RPi using XBee and XBee Pro radio modems - I had too much invested in the Zwave devices and percevered and made them work.

Good luck if you continue.

Posts: 4
Joined: Thu Jan 09, 2014 9:52 am

Re: Python-openzwave & Jasco 45609

Fri Jan 10, 2014 9:35 am

According to suggestion of Stephen Smith (many thanks!) I changed line 225 of lib/libopenzwave.cpp
#include "vers.cpp"
#include "vers.c" (which file I have in /openzwave/cpp/build/linux/vers.c)

Now I got following:
pi@raspberrypi ~/python-openzwave $ python setup-lib.py build
running build
running build_py
package init file 'lib/__init__.py' not found (or not a regular file)
package init file 'lib/__init__.py' not found (or not a regular file)
running build_ext
skipping 'lib/libopenzwave.cpp' Cython extension (up-to-date)
building 'libopenzwave' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -Iopenzwave/cpp/src -Iopenzwave/cpp/src/value_classes -Iopenzwave/cpp/src/platform -Iopenzwave/cpp/build/linux -I/usr/include/python2.7 -c lib/libopenzwave.cpp -o build/temp.linux-armv6l-2.7/lib/libopenzwave.o
cc1plus: warning: command line option â-Wstrict-prototypesâ is valid for Ada/C/ObjC but not for C++ [enabled by default]
lib/libopenzwave.cpp: In function âPyObject* __pyx_pf_12libopenzwave_9PyManager_12getOzwLibraryVersion(PyObject*, PyObject*)â:
lib/libopenzwave.cpp:5483:42: error: âozw_vers_majorâ was not declared in this scope
lib/libopenzwave.cpp:5485:42: error: âozw_vers_minorâ was not declared in this scope
lib/libopenzwave.cpp:5487:42: error: âozw_vers_revisionâ was not declared in this scope
lib/libopenzwave.cpp: In function âPyObject* __pyx_pf_12libopenzwave_9PyManager_25getPollIntensity(PyObject*, PyObject*)â:
lib/libopenzwave.cpp:6651:95: error: âclass OpenZWave::Managerâ has no member named âGetPollIntensityâ
error: command 'gcc' failed with exit status 1


Posts: 56
Joined: Wed Nov 21, 2012 12:29 am

Re: Python-openzwave & Jasco 45609

Wed Feb 12, 2014 11:26 pm

I been trying to get python-openzwave working for 2 whole day now , I don`t think it was every made to compile .
I`m using to latest branches of each, so it should compile.
I`ve read so my documents which say do this to install openzwave and python-openzwave .

hg clone https://code.google.com/p/python-openzwave/ and go in the python-openzwave directory and do a .
/update which installs openzwave .

then it says use ./compile.sh which just give me a

| Build openzwave |
make: *** No targets specified and no makefile found. Stop.

Tried doing it manual .

python setup-lib.py build
python setup-api.py build

which gives me the ver.cpp , tried editing it out to start the error , but just get a new error somewhere down the line.

I give up !!!!

Return to “Automation, sensing and robotics”