lewisallanreed
Posts: 2
Joined: Wed Jun 13, 2018 12:39 pm

RPi3 Model B + SN74HC04 inverter + Maxbotix LV-MaxSonarEZ0 (MB1000) (+ Noob)

Wed Jun 13, 2018 1:30 pm

Hi everyone, as the title suggests, I'm a noob and I'm try to make a setup work where a sensor (MB1000), powered by the RPi, gets data, which, after being inverted, is sent to RPi's pin 10 (RX for serial communication) to be read by "minicom" a program by Maxbotix, which should interpret it and print it on the terminal screen.

Now, I closely followed the instructions as per this article https://www.maxbotix.com/Raspberry-Pi-w ... ensors-144 but it doesn't seem to work for me, for some reason. I'm confused and baffled, but I'm a noob so I shouldn't be surprised.
I don't really know where to go from here. When I ask the /dev/ttyS0, which is the port I'm supposed to check, according to the tutorial, I get nothing. Asking the /dev/ttyAMA0, it spews out a bunch of gibberish of japanese characters and whatnot. It seems to be a problem with the way the Pi interprets the serial data, although I'm following to a tee the instructions which say the serial data should be inverted... So I don't know what's there not to understand. Got any clue??

Thanks for any possible replies!!

lewisallanreed
Posts: 2
Joined: Wed Jun 13, 2018 12:39 pm

Re: RPi3 Model B + SN74HC04 inverter + Maxbotix LV-MaxSonarEZ0 (MB1000) (+ Noob)

Wed Jun 20, 2018 7:37 pm

Color me impressed. It really is a tough Raspberry Pi project if even the people on the Raspberry Pi forum can't help me. Well, I tried. Thanks for trying too! I'll find another solution.

Return to “Automation, sensing and robotics”

Who is online

Users browsing this forum: No registered users and 8 guests