astrotutor
Posts: 24
Joined: Wed Feb 20, 2013 10:57 am

Trouble getting BlueDot to connect

Wed Aug 16, 2017 2:29 pm

Hi,
I'm trying to get my Android Phone to Connect with a Pi3 via BlueDot. Following the get started instructions it just isn't playing ball.
I don't get the final part about typing in the PIN on the Pi3 or mobile. And when I try and connect the BlueDot app it fails.
Anyone any ideas? I've tried unpairing them both a few times and retrying but to no avail.
Thanks anyone for any advice.
Robert

User avatar
LetHopeItsSnowing
Posts: 354
Joined: Sat May 26, 2012 6:40 am
Location: UK
Contact: Website

Re: Trouble getting BlueDot to connect

Sun Sep 10, 2017 8:55 pm

It sounds like your Pi and Android phone aren't pairing properly.

Are you pairing using the command line (bluetoothctl) or via the GUI? If you have tried one, try the other, I have experienced problems where linux wont pair via one route, but it will the other!

Out of interest, what phone are you using?

fyi - I wrote BlueDot.
"am I getting slower, or is stuff more complicated; either way I now have to write it down - stuffaboutcode.com"

User avatar
LetHopeItsSnowing
Posts: 354
Joined: Sat May 26, 2012 6:40 am
Location: UK
Contact: Website

Re: Trouble getting BlueDot to connect

Sun Sep 10, 2017 9:00 pm

Also, are you using a recent version of Raspbian? I would definitely upgrade to Raspbian Stretch.

I found that some of the earlier version of Raspbian really didnt handle bluetooth very well. Older versions of bluez I think were mainly to blame.
"am I getting slower, or is stuff more complicated; either way I now have to write it down - stuffaboutcode.com"

Return to “Automation, sensing and robotics”

Who is online

Users browsing this forum: No registered users and 26 guests