dobbers24
Posts: 2
Joined: Thu Jul 19, 2012 2:35 pm

Pi + Bluetooth + SMA Inverter - not stable

Thu Jul 19, 2012 3:16 pm

I have my Pi installed with Wheezy, Tesco bluetooth dongle and running from Kindle PSU.
Installed sma-bluetooth software from http://code.google.com/p/sma-bluetooth/
The crontab job then wakes up every 5 minutes to talk to the SMA Inverter to grab the solar panel output data and post to pvoutput. This works fine for a while and then once or twice a day the bluetooth gives up and I have to reboot the whole Pi to clear it. BTW running /etc/init.d/bluetooth restart does not clear the issue.

Is anyone else out there running a Pi to gather stats from SMA Inverters via bluetooth and finding bluetooth unstable after running for a while?

regards,

dobbers

mavo
Posts: 7
Joined: Wed Aug 01, 2012 2:08 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Wed Aug 01, 2012 2:11 pm

Hi,

I'm all set up to get started with exactly the same project, so i cannot say yet if it's unstable. But if you could help with some step by step instructions, then i'd be happy to report feedback.

Wombatsev
Posts: 3
Joined: Fri Aug 10, 2012 8:55 am

Re: Pi + Bluetooth + SMA Inverter - not stable

Sat Aug 18, 2012 10:21 am

Hi

I have just tried to set it up. I am using a generic Bluetooth device purchased from eBay.
I have found that the Bluetooth device seems to go to sleep and doesn't wake up again. Also when I run the software with the -f to force a connection it hangs the Pi and I have to reboot to get it back.
I am going to try from scratch again over the next week.

Regards
Mark

honda4life
Posts: 74
Joined: Thu Mar 15, 2012 7:27 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Sat Aug 18, 2012 2:01 pm

Same problem here, tried different receivers, other power supply...
Didn't found a solution after a few days.

You can try hiconfig hci0 reset, but sometimes this isn't even possible.

PiAir
Posts: 7
Joined: Sat Aug 18, 2012 6:28 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Sat Aug 18, 2012 6:33 pm

@dobber24

> This works fine for a while

Can you explain what you mean by "for a while"? I've got it up and running stable now for 7 days strait. I also use the Tesco nano bluetooth dongle and Raspberry Wheezy.
I haven't created a step-by-step setup instruction in English yet (need to find some time to redo the setup on a different SD card), but I don't know what would cause your bluetooth to crash.

Wombatsev
Posts: 3
Joined: Fri Aug 10, 2012 8:55 am

Re: Pi + Bluetooth + SMA Inverter - not stable

Tue Aug 21, 2012 12:51 pm

Wombatsev wrote: I am going to try from scratch again over the next week.

Regards
Mark
I have started again with a new build of "wheezy".
But it unfortunately locks up still.
I have ordered a new BT device just in case this is the problem.
Will let you know how it goes once it has arrived.

Regards
Mark

Roger Munford
Posts: 1
Joined: Fri Aug 24, 2012 6:40 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Fri Aug 24, 2012 6:51 pm

I did a course at SMA (12 months ago) and an instructor told me that there have been stability issues with Bluetooth in the past and he recommended getting a HAMA adapter which you can get at Amazon.
I have tried a Belkin adpter which did not work but have used the HAMA adapter without any problem. However I have only used it to connect briefly and download data and so I don't know if it would perform continuously.

Roger

SirFredman
Posts: 1
Joined: Sat Aug 25, 2012 8:40 am

Re: Pi + Bluetooth + SMA Inverter - not stable

Sat Aug 25, 2012 8:50 am

Same here, running a Pi with Wheezy using a cheap no-name ('conceptronic') bluetooth adapter.

After some time the bluetooth connection just dies and can only be brought back with a 'reboot'. This can happen multiple times a day, but the setup might just as well run flawlessly for a day.

Another bluetooth device might be the solution (http://www.raspberrypi.org/phpBB3/viewt ... 41&t=15109, so I'll try to get another one and see if that helps.


Wombatsev
Posts: 3
Joined: Fri Aug 10, 2012 8:55 am

Re: Pi + Bluetooth + SMA Inverter - not stable

Sat Sep 01, 2012 7:53 am

Hi all

Started again with a new build of wheezy.

I followed instructions from the below site to the letter.

https://code.google.com/r/rcphills-sma- ... straction/

It now works , for a day anyway!. I am using Logitech USB Bluetooth dongle that I had lying around.
The one thing I found important was to make sure that the raspbian was up to date before you start.

Cheers and good luck.

Mark 7


honda4life
Posts: 74
Joined: Thu Mar 15, 2012 7:27 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Sun Sep 02, 2012 8:16 am

And it is working great... Only USB 1.1 for ethernet also :(
Can't find a way to force that specific port in USB 1.1, information found but can't find the right "file" on the pi, even with find :(

collywobbles
Posts: 9
Joined: Mon Mar 19, 2012 12:06 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Fri Sep 07, 2012 12:29 pm

I'm doing the same thing, running smatool to get solar readouts. I was using a bluetooth dongle and a wifi dongle. I tried a powered hub (recommended on the wiki) and that didn't work, I just bought a ethernet over power plug and took the wife dongle out, still no joy.

Have tried an older Belkin BT stick dongle and also a very new mini one.

Looking for a solution!

honda4life
Posts: 74
Joined: Thu Mar 15, 2012 7:27 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Sat Oct 13, 2012 4:58 pm

I think problem is solved since last release (usb interrupt rate?)
Will see tomorrow.

honda4life
Posts: 74
Joined: Thu Mar 15, 2012 7:27 pm

Re: Pi + Bluetooth + SMA Inverter - not stable

Tue Nov 06, 2012 10:52 pm

It's worth to try this tool:
http://code.google.com/p/sma-spot/
It's a good start to something better then smatool ;)

Return to “Automation, sensing and robotics”

Who is online

Users browsing this forum: No registered users and 11 guests