Page 1 of 1

Modem Reset Restarts Pi

Posted: Mon Jul 14, 2014 10:04 pm
by cyanarnofsky
Been using a USB Multi Tech modem with Verizon through my Pi that I was given to test. Got through some issues but have it connecting now, whats odd is I went through all the updates for the Pi and what not. If I use a year old image my AT shutdown command for the modem works great and merely resets the modem only with no Pi change.

Since the updating to current whenever I send the AT command to shutdown the modem (I have a small script to watch teh ppp connection for auto reconnect. If its sees no PPP connection it then resets the modem as I was having issues with busy line, then trys to redial.)

at#shdn

is the AT command, since I have updated when I run my script or that command only from Minicom it resets the entire device. I was thinking maybe something to do with hotplug issues but I have tried the upgraded cap and still remains the same. The modem pulls power seperatly I have a 5v 4amp PSU that splits to power the pi and modem on a shared line.

Curious if anyone has a thought to why the entire system restarts itself when before updating it works all day long.

EDIT: measured boards current while running the command and voltage stays around 5 so it seems that it is not a current drop.

Re: Modem Reset Restarts Pi

Posted: Mon Jul 14, 2014 11:08 pm
by cyanarnofsky
Created another SD and updated but left out the firmware update and everything seems normal. Maybe a update fluke.