Page 1 of 1

Open iSCSI anyone?

Posted: Fri Jun 01, 2012 7:21 pm
by Scotty T
I'm trying to get open iSCSI working. I'm having a tough time the iface is not being recognized as the documentation says. It says that it will automatically detect the driver in the ifaces.

So..... I went in and created iface0 and added the hardware address. Unfortunately the driver doesn't show before the hardware address. Example. I should see cxgb3i.b8:27:eb:d5:eb:dd
but I don't all I see is b8:27:eb:d5:bb:dd

Thoughts, anyone have suggestions, anyone play with this yet?

Re: Open iSCSI anyone?

Posted: Sat Jun 02, 2012 9:39 pm
by Scotty T
I could really use some help with this if anyone has expertise.

For some reason the iscsi daemon is failing to load.

Re: Open iSCSI anyone?

Posted: Sun Jun 03, 2012 4:02 pm
by nidO
Have you recompiled the kernel yet to include the relevant iscsi modules? (by default the debian pi image does not include iscsi support) - This is a crucial step in order to get iscsi working.

Re: Open iSCSI anyone?

Posted: Mon Jun 04, 2012 1:02 pm
by Scotty T
I'm not very familiar on how to do that.

If I use synaptic or apt-get doesn't it recompile for me?

Re: Open iSCSI anyone?

Posted: Tue Jun 05, 2012 3:47 pm
by aaa801
Scotty T wrote:I'm not very familiar on how to do that.

If I use synaptic or apt-get doesn't it recompile for me?
No you need to recompile it

Re: Open iSCSI anyone?

Posted: Tue Jun 05, 2012 4:39 pm
by Scotty T
For those who come across this post. The directions to recompile are here....

http://www.raspberrypi.org/phpBB3/viewt ... 109#p92109

I'm in the middle of recompiling and don't know if I will be successful but you will find this post helpful.