NikTheGeek
Posts: 7
Joined: Tue May 29, 2012 7:29 pm

Vmware View Open Client

Tue May 29, 2012 7:39 pm

Working for us at Warrington Collegiate. We recompiled the Vmware View Open Client for the Arm architecture and it works great. It also runs in kiosk mode which prevents it being shut down. We are thinking of packaging the install (Debian Squeeze) back up as an ISO and making the lot available for download.

Comments?

tnx

Nick

p.s. follow @warringtoncoll to contact us, or the guy that compiled it was @nowwashyoureyes

NikTheGeek
Posts: 7
Joined: Tue May 29, 2012 7:29 pm

Re: Vmware View Open Client

Tue May 29, 2012 8:09 pm

Should have said: Yes, we know the video is rubbish. We got our AV guy to use a "proper" video camera on a tripod. When the GUI kicks in, the camera loses its autofocus and panics! :)

I'll re-do it on a "proper" digital fixed focus handy cam :)

Nik @nikthegeek

NikTheGeek
Posts: 7
Joined: Tue May 29, 2012 7:29 pm

Re: Vmware View Open Client

Tue May 29, 2012 8:44 pm


zunder1990
Posts: 1
Joined: Fri Jun 01, 2012 5:50 pm

Re: Vmware View Open Client

Fri Jun 01, 2012 5:56 pm

Please make an ISO. I would love use a Pi as an zero client from my view install.

wrhii
Posts: 66
Joined: Fri Nov 18, 2011 1:47 am

Re: Vmware View Open Client

Tue Jun 05, 2012 11:36 pm

Is it safe to assume this would also work as a Thin Client for a VMware ESXi server?

Spiffy
Posts: 3
Joined: Fri May 25, 2012 8:52 am

Re: Vmware View Open Client

Wed Jun 06, 2012 12:53 pm

Please, oh please, oh PLEASE upload that ISO! :D

solutionssquad
Posts: 15
Joined: Wed Jun 06, 2012 2:56 pm

Re: Vmware View Open Client

Wed Jun 06, 2012 3:01 pm

Spiffy wrote:Please, oh please, oh PLEASE upload that ISO! :D
Ditto!

User avatar
fusiooon
Posts: 9
Joined: Tue May 08, 2012 11:23 am

Re: Vmware View Open Client

Mon Jun 11, 2012 11:15 am

solutionssquad wrote:
Spiffy wrote:Please, oh please, oh PLEASE upload that ISO! :D
Ditto!
+3

NikTheGeek
Posts: 7
Joined: Tue May 29, 2012 7:29 pm

Re: Vmware View Open Client

Tue Jun 12, 2012 11:40 am

I (almost) promise we'll upload it next week. It's been half term at college so we've been shut.

It is running against our Vmware View desktop (v5) infrastructure. I assume it would run with ESX too, but not tried it.

One of my IT staff did the compiling and he's still on holiday in France. He's back next week.

Hassle him @NowWashYourEyes and me @NikTheGeek and between us, we'll strip out our connection details, build an ISO and stick it on one of our websites.

Nick

NikTheGeek
Posts: 7
Joined: Tue May 29, 2012 7:29 pm

Re: Vmware View Open Client

Mon Jun 18, 2012 11:06 am

Here you go, ready for download plus instructions. It's on skydrive in a zip file called Magnum (Pi)

http://sdrv.ms/KvrNTs

Have fun!

Nick

HKCisONLINE
Posts: 1
Joined: Tue Jun 19, 2012 9:27 pm

Re: Vmware View Open Client

Tue Jun 19, 2012 9:28 pm

Wow Thx a lot !

still waiting for the download to finish, will post after test :)

-/.HKCisONLINE.\-

sdmeijer
Posts: 23
Joined: Thu Jun 21, 2012 6:13 pm

Re: Vmware View Open Client

Thu Jun 21, 2012 6:15 pm

You can also compile it yourself (I did).

Just follow the instructions on http://code.google.com/p/vmware-view-op ... /Compiling.
Also install libboost-all-dev package, before compiling.

G_LO
Posts: 1
Joined: Wed Jul 04, 2012 12:44 am

Re: Vmware View Open Client

Wed Jul 04, 2012 12:46 am

Awesome work, going to try it as well when time allows.

Is this just working the RDP portion of View or is it also doing the full PCoIP stream ?

deanbeasley
Posts: 7
Joined: Thu Jul 05, 2012 8:12 am

Re: Vmware View Open Client

Thu Jul 05, 2012 10:30 am

Hello everyone,

I took delivery of my pi on Monday, Debian Squeeze installed, runs great. Has anyone got noddy instructions on how to setup RD so I can connect to a Windows 7 machine? very keen to get this thin client pi setup asap.

Thanks in advance!

Dean

deanbeasley
Posts: 7
Joined: Thu Jul 05, 2012 8:12 am

Re: Vmware View Open Client

Sat Jul 14, 2012 10:33 am

Sorted

rashidkhan
Posts: 6
Joined: Thu Jul 19, 2012 7:35 pm

Re: Vmware View Open Client

Mon Sep 17, 2012 2:42 pm

Hello everyone,

I downloaded the file and used win32diskimager.exe to put it on a 32GB Sandisk Class 10 Ultraspeed 45Mbps SD card, it succeeded.

But when i insert in RPI and boot it starts to boot but after a while it keeps saying "mmc0: Timeout waiting for hardware interrupt."

Also everything is very very slow, i waited and waited untill literally about 5 hours i got to the shell prompt and i typed startx and then nothing happened.

I have also tried the Squeeze distro and Rasbmc as well and they do run fine but again slow, not quite as slow as the VMWare debain image.
Is this normal? is my RPI faulty? Please can anyone help?

Thanks

Donal
Posts: 3
Joined: Sun Oct 07, 2012 8:22 pm

Re: Vmware View Open Client

Sun Oct 07, 2012 8:37 pm

hello there just stumbled upon your video, as part of my uni project i'm going to use Vmware with a RPI as a dumb terminal and help or feedback you could give me would be much appreciated

sharrisct25
Posts: 3
Joined: Mon Dec 31, 2012 6:27 am

Re: Vmware View Open Client

Mon Jan 07, 2013 8:13 pm

Has anybody got the downloaded iso to work lately. I am not sure why but all the attempts I have made to get this result in either a unbootable SD card or a deb file that raspbian can not read. I have tired different clients for the download and different SD cards no dice.

hurns92
Posts: 1
Joined: Wed Jul 10, 2013 1:42 pm

Re: Vmware View Open Client

Wed Jul 10, 2013 1:45 pm

Need help got the magum pi on a sd card put it sarted it up the instruction that were given...

1) Write the Debian-VMware-View4.5.0.img to 2GB SD Card

2) Insert into Raspberry Pi

3) Login as pi (password is raspberry)

4) switch to superuser with sudo -s

5) use joe or vi to edit /root/.xinitrc

6) change the --ServerURL and --domainName then save the file

7) use joe or vi to edit /boot/cmdline.txt

8) Change the 3 at the end of the line to 5, this will start the GUI automatically at boot

9) restart the Pi, (halt, reboot, shutdown -r, etc.)

# For Troubleshooting change the 5 back to 3 in the cmdline.txt file by putting the card into a Win/Lin/MAC and start again :-)

Problem is how do i get line 5 to work. I am in sudo mode but it says "you don't have permission"

ctyjiuh
Posts: 1
Joined: Sat Jun 20, 2015 11:49 am

Re: Vmware View Open Client

Sat Jun 20, 2015 11:55 am

Hi
I've wrote the image to microSD card on Mac OS X:

Code: Select all

sudo dd bs=2m if=MagnumVmwareViewClient/Debian-VMware-View4.5.0.img of=/dev/rdisk1
and inserted to raspberry pi B+, but when I power it up, I got the black screen, red and green LED indicators are lighting and not blinking. What could be the reason?

md5 sum of Debian-VMware-View4.5.0.img: bd37983604163bb44110716565e74dca

mojimaleki
Posts: 6
Joined: Sun Apr 12, 2015 9:07 am

Re: Vmware View Open Client

Tue Sep 08, 2015 8:24 am

I downloaded Magnum project, but not load raspberry pi.

Please Help me.

Thanks

blackdoost
Posts: 1
Joined: Sat Jan 28, 2017 3:13 pm

Re: Vmware View Open Client

Sat Jan 28, 2017 3:16 pm

Yes
I downloaded Magnum project, but not load raspberry pi.

Please Help me.

Thanks

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 18 guests