giovani
Posts: 17
Joined: Fri Sep 06, 2013 6:38 am
Location: Rome, Italy
Contact: Website

Raspberry Pi CPU seems to Hang when running soffice.bin

Fri Dec 20, 2013 8:26 am

I have recently updated my Pi (apt-get update / upgrade / rpi-update) and this process also updated OwnCloud (for which my Pi is optimized for) from 5 to 6.0.0a.

From now on, when owncloud process starts, soffice.bin process uses nearly 100% cpu and the Pi stops responding (keyboard does not respond and ssh stops working). If I shutdown the power and restart, it becomes responsive again...until OwnCloud 6 starts working and using soffice.bin.

Any idea if CPU might be getting overloaded and causes this? Anyone using owncloud on the Pi with the same issue ? Thanks.

JF002
Posts: 94
Joined: Sat Feb 04, 2012 8:49 am
Contact: Website

Re: Raspberry Pi CPU seems to Hang when running soffice.bin

Sat Dec 21, 2013 9:16 am

soffice.bin seems to be related to OpenOffice, and not to Owncloud...
I searched for "soffice.bin" in google and found a lot of entries about soffice.bin eating all the CPU and RAM.

Are you using OpenOffice on your pi?
My web site : https://codingfield.com

User avatar
DougieLawson
Posts: 35814
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Raspberry Pi CPU seems to Hang when running soffice.bin

Sat Dec 21, 2013 11:31 am

The RPi doesn't have enough grunt to run open office or libre office. If you must run that resource hog stick to running it on windows.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

giovani
Posts: 17
Joined: Fri Sep 06, 2013 6:38 am
Location: Rome, Italy
Contact: Website

Re: Raspberry Pi CPU seems to Hang when running soffice.bin

Sat Dec 21, 2013 6:11 pm

Hi JF002 and DougieLawson,

No I am not running OpenOffice/LibreOffice directly on the Pi, only OwnCloud.

But looking at http://doc.owncloud.org/server/6.0/admi ... eview.html I found out that OwnCloud 6 can be installed using OpenOffice libraries to show thumbnail previews.

Since I have installed OwnCloud using the Linux Package from http://owncloud.org/install/ I think this package has OpenOffice libraries as dependencies by default. I checked apt log and in fact those were installed in the upgrade process.

To solve my Pi hanging every time OwnCloud started, I added

Code: Select all

  'enable_previews' => false,
to my owncloud.conf file to disable previews and it seems all fine again (the icons now do not show the file thumbnails, but who cares ;-) ? )

Return to “Networking and servers”