Page 2 of 2

Re: isc-dhcp-server fails to start.

Posted: Fri Aug 24, 2018 8:12 pm
by monapi
mfa298 wrote:
Wed Aug 22, 2018 8:27 am
monapi wrote:
Tue Aug 21, 2018 6:00 am
to use the tutorial i said before and when i see the dhcp status it says fail but when i change wlan0 to up i raspberry pi can give IP to my phone but both of them can't connect to the internet. i need internet on my pi is sth wrong? how can i solve it?
Are you trying to share internet from your phone to the Pi? If so this is probably the wrong way to do it, you would do better setting your phone as a hotspot and then connecting the pi to that.

no i want to share internet from pi to my phone or other devices. for this whats wrong with what i have done?

Re: isc-dhcp-server fails to start.

Posted: Sun Aug 26, 2018 9:10 am
by mfa298
monapi wrote:
Fri Aug 24, 2018 8:12 pm
... for this whats wrong with what i have done?
Looking at your other posts it looks like you've hijacked several threads trying to get help on the same subject - with some of the threads doing similar things but in different (and potentially incompatible) ways.

I'd suggest creating a new thread with details of what you're actually trying to do and what things you've started to setup.

Re: isc-dhcp-server fails to start.

Posted: Sun Aug 26, 2018 9:44 am
by monapi
mfa298 wrote:
Sun Aug 26, 2018 9:10 am
monapi wrote:
Fri Aug 24, 2018 8:12 pm
... for this whats wrong with what i have done?
Looking at your other posts it looks like you've hijacked several threads trying to get help on the same subject - with some of the threads doing similar things but in different (and potentially incompatible) ways.

I'd suggest creating a new thread with details of what you're actually trying to do and what things you've started to setup.
ok ,i'll do it.
thanks

Re: isc-dhcp-server fails to start.

Posted: Sun Nov 11, 2018 6:08 am
by vlahx
Hello,
I had a similary problem when i configured my RPI as a AC.
I think, the solution is as:
Try to stop or disable the preinstalled dhcpcd client because not, you cannot configure some interfaces in /etc/network/interfaces.
configure the wlanx in interfaces as ip-address and broadcast

auto wlanx # that means wlanx start on boot put the number what you have instead x. Usually is wlan0
iface wlanx inet static
ip-adrress=10.10.10.1/24 #as example. that 24 is for netmask as bellow defined
netmask-=255.255.255.0 #that means the network class is between 10.10.10.1 to 10.10.10.255
broadcast=10.10.10.255
#you dont need to configure gateway
network=10.10.10.0

#you must configure the eth0 interface here as static ip because you have not dhcpcd for autoconnect to another server or somewhere to #internet. I think, except is the connection is ppoe
#at last you must modify in dhcpd.conf the INTERFACES="wlanx", not eth0, because wlanx offer connections to other devives as your phone. If not, the phone cannot get an ip-address from your RPI as server.

I hope that help !

Re: isc-dhcp-server fails to start.

Posted: Sun Feb 17, 2019 7:35 am
by JGwinner
What's odd, is if I edit

Code: Select all

/etc/dhcp/dhcpd.conf 
and add the lines:

Code: Select all

interface wlan0
    static ip_address=10.40.5.110/26
    nohook wpa_supplicant
I get an error:

Code: Select all

[email protected]:~ $ dhcpd -t
Internet Systems Consortium DHCP Server 4.3.5
Copyright 2004-2016 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
/etc/dhcp/dhcpd.conf line 59: expecting a declaration

^
Configuration file errors encountered -- exiting
exiting.
If I take those lines out, dhcpd -t works fine, but wlan0 has no IP at all.

== John ==