mrcranky
Posts: 9
Joined: Fri Dec 28, 2012 8:27 pm

Hamachi Problems

Thu Oct 03, 2013 4:18 pm

Hi,

I'm trying to install Hamachi, and I get the following error:

Setting up logmein-hamachi (2.1.0.119-1) ...
mknod: `/dev/net/tun': File exists
update-rc.d: using dependency based boot sequencing
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachiSegmentation fault
failed!


-I followed the lifehacker article (http://lifehacker.com/5978098/turn-a-ra ... ere-you-go)
-I tried the armhf.deb
-I also tried the armel.deb using the instructions to force-architecture
-I'm using the latest Raspian from the latest Noobs.

With both installations, I get the same error.

I was hoping to find an archive of older versions of Hamachi that worked for others, but I couldn't find any on the logmein website

Any suggestions to get this working would be appreciated.

Thanks!

john564
Posts: 80
Joined: Tue Oct 30, 2012 7:05 am

Re: Hamachi Problems

Thu Oct 03, 2013 5:42 pm

It should work on this image
http://mirror.bytemark.co.uk/raspberryp ... ezy-armel/

you can do "sudo apt-get update" but don't do upgrade
Last edited by john564 on Fri Oct 04, 2013 7:53 am, edited 1 time in total.

mrcranky
Posts: 9
Joined: Fri Dec 28, 2012 8:27 pm

Re: Hamachi Problems

Thu Oct 03, 2013 5:57 pm

john564 wrote:It should work on this image
http://mirror.bytemark.co.uk/raspberryp ... ezy-armel/

you can do "sudo apt-get update" but don't do uprade
Thanks for the link, but I'm a bit paranoid about using images from unknown sources. How do I know that the image is safe & not malicious in any way?

Houser
Posts: 6
Joined: Fri Oct 04, 2013 3:49 am

Re: Hamachi Problems

Fri Oct 04, 2013 3:53 am

I have the EXACT same problem, and have tried everything you have tried. I either get Illegal Instruction or Segmentation Fault when the Hamach daemon executes.

I will try the above suggestion, but download the image from the regular repo and not do the apt-get upgrade. We will see how it goes.

txt3rob
Posts: 365
Joined: Sat Aug 11, 2012 3:45 pm
Contact: Website

Re: Hamachi Problems

Fri Oct 04, 2013 7:42 am

The Raspberry Pi Hell Guy - Random Ramblings to assist me and others.
http://raspberrypihell.blogspot.com
My Github - http:/www.github.com/random-robbie/
http://www.smspi.co.uk - send free uk sms via your raspberry pi from here

Houser
Posts: 6
Joined: Fri Oct 04, 2013 3:49 am

Re: Hamachi Problems

Fri Oct 04, 2013 4:07 pm

No good. I have reimaged Raspian, both directly (latest version from Sept 2013) and using NOOBS (a few months old).
Whatever I do, when Hamachi tries to launch I still get Illegal Instruction or Segmentation Fault. I also get an error when setting up lsb, about the symlink for armhd not found, but I have no idea where this symlink should be, or if it even a problem.

Sucks to be new to the Pi/Linux right now foe me. :(
Houser wrote:I have the EXACT same problem, and have tried everything you have tried. I either get Illegal Instruction or Segmentation Fault when the Hamach daemon executes.

I will try the above suggestion, but download the image from the regular repo and not do the apt-get upgrade. We will see how it goes.

mrcranky
Posts: 9
Joined: Fri Dec 28, 2012 8:27 pm

Re: Hamachi Problems

Fri Oct 04, 2013 5:02 pm

Houser wrote:No good. I have reimaged Raspian, both directly (latest version from Sept 2013) and using NOOBS (a few months old).
Whatever I do, when Hamachi tries to launch I still get Illegal Instruction or Segmentation Fault. I also get an error when setting up lsb, about the symlink for armhd not found, but I have no idea where this symlink should be, or if it even a problem.

Sucks to be new to the Pi/Linux right now foe me. :(
Yeah, I just did the same thing as you minutes ago and had no luck. I tried both the armel and the armhf packages. It looks like I might look for another VPN solution.

If I find something, I'll report back.

mrcranky
Posts: 9
Joined: Fri Dec 28, 2012 8:27 pm

Re: Hamachi Problems

Sat Oct 05, 2013 3:35 pm

I did some more research, and decided to skip Hamachi and go for OpenVPN. If you go this way, just remember that you will have to do port forwarding on your router to the Raspberry Pi.

This is the tutorial that I'm using.

http://raspberrypihelp.net/tutorials/1- ... r-tutorial


I'm doing it at work (and am planning to use this at home) so I stopped the tutorial once I needed to set the IP address of my Pi. I'm going to finish this at home in a few days. So far, the directions have worked flawlessly. The only thing different that I did was run sudo rpi-update since I read that it was needed.

I'll report back next week once (and if) I have this up & running.

hrabeX
Posts: 13
Joined: Mon Apr 08, 2013 8:04 am

Re: Hamachi Problems

Sat Oct 05, 2013 8:59 pm

Same problem here. Segmentation fault on 2013-09-25-wheezy-raspbian clean image. Never had this problem before. Any ideas, please?

Houser
Posts: 6
Joined: Fri Oct 04, 2013 3:49 am

Re: Hamachi Problems

Sat Oct 05, 2013 9:17 pm

Operating on the theory that version 119 of Hamachi is the problem, I sent an email to the feedback email address at https://secure.logmein.com/labs. I'll post any reply I get here.

hrabeX
Posts: 13
Joined: Mon Apr 08, 2013 8:04 am

Re: Hamachi Problems

Sun Oct 06, 2013 8:46 am

You're right! Previous version of hamachi is working with no problems. Thanks for the tip!
link: https://www.dropbox.com/s/b3qmefk60n7ng ... -armel.tgz

Houser
Posts: 6
Joined: Fri Oct 04, 2013 3:49 am

Re: Hamachi Problems

Mon Oct 07, 2013 2:44 pm

Used the older version from the Dropbox account, (unpacked it and ran sudo bash install.sh) and Hamachi was installed. Now trying to configure it.

Version 119 was the problem.

john564
Posts: 80
Joined: Tue Oct 30, 2012 7:05 am

Re: Hamachi Problems

Tue Oct 08, 2013 12:39 am

Houser wrote:Used the older version from the Dropbox account, (unpacked it and ran sudo bash install.sh) and Hamachi was installed. Now trying to configure it.

Version 119 was the problem.
What Raspberry OS are you using,
I have trouble installing lsb lsb-core in any HF Raspbian after May-2013

the Soft-float Raspbian was fine, but now raspberrypi.org remove torrent trackers for older versions of Soft-Float

Houser
Posts: 6
Joined: Fri Oct 04, 2013 3:49 am

Re: Hamachi Problems

Tue Oct 08, 2013 4:50 am

What Raspberry OS are you using,
I have trouble installing lsb lsb-core in any HF Raspbian after May-2013

the Soft-float Raspbian was fine, but now raspberrypi.org remove torrent trackers for older versions of Soft-Float[/quote]

---
I've currently been using the Mame build (for gaming). I exit to the command prompt, type StartX, and I'm back to the standard Raspian and LXTerminal. But I have never had any issues doing lsb and lsb-core on any of the other builds I've used, including the latest wheezy Raspian and NOOBS.

Currently I've got Hamachi installed and I followed the directions up to the 'join' part, but it keeps saying Network not Found when I do a sudo hamachi join 123-456-789 (the client id). Can't figure it out.

txt3rob
Posts: 365
Joined: Sat Aug 11, 2012 3:45 pm
Contact: Website

Re: Hamachi Problems

Tue Oct 08, 2013 8:45 am

dropbox link isnt working for me downloads a empty file tried with winrar and 7zip.
The Raspberry Pi Hell Guy - Random Ramblings to assist me and others.
http://raspberrypihell.blogspot.com
My Github - http:/www.github.com/random-robbie/
http://www.smspi.co.uk - send free uk sms via your raspberry pi from here

john564
Posts: 80
Joined: Tue Oct 30, 2012 7:05 am

Re: Hamachi Problems

Tue Oct 08, 2013 1:15 pm

txt3rob wrote:dropbox link isnt working for me downloads a empty file tried with winrar and 7zip.
here is another way

Code: Select all

 sudo wget https://dl.dropboxusercontent.com/u/140578/logmein-hamachi_2.1.0.86-1_armel.deb

jnash67
Posts: 1
Joined: Wed Oct 09, 2013 11:37 pm

Re: Hamachi Problems

Wed Oct 09, 2013 11:43 pm

I've been having the same problem the last few frustrating days. Tried Hamachi on raspbian, arch, and pidora, all unsuccessfully.

Turns out, the problem is with the latest version of Hamachi, 119. You need to get hold of an earlier version, 86. Fortunately, the link at the very bottom of this chain from last year still works:

Code: Select all

sudo wget https://dl.dropboxusercontent.com/u/140578/logmein-hamachi_2.1.0.86-1_armel.deb
Load it into raspbian, do a:

Code: Select all

sudo dpkg -i logmein-hamachi_2.1.0.86-1_armel.deb 
and it works great as per the lifehacker article.

mrcranky
Posts: 9
Joined: Fri Dec 28, 2012 8:27 pm

Re: Hamachi Problems

Thu Oct 10, 2013 12:17 am

Hi, I just want to say that I ended up going with OpenVPN. It took about an hour or so to get it working.

And, even though I didn't use it, thanks for posting the link to the older (working) version of Hamachi.

maletced
Posts: 1
Joined: Sat Oct 12, 2013 9:06 pm

Re: Hamachi Problems

Sat Oct 12, 2013 9:10 pm

Hi have the same probleme,
have you got any "ARM HF" version ?
the logmein-hamachi_2.1.0.119-1_armhf.deb doesn't works!

Cédric

vincentjanv
Posts: 12
Joined: Sun Oct 28, 2012 11:26 am

Re: Hamachi Problems

Sat Oct 26, 2013 8:29 am

maletced wrote:Hi have the same probleme,
have you got any "ARM HF" version ?
the logmein-hamachi_2.1.0.119-1_armhf.deb doesn't works!

Cédric
You need to force it,

Code: Select all

sudo dpkg --force-architecture --force-depends -i logmein-hamachi_2.1.0.119-1_armhf.deb

txt3rob
Posts: 365
Joined: Sat Aug 11, 2012 3:45 pm
Contact: Website

Re: Hamachi Problems

Tue Oct 29, 2013 11:17 am

working commands:

http://raspberrypihell.blogspot.co.uk/2 ... ry-pi.html

i actually used this today as well to do a fresh install.
The Raspberry Pi Hell Guy - Random Ramblings to assist me and others.
http://raspberrypihell.blogspot.com
My Github - http:/www.github.com/random-robbie/
http://www.smspi.co.uk - send free uk sms via your raspberry pi from here

jdb12
Posts: 1
Joined: Sat Aug 02, 2014 1:32 am

Re: Hamachi Problems

Sat Aug 02, 2014 1:35 am

I'm not sure how many people are still looking at this thread, but I think I found an answer. I was having this problem when I installed Raspbian today (08/01/2014), and I got the Segmentation fault error. I was able to get a working version of Hamachi by following the instructions found here: http://raspberrypihell.blogspot.co.uk/2 ... ry-pi.html. Hope this helps!

CTassisF
Posts: 2
Joined: Thu May 16, 2013 5:07 am

Re: Hamachi Problems

Sat Aug 16, 2014 10:03 pm

LogMeIn just released a new version of Hamachi and it works fine on my Raspbian (without Illegal Instruction or Segmentation Fault errors).

You can download it here: https://secure.logmein.com/labs/#HamachiforLinux

César

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 8 guests