User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:26 pm

This is probably the problem:
Microsoft wrote:If you are trying to configure Connection Sharing manually for a connection, make sure that the home network adapter does not have ICF enabled. If ICF is enabled, you must either disable it before you can configure Connection Sharing on the external connection or use the Network Setup Wizard to enable ICS. The wizard disables ICF on home networking interfaces.
So:
To open Network Connections, click Start, click Control Panel, click Network and Internet Connections, and then click Network Connections.
Click the Ethernet connection, and then, under Network Tasks, click Change settings of this connection.
On the Advanced tab, under Internet Connection Firewall, clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.

That still leaves the firewall in place on your WiFi connection, so you are still protected.

Try that and then do the "traceroute 194.168.8.100" again.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:30 pm

it should be 194.168.8.100 that was bad info on my behalf i was trying to set up a ftp server at the same time lol

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:32 pm

i think he really needs to start a fresh with the pi install he has changed so many things and aslo start over with all the things he has also changed on the network connections

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:35 pm

thats very kind of you and i will call you up on that if i dont fix it, and arrange a more convenient time

really appreciate the help, i feel i will get there very soon so close, am gonna dance around the room :D

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:35 pm

dasimpson wrote:i touch nothing on the rpi at all when i connect thru my laptop and use ics
Unfortunately that will not work in this case. There are real reasons for that. We know exactly why ICS doesn't just work out of the box, and we have got it almost working. The set-up of your working Pi will not help Devon Mafia, because his router conflicts with ICS, Microsoft did not make ICS configurable, and he can't change his router. But yours worked first time, so you do not have the same problems that he has.
i think he really needs to start a fresh with the pi install he has changed so many things and aslo start over with all the things he has also changed on the network connections
That was my thought too, until he got ssh working. Now I can see light at the end of the tunnel. His routes are correct, but Windows is not responding to pings. That is almost certainly a firewall issue, hence my previous post.
am gonna dance around the room
We will require pictures, nay video. :-D

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:39 pm

the only things that can stop ics is his cimputer the router wont change anything with that
his router has the standerd gateway ip of 192.168.0.1
so that ant a problem the problem is in the order you do things pi not on when setting ics it wont work pi on and set ics it will work but you then have to rebout the pi if you dont you will just keep getting conflicts

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:46 pm

dasimpson wrote:it should be 194.168.8.100 that was bad info on my behalf i was trying to set up a ftp server at the same time lol
Right you are, I misread it: I've edited my last post. It actually doesn't change things, since it didn't get as far as the Windows box, let alone the router.
the only things that can stop ics is his cimputer the router wont change anything with that
Incorrect. His router hands out addresses in 192.168.0.x, that is the same network that ICS uses by default. So both NICs on the Windows box end up configured to use the same network and Windows can't route any traffic, not even its own. In fact the Ethernet is the lowest cost route, so all the Internet traffic goes to the Pi. The result is that the Windows box can not see the Internet.

We fixed that by changing the IP address of the Ethernet NIC to 10.0.0.1. However because ICS is unconfigurable, we cannot use its DHCP server, so the Pi has to have a static IP address (10.0.0.2). All this is now working.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:49 pm

well that is very odd i connect to routers all the time that have 192.168.0.1 as gateway and use ics to my pi i do this at home frinds cybercafes etc and works with out a problem

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:53 pm

I could leave my cam recording when i am close :D

there is no 'Network Tasks' when i click the ethernet connection icon box, i turned the firewall off but i couldnt find any option that said change settings of this connection...although it does remember i have switched the firewall off

also this is what cmd ipconfig/all is saying, i put thos ip addresses in dns settings in the box where i used a manual ip address 10.0.0.1 in ethernet icon box thing.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:56 pm

yeah the 2 dns ip are 194.168.4.100 and 194.168.8.100

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:57 pm

oops forgot to send

Code: Select all

Ethernet adapter Ethernet:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
        Physical Address. . . . . . . . . : 00-21-85-47-B2-C8
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 10.0.0.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : 192.168.8.100
                                            192.168.4.100

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 10:59 pm

yeah change the 192 to 194

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:00 pm

Ruddy Microsoft. Can't even trust them to be right about their own damn OS. I can't check it here at home; I don't have an XP box.

Fortunately back on page 2 we have the right procedure; it'll be this one:
  1. Click Start, and then click Control Panel.
  2. Click Network and Internet Connections, Click Network Connections.
  3. Right-click the connection that you use to connect to the Raspberry Pi. This will be the Ethernet interface.
  4. Click Properties.
  5. Click the Advanced tab.
  6. Under Internet Connection Firewall, clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.
  7. Click OK
  8. Click OK
Log in to the Pi over ssh and try the "traceroute 194.168.8.100" again.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:04 pm

forget about the firewall for a sec and use the correct ip lol might of been the wrong ip that was the prob

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:10 pm

dasimpson wrote:well that is very odd i connect to routers all the time that have 192.168.0.1 as gateway and use ics to my pi i do this at home frinds cybercafes etc and works with out a problem
Windows XP is uniquely unconfigurable. Even Windows 95 allowed you to change the IP address; XP does not. I googled a lot and then tested it on my XP laptop at work. I know that what I say is the truth. I also know that at least two Microsoft Knowledgebase articles on the matter are badly flawed.

I was a network administrator back in 1990 when Ethernet meant coxial cable, and I am one now. I do know what I am talking about.

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:11 pm

dasimpson wrote:forget about the firewall for a sec and use the correct ip lol might of been the wrong ip that was the prob
No it was not.
If it had been the wrong IP then at least the Windows PC and the router would have replied.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:13 pm

no cos your traceing a route to witch they is no end a trace only ends if it finds what it is looking for

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:16 pm

and in sudo nano /etc/resolv.config? you wont to set the name server to 194.168.4.100

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:23 pm

no cos your traceing a route to witch they is no end a trace only ends if it finds what it is looking for
The Pi has a default route to the Windows box. The windows box has a default route to the router. That is all they know. The router may, but probably doesn't, know that the IP address doesn't exist. The next machine probably does know, so the trace would end there. So you would get a response from the Windows box and the router but no further.

On my Pi, without a Windows box in the way, it looks like this:

Code: Select all

pi@raspberrypi ~ $ traceroute 192.168.8.100
traceroute to 192.168.8.100 (192.168.8.100), 30 hops max, 60 byte packets
 1  192.168.0.1 (192.168.0.1)  1.259 ms  1.396 ms  1.653 ms
 2  * * *
 3  * * *
 4  * * *
...
 
A response from the router.


User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:28 pm

One thing at a time. We don't need the nameserver until we get the traceroute working. We'll need those nameservers in eventually, but the traceroute doesn't depend on the nameserver because we're giving it the IP address.

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:29 pm

why is sudo nano /etc/resolv.config now empty? it wasnt a few hours ago!!

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:29 pm

me not knowing what imk talking about also just noticed this
pi@raspberrypi ~ $ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 10.0.0.1 0.0.0.0 UG 0 0 0 eth0
10.0.0.0 * 255.255.255.0 U 0 0 0 eth0
now if im right in thinking dosent that mean the rpi has an ip adress befor the gateway ip meaning it is out of rang of the asigned ip range just putting it out there considering i am untrined and am just a self tourt persion

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:30 pm

this is why i said start clean and i will walk you thru it considering i have this working with router gateway ip of 192.168.0.1 pc ip of 102.169.0.101
isc connection i[p 192.168.0.1 pi ip of 192.168.0.154
the more time i connect the pi the lower the last number seems to get

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Sun Feb 17, 2013 11:33 pm

so i put this into trace route

Code: Select all

pi@raspberrypi ~ $ traceroute 192.168.8.100
traceroute to 192.168.8.100 (192.168.8.100), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
pi@raspberrypi ~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.0.0.1        0.0.0.0         UG    0      0        0 eth0
10.0.0.0        *               255.255.255.0   U     0      0        0 eth0
pi@raspberrypi ~ $ traceroute 192.168.4.100
traceroute to 192.168.4.100 (192.168.4.100), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
pi@raspberrypi ~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.0.0.1        0.0.0.0         UG    0      0        0 eth0
10.0.0.0        *               255.255.255.0   U     0      0        0 eth0
pi@raspberrypi ~ $
is that right? i put the 194.168.8.100 numbers in dns in ethernet icon thing on windows box

cmd has this to say in ipconfig/all

Code: Select all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : Devonrevenge
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 802.11b/g Mini Car

        Physical Address. . . . . . . . . : 00-1D-92-C9-80-AF
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.0.16
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1
        DHCP Server . . . . . . . . . . . : 192.168.0.1
        DNS Servers . . . . . . . . . . . : 194.168.4.100
                                            194.168.8.100
        Lease Obtained. . . . . . . . . . : Sunday, February 1
M
        Lease Expires . . . . . . . . . . : Sunday, February 1
M

Ethernet adapter Ethernet:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek PCIe FE Fa
        Physical Address. . . . . . . . . : 00-21-85-47-B2-C8
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 10.0.0.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : 192.168.8.100
                                            192.168.4.100

Return to “Networking and servers”